[Résolu] Pas d’accès à mon wordpress local sous xampp (Créer un compte)

  • WordPress :5.4
  • Statut : résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2343048
    dthz
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    Ma configuration WP actuelle 5.4.1 (Xampp 3.2.4)

    • Version de PHP/MySQL : 7.3/5.6
    • Thème utilisé : generatedpress
    • Extensions en place : Photo Gallery, UberMenu3, Wordfence Security.
    • Nom de l’hébergeur : OVH
    • Adresse du site : danielthizy.fr

    Problème(s) rencontré(s) : Je souhaite rapatrier mon site en local.

    – J’ai rapatrié tout les fichiers wordpress de mon site OVH et ma base de données.

    – J’ai installé Xampp, + WordPress dans un dossier nommé “compostelle”.

    – Supprimé tous les fichiers du WordPress local

    – Supprimé la base locale présente dans wordpress et créé ma propre base dans laquelle j’ai importé celle d’OVH.

    – Modifié le wp-config.php:
    DB-NAME
    DB-USER: root
    DB-PASSWORD: vide
    DB-HOST: Localhost

    – Pour modifier les URL j’utilise le script d’Interconnectit “Search and Replace master” (SRDB-master).
    Je tape: Localhost/compostelle/SRDB-master/
    qui me répond: erreur Ajax.
    J’ai passé le module conseillé par SRDB-master “srdb.cli.php” qui me donne le résultat suivant (cf fichier joint) que je suis incapable d’exploiter car ne connaissant pas PHP.

    Quelqu’un peut-il m’aider ? Merci d’avance.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2343056
    ferman
    Participant
    Maître WordPress
    2513 contributions

    Bonjour,

    Je ne peux pas répondre à vos questions mais simplement vous dire comment j’utilise XAMPP.

    1. XAMPP est installé directement dans c:/xampp. (c’est recommandé)
    2. Dans htdocs j’ai créé une fois pour toutes mon dossier site (en fait plusieurs) avec le même nom que le site. (pour vous  ” danielthizy”)
    3. Dans phpmyadmin j’ai créé une base de données, nommée comme la base du site en ligne pour plus de commodité.
    4. A chaque fois que je veux faire une copie en local, par ftp je copie directement les dossiers du site enligne sur mon PC. Cela fait une sauvegarde du site
    5. Je  copie ensuite dans “monsite” local, modifie .htaccess (j’enlève les redirections s’il y en a) et wp config.
    6. J’importe ma base de données et change manuellement les url site et wordpress (premières lignes wp-options). Pour vous de  http: //www.danielthizy.fr en http: //localhost/danielthizy. Ce qui donne accès à l’admin de wordpress.
    7. Je télécharge l’extension “better search replace” et remplace tous les liens pour vous  http: //www.danielthizy.fr par http: //localhost/danielthizy.

    Ce n’est peut-être pas la meilleure méthode mais ça a toujours marché sans le moindre problème.

    Note. Vous savez que pour que XAMPP fonctionne parfaitement, il y a quelques paramètres à modifier à la fois dans les dossiers apache et dans mysql. Si vous en avez besoin je vous les passerai. Autrement il peut y avoir des problèmes (essentiellement d’importation dans la BDD en cas de tables importantes)

     

     

     

    • Cette réponse a été modifiée le il y a 2 semaines et 2 jours par ferman.
    #2343079
    dthz
    Participant
    Initié WordPress
    3 contributions

    Bonjour ferman,
    1- Xampp est effectivement installé sous C:\
    2- Je n’ai pas modifié le nom de mon dossier compostelle ni le nom de ma BdD, mais vos explications m’ont été d’un grand secours en me permettant de mieux comprendre.
    3- Mon .htaccess n’a rien de singulier.
    4- J’ai modifié manuellement les 2 premières lignes de wp-options.
    5- J’ai téléchargé et utilisé le plugin “better search replace” que je ne connaissais pas, sans cocher la case “Remplacer les GUID?”
    Tout à l’air de fonctionner pour le mieux maintenant !
    Par contre, je suis preneur du paramétrage de Xampp car je n’ai pas vu où il était possible de le paramétrer…
    Encore merci pour votre aide précieuse. dthz.

    • Cette réponse a été modifiée le il y a 2 semaines et 1 jour par dthz.
    #2343107
    ferman
    Participant
    Maître WordPress
    2513 contributions

    Bonjour,

    Les renseignements sont en pièce jointe.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2343119
    dthz
    Participant
    Initié WordPress
    3 contributions

    Merci  ferman,

    J’ai fait le nécessaire au cas où. dthz.

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.