Pas accès portail Admin + aucun site trouvé depuis compte wordpress (Créer un compte)

  • WordPress :5.7
  • Statut : non résolu
  • Ce sujet contient 10 réponses, 2 participants et a été mis à jour pour la dernière fois par ferman, le il y a 2 minutes.
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #2377123
    Zabouj59
    Participant
    Initié WordPress
    6 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :  7.0 / 1
    • Thème utilisé : Sydney
    • Extensions en place : WordFence, …
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://agilegap-conseil.fr/

    Problème(s) rencontré(s) : Bonjour, quand je veux rejoindre le portail pour me connecter sur mon compte administrateur, je tombe sur une page d’échec. Quand je me connecte sur mon compte WordPress, il y a marqué que je n’ai crée aucun site alors que si. Je souhaite accéder a mon compte administrateur pour faire quelques modifications et mise à jours.

    #2377131
    ferman
    Participant
    Maître WordPress
    3981 contributions

    Bonjour,

    Cela peut venir de wordfence selon la manière dont il est réglé. Par FTP, renommez le dossier wordfence en wordfence-x. Avez-vous donné par erreur un mauvais identifiant lors d’une tentative de connection (même une fois)? Avez-vous  d’autres extensions de sécurité à part wordfence?

    • Cette réponse a été modifiée le il y a 3 jours et 1 heure par ferman.
    #2377283
    Zabouj59
    Participant
    Initié WordPress
    6 contributions

    Bonjour, je ne peux pas renommez le dossier wordfence car je n’ai pas accès à l’administration du site.

    https://agilegap-conseil.fr/wp-admin  montre une page non trouvée (j’ai fait la page qui apparait).

    Il me semble qu’il y ait eu une tentative de connexion réussi qui ne provenait pas de moi.

    Pou résoudre le problème, pensez-vous que je dois supprimer le module existant et en refaire un nouveau depuis l’interface module en 1 clic d’ovh?

     

     

    #2377346
    ferman
    Participant
    Maître WordPress
    3981 contributions

    Bonjour,

    Bien sûr que vous n’avez pas accès à l’administration (c’est le titre de votre sujet). Dans ce cas il vous faut procéder autrement (par FTP).  Il n’y a pas moyen de faire autrement. Pour cela il vous faudra deux outils: Filezilla (un logiciel, explications ICI) et Notepad++ (un éditeur de textes) .

    Avec Filezilla, muni des identifiant et mot de passe FTP donnés par votre hébergeur vous aurez accès aux dossiers de votre site chez l’hébergeur  et donc au dossier Wordfence que vous pourrez renommer. Notepad++ n’est pas utile ici mais il sera sans doute utile en d’autres occasions. Si renommer le dossier vous redonne accès à l’administration et une fois  dans cette administration, vous pourrez redonner au dossier wordfence son nom d’origine puis regarder dans les réglages du plugin: il doit y avoir un mauvais identifiant sur liste noire, à effacer pour débloquer.

    #2377380
    Zabouj59
    Participant
    Initié WordPress
    6 contributions

    Bonjour, j’ai installé Filezilla et j’ai suivi la vidéo tutoriel.

    Après avoir entré, l’adresse FTP dans hôte, l’identifiant et le mot de passe associé, je suis parvenu a me connecter mais que en port 21.

    J’ai essayé de renommer le dossier wordfence en wordfence-x mais sans résultats. (Quand je rentre “https://agilegap-conseil.fr/wp-admin/”, je tombe encore sur une page que j’ai crée sur mon site pour les pages introuvables.)

    Les autres plugins du sites sont: (dans wp-content/plugins/…)

    akismet/coming soon/contact form 7/cookie notice/formidable/google analytics for wordpress/one click demo import/ site origin panels/so widget bundle/ ssl insecure content fixer/ syndey toolbox/ updraftplus/wordfence-x/wordpress-seo/wps-hide-login

    Avez vous d’autres idées pour débloquer la situation?

    Merci de votre aide en tout cas 🙂

    #2377383
    ferman
    Participant
    Maître WordPress
    3981 contributions

    Bonjour,

    Ne vous occupez pas pour le moment des autres extensions. Wordfence peut vous bloquer de différentes manières (par ip, par id). En particulier,il est possible de le régler pour que le fait d’entrer un mauvais identifiant vous bloque immédiatement.

    Il y a plusieurs pages de documentation Wordfence  sur le web. Par exemple ici, ici et bien d’autres. Dans le deuxième lien, je regarderais  en priorité cette possibilité.

    “lockout-invalid-user”>Immediately lock out invalid usernames
    This option will immediately lock out someone who attempts to log in with an invalid username. Please note that your real users may mistype their usernames. This will cause them to get locked out, which is an inconvenience. We recommend enabling this feature for sites that have a low number of users such as 1-2 admins and/or a possibly a few editors. If a legitimate user is locked out you can find and delete any currently active block on the Wordfence Firewall > Blocking page.

    Pour le déblocage regardez aussi  cette page de doc.

     

     

    • Cette réponse a été modifiée le il y a 6 heures et 33 minutes par ferman.
    #2377410
    Zabouj59
    Participant
    Initié WordPress
    6 contributions

    Je n’ai pas compris comment je peux modifier les paramètres de WordFence sans avoir accès a mon site.

    J’ai regardé dans les fichiers de mon site par FTA avec NotePad++, j’y ai trouvé pleins de fichier dont le fichier blacklist mais je ne trouve pas d’utilisateurs bloqués, juste l’interface codé de wordfence sur ma page admin.

    Je crois que je vais juste supprimer mon site et en refaire un nouveau, repartir de 0.

    #2377413
    Zabouj59
    Participant
    Initié WordPress
    6 contributions

    J’ai réussi a accéder au portail administrateur et a me connecter en tant qu’admin en mettant -x après Plugins et Thèmes en FTP

    #2377417
    ferman
    Participant
    Maître WordPress
    3981 contributions

    Maintenant, il faut renommer les dossiers thèmes et plugins (renommer ne réactive rien)  et réactiver un par un depuis votre administration . Commencez par les plugins et d’abord par wordfence, en vérifiant à chaque fois que vous pouvez vous déconnecter puis vous reconnecter. Cela vous donne le plugin responsable. vous le re-désactivez, entrez dans votre administration et activez tout le reste. Ensuite il faudra essayer de voir ce qui ne va pas avec le plugin coupable.

    • Cette réponse a été modifiée le il y a 1 heure et 57 minutes par ferman.
    #2377426
    Zabouj59
    Participant
    Initié WordPress
    6 contributions

    Le problème vient de l’extension suivante:

    WPS Hide Login: Protégez votre site Web en changeant l’URL de connexion et en empêchant l’accès à la page wp-login.php et au répertoire wp-admin aux personnes non-connectées.

    Est-ce que c’est utile pour mon site ou je peux le supprimer?

    • Cette réponse a été modifiée le il y a 1 heure et 28 minutes par Zabouj59.
    #2377437
    ferman
    Participant
    Maître WordPress
    3981 contributions

    Avec wordfence installé je pense que vous n’avez pas besoin d’un deuxième plugin de sécurité donc, oui, vous pouvez supprimer wps hide login s’il pose problème. Vous pouvez aussi regarder les réglages de wps hide login et voir s’il est correctement paramétré.

    • Cette réponse a été modifiée le il y a 1 minute par ferman.
    • Cette réponse a été modifiée le il y a 17 secondes par ferman.
11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.