Pages pointent sur une erreur (Créer un compte)

  • Statut : non résolu
  • Ce sujet contient 20 réponses, 3 participants et a été mis à jour pour la dernière fois par Anonyme, le il y a 12 années et 2 mois.
15 sujets de 1 à 15 (sur un total de 21)
  • Auteur
    Messages
  • #508647
    mulanee
    Participant
    Chevalier WordPress
    101 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.3.2 FR
    – Version de PHP/MySQL : OVH ?
    – Thème utilisé : iFeature free
    – Extensions en place : postie -piwigomedia -db cache -TAC -wordpress data base backup -akismet etc…
    – Nom de l’hebergeur : OVH
    – Adresse du site : http://clemelis.net
    Problème(s) rencontré(s)
    :

    Bonjour,

    Quand je clique sur les liens 2 ou 3 ou 4 en bas de page, je tombe sur

    The requested URL /page.htm/2 was not found on this server.

    J’ai fait pointer wordpress sur / et non sur /wordpress, mais rien d’autre à signaler à part ça.

    Une idée?

    #828901
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #828902
    mulanee
    Participant
    Chevalier WordPress
    101 contributions

    Voilà mon .htaccess:

    SetEnv PHP_VER 5
    SetEnv REGISTER_GLOBALS 0

    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]


    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]


    # END WordPress

    Je n’ai pas déversé /wordpress dans / car ça fait un peu bazar et j’ai d’autres directories aussi au même endroit.
    L’erreur 404 arrive quand on clique en bas sur un numéro de page.
    J’ai installé via le manager d’OVH.
    Les permaliens par défaut, c’est à dire la syntaxe par défaut?

    #828903
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #828904
    mulanee
    Participant
    Chevalier WordPress
    101 contributions

    Merci de la réponse, j’ai supprimé le doublon du .htaccess
    J’ai trouvé le problème: wordpress ajoute les extensions qiuand ça lui parait utile et qu’il en trouve une sympa.
    Le /page de wordpress a été perturbé par une page.html qui était à ma racine et que j’ai renommé différemment.
    J’aurais du y penser j’avais déjà eu le soucis avec un contact.php

    #828905
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #828906
    mulanee
    Participant
    Chevalier WordPress
    101 contributions

    Ah oui au fait pourquoi prendre la syntaxe par défaut des permaliens?

    #828907
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #828908
    mulanee
    Participant
    Chevalier WordPress
    101 contributions

    En tout cas ça m’a mis le bazar avec tous mes permaliens.
    Après changement de la syntaxe dans les options du TDB, les permaliens n’ont eux pas bougé!!
    Les pages sont des pages issues de WP; au départ c’était des anciens .htm… transformés; ce n’est plus le cas

    #828909
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #828910
    mulanee
    Participant
    Chevalier WordPress
    101 contributions

    J’ai bidouillé mes pages moitié en code moitié en éditeur visuel; ce dernier n’est pas des plus pratiques!
    Maintenant ce sont des pages WP

    #828911
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #828912
    mulanee
    Participant
    Chevalier WordPress
    101 contributions

    Résultat pas terrible.
    http://clemelis.net/?page_id=156
    J’essaierai avec le plugin.

    #828913
    Philibert
    Participant
    Chevalier WordPress
    121 contributions

    Pour les permaliens, aller dans « Réglages/Permaliens » et choisir « Nom de l’article ».
    ou taper /%postname%/ dans le champ « Structure personnalisée ».

    #828915
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

15 sujets de 1 à 15 (sur un total de 21)
  • Vous devez être connecté pour répondre à ce sujet.