Pages 2 et 3 d’une catégorie qui redirige vers erreurs 404 (Créer un compte)

  • Statut : non résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #561269
    Melanie R
    Membre
    Initié WordPress
    13 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 4.4.2
    – Version de PHP/MySQL :
    – Thème utilisé : Modernize (par Goodlayer)
    – Extensions en place : aksimet, all in one SEO pack, backWPup, google XML, shareaholic, (15 extentions au total)
    – Nom de l’hebergeur : OVH
    – Adresse du site : http://www.gazette-d-une-future-maman.com

    Problème(s) rencontré(s) :

    Bonjour.

    Je vous remercie par avance du temps que vous allez me consacrer.

    Lundi, j’ai eu un plantage serveur. Je me suis retrouvée avec tout mon site inaccessible (erreur 404), alors que je n’avais ni installé de nouveau plugins, ni fait de mise à jour. J’avais juste publié un nouvel article. Par chance, j’avais une sauvegarde et j’ai remis mon blog sur les rails. Il y avait un problème au niveau de la table « post » dans ma BDD, j’ai donc re-uploader celle sauvegardée précédemment.

    J’ai eu quelques petits problèmes d’images qui n’apparaissaient plus, mais j’ai trouvé le problème ! Jamais d’accents dans les noms d’images (à présents je sais et j’apprends de mes erreurs). J’ai re-uploader les photos en modifiants les noms et tout avait l’air de rentrer dans l’ordre (je devais juste m’occuper de faire les redirections 301 sur les images qui avaient l’ancien noms). Brefs pour moi le problème était résolu.

    Mais apparemment, un autre est arrivé. En allant sur mon site, je viens de m’apercevoir que la page 2 et 3, d’une de mes catégorie redirigent vers une erreur 404, alors que je sais qu’il y a des articles à afficher. Je ne sais pas du tout de quoi cela pourrait venir.

    j’espère que vous m’avez compris.
    Avez vous une idée ?

    Bonne soirée à tous
    Et merci d’avance
    Mélanie

    #1048840
    Melanie R
    Membre
    Initié WordPress
    13 contributions

    Pour plus d’aide, voici le lien de la catégorie qui pose problème. Page 2 et 3 pointent vers une erreur 404 alors que des articles sont à afficher.

    http://www.gazette-d-une-future-maman.com/de-tout-de-rien/

    Merci d’avance
    Mélanie

    #1048841
    njaka41
    Participant
    Chevalier WordPress
    212 contributions

    Bonjour Mélanie R,
    Je vous conseille de bien vérifié le « query_post » celle qui gère la pagination. Ou bien de renomer la catégorie pour voir si c’est le nom qui porte problème.
    Bon courage

    #1048842
    Flobogo
    Modérateur
    Maître WordPress
    18599 contributions

    Bonjour,

    1ère piste : vous avez une autre catégorie « de tout de rien » sous « Grossesse & Co »* … il y a peut-être confusion.

    2ème piste : parfois, c’est tout bête et ça marche –> allez dans le menu Réglages > Permaliens, cliquez en bas sur « enregistrer » même sans changer aucun réglage, et testez …

    * A propos de l’item Grossesse & Co dans votre menu : il mène sur une page vide, ça ne sert à rien.
    Soit vous avez une vraie catégorie « Grossesse » qui contient les 3 sous-catégories (petits maux / préparer l’arrivée / de tout et de rien) et votre lien doit mener à cette catégorie, soit il faut rectifier dans votre menu pour que l’item « Grossesse » ne soit pas cliquable, en mettant un # (et c’est tout) dans le lien.

    #1048843
    Melanie R
    Membre
    Initié WordPress
    13 contributions

    Bonjour à tous.

    Merci pour vos retours et excusez moi pour mon retour tardif mais je n’ai pas eu le temps de me pencher sur la question plus tôt. Beaucoup de boulot perso.

    Pour répondre à njaka41, j’ai essayé de renommer la catégorie. RAS. Je vais essayer de creuser du coté du query_post mais pour être franche c’est chinois pour moi 🙂 En plus, si le problème venait de là, es-ce que je n’aurais pas un problème aussi avec ma pagination en page d’accueil ???

    Pour répondre à Flobogo, oui effectivement, j’ai 2 catégories « de tout et de rien » (j’avais fait exprès de mettre des majuscules à l’un mais pas à l’autre pour les différenciés). Cela n’avait jamais posé problème avant, mais il faut bien un début 😉 Pour éviter toutes confusions j’ai crée une nouvelle catégorie « en vrac » et j’ai ensuite basculé mes posts de « de tout et de rien » vers « en vrac ». Toujours le même problème. La page 2 en vrac donne une erreur 404. J’ai aussi essayé de ré-enregistrer mes permaliens comme proposé. Toujours pas de résultats.

    Avez vous d’autres idées ? Merci d’avance

    PS : Pour l’item grossesse, merci je vais tester vos conseils. Cela me dérangeais aussi mais je n’avais pas de solution à ce petit problème.

    Encore merci à vous.
    Mélanie, qui apprends toujours plus sur wordpress grâce à vous !

    #1048844
    Flobogo
    Modérateur
    Maître WordPress
    18599 contributions

    Alors, pour la pagination, vérifiez aussi combien vous avez demandé d’article à l’affichage d’un flux –> à voir dans Réglages.
    Je sais que parfois, il y a un souci à ce niveau-là, mais je ne sais plus trop ce qu’il faut faire.

    Essayez une recherche sur le forum, avec le mot-clé : pagination

    #1048845
    Flobogo
    Modérateur
    Maître WordPress
    18599 contributions

    :hs: Zut, j’ai oublié : merci pour le message sur mon site 🙂

    #1048846
    Melanie R
    Membre
    Initié WordPress
    13 contributions

    @flobogo Merci pour le retour. Oui j’ai vérifié l’affichage du flux d’articles. C’est la première chose que j’ai fait. Je vais repartir à la recherche d’une piste sur le forum ! En tous cas merci !

    Si d’autres ont des idées, je suis preneuse !

    Bonne soirée

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.