Page qui ne s’affiche plus (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 25)
  • Auteur
    Messages
  • #550901
    kosh5
    Participant
    Chevalier WordPress
    228 contributions

    Bonjour à tous,

    J’ai un gros souci sur mon blog… Depuis peu cette page ne s’affiche plus :

    http://magnetisme-et-bien-etre.com/apprenez-a-magnetiser-vos-proches/

    (c’était la seule qui me permettait de régler mes frais d’hébergement…)

    Je ne comprends pas du tout l’origine du problème. Quelqu’un aurait-il une piste ?

    Merci et bonne journée,

    Alexis

    Ma configuration WP actuelle :
    – Version de WordPress : 4.2.2
    – Version de PHP/MySQL : 5.4.38 / 5.1.73-2+squeeze+build1+1-log
    – Thème utilisé : Twenty Twelve Child
    – Extensions en place : Affiliation Manager (6.2), BackUpWordPress (3.1.3), Commerce Manager (6.2), Contact Form 7 (4.1), Forum_wordpress_fr (3.9), GA Google Analytics (20140923), Hupso Share Buttons for Twitter, Facebook & Google+ (3.9.25), Image Widget (4.1), Media File Renamer (1.9.8), Membership Manager (6.2), Regenerate Thumbnails (2.2.4), TinyMCE Advanced (4.1.7), WordPress SEO (2.1.1), WP-Optimize (1.8.9.7)
    – Adresse du site : http://magnetisme-et-bien-etre.com
    – Nom de l’hébergeur : Apache

    #1009369
    Benzouye
    Participant
    Maître WordPress
    575 contributions

    Bonjour,

    Quel est censé être le contenu de cette page ? Utilise-t-elle un modèle de page ?
    Un plugin est-il impliqué dans ce contenu ?

    #1009370
    kosh5
    Participant
    Chevalier WordPress
    228 contributions

    Il y a du texte, des images, et un bouton Paypal. Ce bouton est le seul truc en plus par rapport aux autres pages et articles.

    Ce qui est bizzarre, c’est que j’ai copié-collé ce lien dans un mail (yahoo) et que la page m’apparait en extrait avec le début du texte + une image, et malgré tout quand on clique sur le lien tout est invisible.

    #1009371
    Franck (fge)
    Modérateur
    Maître WordPress
    9576 contributions

    Je ne comprends pas du tout l’origine du problème. Quelqu’un aurait-il une piste ?

    Déjà il faudrait savoir si depuis le tableau de bord, dans l’interface de rédaction, la page apparaît correctement ou pas, ce serait une bonne indication.
    Ensuite tu peux aller vérifier dans phpMyAdmin s’il n’y a pas de tables corrompues qu’il faudrait corriger.

    #1009372
    kosh5
    Participant
    Chevalier WordPress
    228 contributions

    Merci de cette réponse.

    Oui, dans le tableau de bord tout s’affiche correctement ! A n’y rien comprendre…

    J’ai tenté, pour l’expérience de créer une nouvelle page en copiant-collant le contenu, et idem elle ne s’affiche pas, tout en se voyant correctement dans l’espace interne.

    (par espace interne j’entends : lorsque je suis sur la page avec la barre d’outils et que je peux modifier textes et images. Si je fais un “aperçu”, là, ça ne s’affiche pas).

    #1009373
    Benzouye
    Participant
    Maître WordPress
    575 contributions

    As-tu essayé en retirant le bouton PayPal ? D’ailleurs c’est un shortcode ? un iframe ? lié à un plugin ?

    #1009374
    kosh5
    Participant
    Chevalier WordPress
    228 contributions

    Je précise qu’il y a peu, cette page s’affichait correctement. Elle est passée du “statut” affichage normal au “statut” aucun affichage sans que je ne fasse de modification dans la page.

    Donc peut-être (simple piste, je n’y connais rien) que ça pourrait être lié à une mise à jour, un plugin général, ou bien mon thème-enfant ?

    #1009375
    kosh5
    Participant
    Chevalier WordPress
    228 contributions

    J’avais envoyé mon message avant de voir ta réponse, Benzouye.

    Je viens d’essayer, effectivement sans le bouton Paypal tout s’affiche normalement.

    WTF !?!

    Merci, tu as en tout cas fait clairement avancer le sujet.

    Maintenant ça me fait une page de vente sans possibilité de vente, mais je connais les données du problème.

    Si tu sais comment le résoudre, je suis preneur ! Je vais en attendant réécrire à Paypal.

    #1009376
    kosh5
    Participant
    Chevalier WordPress
    228 contributions

    Bon, alors en fait ça vient du code ” [purchase-button id=2]” qui est lié au plugin Kleor.

    Le gars de Kleor me dit :

    “Essayez de désactiver vos plugins autres les plugins Kleor
    pour voir.
    Activez un autre
    thème aussi pour voir si ça vient de votre thème
    actuel.”

    Qu’en pensez-vous, est-ce que je tente ce qu’il me conseille ? Est-ce que ça ne risque pas de chambouler mon blog ?

    #1009377
    kosh5
    Participant
    Chevalier WordPress
    228 contributions

    Alors…

    Je suis allé dans Extensions, j’ai désactivé chaque plugin s’y trouvant, un par un, hormis les 3 plugins Kleor. (A chaque extension désactivée j’ai fait une actualisation de la page http://magnetisme-et-bien-etre.com/apprenez-a-magnetiser-vos-proches/ , celle qui est en bug).

    ça n’a rien donné.

    J’ai ensuite mis un autre thème (en actualisant toujours à chaque fois la page), puis encore d’autres thèmes, ça n’a rien changé non plus.

    Je ne sais plus quoi faire ! Si jamais vous avez une idée je suis preneur.

    Bonne journée,

    Alexis

    #1009378
    Benzouye
    Participant
    Maître WordPress
    575 contributions

    Il faudrait passer ton site en mode DEBUG pour voir si un message d’erreur apparaît sur la page en question.

    Edites le fichier wp-config.php et met true au lieu de false à la ligne WP_DEBUG, et relances la page. Dis-nous si un message apparaît.

    #1009379
    kosh5
    Participant
    Chevalier WordPress
    228 contributions

    Merci de ta réponse.

    Tout d’abord pour info, on m’a conseillé de me connecter via Filezilla et de renommer plugins en pluginsX.
    Résultat : le fameux code [purchase-button id=2] ne fait plus buguer la page, maintenant la page s’affiche même quand j’y inclus [purchase-button id=2]. D’autre part, ce code s’affiche désormais tel quel, comme un simple texte, sans que l’on puisse cliquer. Ce qui est normal je suppose vu que j’ai mis les plugins en pluginsX, et que du coup plus aucun plugin ne fonctionne, en tout cas je ne vois plus apparaitre les plugins de Kleor dans mon espace interne. C’est ballot va-t-on me dire. (je ne sais pas si ça donne des indications utiles ?)

    Pour faire la manip que tu me conseilles je suppose qu’il me fallait remettre pluginsX en plugins avant ? C’est ce que j’ai fait.

    Donc j’ai remplacé flase par true, voilà ce que ça donne :

    http://magnetisme-et-bien-etre.com/apprenez-a-magnetiser-vos-proches/

    je copie-colle le texte :

    Warning: include_once(/home/magnetisky/www/wp-content/plugins/commerce-manager/shortcodes.php): failed to open stream: No such file or directory in /home/magnetisky/www/wp-content/plugins/commerce-manager/commerce-manager.php(373) : runtime-created function on line 1

    Warning: include_once(): Failed opening ‘/home/magnetisky/www/wp-content/plugins/commerce-manager/shortcodes.php’ for inclusion (include_path=’.:/usr/local/php5.4/lib/php’) in /home/magnetisky/www/wp-content/plugins/commerce-manager/commerce-manager.php(373) : runtime-created function on line 1

    Fatal error: Call to undefined function purchase_button() in /home/magnetisky/www/wp-content/plugins/commerce-manager/commerce-manager.php(373) : runtime-created function on line 1

    Heu… pour moi c’est du chinois, si toi ou quelqu’un d’autre comprend je suis preneur

    Merci encore !

    #1009380
    kosh5
    Participant
    Chevalier WordPress
    228 contributions

    P.S. : sur la page d’accueil de mon site il y a aussi ça qui s’affiche tout en haut :

    Warning: include(/home/magnetisky/www/wp-content/plugins/commerce-manager/includes/install.php): failed to open stream: No such file or directory in /home/magnetisky/www/wp-content/plugins/commerce-manager/commerce-manager.php on line 26

    Warning: include(): Failed opening ‘/home/magnetisky/www/wp-content/plugins/commerce-manager/includes/install.php’ for inclusion (include_path=’.:/usr/local/php5.4/lib/php’) in /home/magnetisky/www/wp-content/plugins/commerce-manager/commerce-manager.php on line 26

    argh…

    #1009381
    Lumiere de Lune
    Participant
    Maître WordPress
    19365 contributions

    C’est très clair, ça dit que ça ne trouve pas le fichier install.php

    réinstallez le fichier à la main, éventuellement tout le plugin…il a l’air de manquer

    #1009382
    Benzouye
    Participant
    Maître WordPress
    575 contributions

    Comme précisé par Lumière de Lune, le plugin semble avoir été supprimé de ton serveur.
    Via FTP vérifies l’existence d’un dossier commerce-manager dans le dossier plugins …
    Vérifies également que le plugin Commerce Manager apparaît dans la liste des extensions du menu Extensions.

15 sujets de 1 à 15 (sur un total de 25)
  • Le sujet ‘Page qui ne s’affiche plus’ est fermé à de nouvelles réponses.