Page introuvable si permaliens différents de “Simple” (Créer un compte)

  • WordPress :5.2
  • Statut : non résolu
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #2285172
    Anthony82
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.3.4-2 / 15.1
    • Thème utilisé :Twenty Nineteen
    • Extensions en place : aucune
    • Nom de l’hébergeur : serveur perso
    • Adresse du site : https://tonyetmary.ovh
    • WordPress : 5.3

    Problème(s) rencontré(s) :

    Bonsoir,

    Je me permets de solliciter votre aide, car le souci que je rencontre est en train de me faire devenir “fou” :p

    J’ai effectué une installation neuve de WordPress sur mon serveur perso (VM Debian)

    Cette VM est située derrière un reverse proxy (le problème que je vous expose ne semble pas venir de là, car même sur l’IP locale, le souci est identique)

    Lorsque j’ai passé mon WP en HTTPS, les permaliens se sont mis à “déconner”. Je ne peux avoir accès aux articles que si les permaliens sont en mode “simple”. Dès que je change le paramétrage, j’ai le message de page introuvable :s

    Pour aller plus loin dans l’explication de la configuration de mon serveur, le certificat SSL est sur le serveur reverse proxy, et non sur le serveur WP (je ne sais pas si cela à un lien avec mon souci)

    J’ai vérifié, le mod_rewrite est bien actif. D’ailleurs, j’ai reinstallé le WP pour en avoir le coeur net, après avoir eu le souci une première fois. Du coup, j’ai essayé de modifier les permaliens Avant la bascule en HTTPS, et tout était ok au niveau des permaliens.

    Dès lors que j’ai basculé en HTTPS (manuellement, je précise), je me suis mis à avoir l’erreur.

    Petite précision, j’ai écumé pas mal de forum (ici et d’autre forum WP ou sur Apache), y ai passé pas mal d’heure, mais sans trouvé de solution, du coup, je m’en remets à vous 🙂

    Si jamais il manque des éléments pour compléter l’explication ou trouver des pistes, je peux bien sur compléter au besoin.

    Je vous remercie par avance pour votre aide.

    Anthony

    #2355740
    Excelsior
    Participant
    Initié WordPress
    4 contributions

    Hello,

    Pardon pour le déterrage de topic, mais j’ai reproduit le problème à l’identique

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.4.11 / 10.3.17-MariaDB
    • Thème utilisé :Twenty Twenty
    • Extensions en place : Members / Peter’s Login Redirect / WP User Avatar / Velvet Blues
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://www.arbogast.me
    • WordPress : 5.5.1
    • Système : Centos 8
    • serveur http : apache

    Les permaliens étaient réglé comme je le voulais et je ne rencontrais pas de problèmes.

    J’ai décidé de passer le site en https, étant donné que ça commençait à devenir « un peu » sérieux. Ça a été plus ou moins laborieux, mais la configuration est à l’identique, à la différence du Virtualhost sur https.

    Depuis, les permaliens ne fonctionnent plus comme prévu. Si j’utilise une structure prédéfinie, je retrouve des erreurs 404.

    En écumant les forums, je suis tombé sur un fix qui consiste à ajouter « /index.php/ » avant le format requis, et quand j’utilise ce « hack », je retrouve bien le fonctionnement des permaliens (mais il y’a un disgracieux « index.php/ » au milieu de l’URL).

    Je précise que j’ai utilisé le plugin « Velvet Blues » update url (sans doutes à tort) pour changer les urls de mon site. Je le soupçonne d’avoir fait une bêtise quelque part (dans la base de données ?), car le reste de la configuration est correct d’après moi.

    Évidemment, comme une belle truffe, j’ai omis de faire un backup avant de me jeter dans la procédure.

     

    Mon site n’étant pas encore très gros, je songe à faire une réinstall complète (ça m’embête un peu car le site est à but privé et j’ai déjà quelques utilisateurs qui ont créé un compte et je déteste embêter les gens qui n’ont rien demandé), mais j’aimerai bien éviter ça.

    Si vous avez des idées de choses qui pourraient me faire avancer. Le serveur est sur un VPS et je maîtrise un peu l’administration linux, j’ai pas peur de taper dans la base si vous avez des idées.

     

    Merci par avance.

    • Cette réponse a été modifiée le il y a 1 mois et 1 semaine par Excelsior.
    #2355786
    Excelsior
    Participant
    Initié WordPress
    4 contributions

    Hello.

    Petit update parce que je suis un vrai Jack Russel, je lâche pas facilement.

     

    J’ai fini par bidouiller ma config apache dans tous les sens en vérifiant les permissions à droite et à gauche (les fichiers de config modulaire, c’est pratique, sauf quand le même paramètre est modifié dans 8 fichiers différents), et j’ai pu restaurer mes permalinks comme à l’origine.

    Donc je pense que j’avais un problème au niveau de mod_rewrite qui n’était visiblement pas actif pour le dossier de mon site wordpress.

     

    Pour ceux qui auraient le même problème, vérifiez tous vos fichiers de config httpd. Dans mon cas, un méchant “Allow Override None” était « caché » dans mon httpd.conf dans la configuration du dossier de wordpress.

    <Directory "/var/www/wordpress">
    
        Options Indexes FollowSymLinks
    
        AllowOverride None
    
        Require all granted
    </Directory>

    En remplaçant ce “None” par “All”, mes problèmes ont disparu.

    Hope this helps!

    #2357110
    Anthony82
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

     

    J’ai vu que vous aviez réussi à résoudre un problème similaire au mien.

    J’ai tenté la manip que vous aviez faite (j’avais bien le All à la place de None), mais sans succès (sur le serveur web, et non le reverse proxy)

    <Directory “/var/www/html/wp_tonyetmary”>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>

    J’ai toujours le même pb.

    Auriez-vous une petite idée ?

    #2357115
    Excelsior
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    À priori, il y’a de bonnes chances que mod_rewrite ne soit pas actif sur votre configuration apache. Je vous invite à bien faire le tour des fichiers de configuration de httpd pour contrôler si un autre fichier ne viendrait pas contredire la portion de configuration que vous avez montré là.

    Également, ça ne coûte rien de vérifier que l’instruction suivante soit bien présente dans votre configuration (et que le fichier en question existe).

    LoadModule rewrite_module modules/mod_rewrite.so

    N’oubliez pas de redémarrer apache après ces modifs. J’ai bien conscience de ne rien dire d’original ici, à part de bien contrôler tous les fichiers de configuration, car dans mon cas, il y’en a 8 ou 10, et je ne regardais pas le bon.

    • Cette réponse a été modifiée le il y a 4 semaines par Excelsior.
    #2357121
    Anthony82
    Participant
    Initié WordPress
    3 contributions

    il faut que je recherche des fichiers httpd ? Ou que je regarde dans le fichier apache.conf ?

    Vous dites que vous aviez bcp de fichiers de conf, avez-vous les noms, et les localisation (qui seront sans doute différentes chez moi)

    Merci d’avance

    #2357123
    Excelsior
    Participant
    Initié WordPress
    4 contributions

    Dans mon installation, ce sont les fichiers qui se trouvent dans /etc/httpd.

    Je n’ai pas de fichier apache.conf

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.