[Résolu] Page de connexion atteinte, mais pas de cadre d’encodage username et pwd visible

  • WordPress :4.9.4
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 25)
  • Auteur
    Messages
  • #2157994
    EricStRoch
    Participant
    Initié WordPress
    17 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé :
    • Extensions en place : All§In§One security, Woocommerce, phot§ogallery, login lockdown,…
    • Nom de l’hébergeur :  OVH
    • Adresse du site : voir fichier texte joint

    Problème(s) rencontré(s) :

    J’ai trois sites hébergés par OVH.  Le site principal (www. etc) n’a pas de problème.

    Par contre, pour les deux autres sites hébergés, si j’atteins bien la page de connexion (dont le nom a été changé volontairement par moi), et je n’en veux pour preuve que je n’ai aucune erreur apparente, j’arrive sur le site lui-même (avec l’adresse de la page de connexion), mais le cadre me demandant d’introduire mes username et password n’apparaît pas, et je ne peux que me promener sur le site comme tout un chacun, sans pouvoir me connecter en tant qu’admin…

    Sur un des deux sites, j’ai déjà restauré via Filezilla la base de données complète, mais cela n’a rien changé… toujours pas de possibilité d’accès.

    Inutile de préciser que, comme le nom des pages respectives de connexion a été changé pour chacun des deux sites secondaires, la tentative de connexion via la page http://www.manoirsaintroch.be/wp-login.php? donne, elle, une erreur.

    En vous remerciant d’avance pour votre aide,

    Cordialement,

    Eric

    PS : je joins dans un fichier texte le contenu de deux mails issus de All In One WP Security m’annonçant que le contenu des deux sites a été modifié… par la mise à jour ?  A part la page de connexion cependant, je ne vois aucun changement sur mes sites…

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2158025
    Li-An
    Modérateur
    Maître WordPress
    20001 contributions

    Bonjour, vous pourriez au moins nous donner l’URL des sites en questions, la version de php voire le nom du thème ! Désactivez la redirection des URL de login si vous le pouvez.

    Allez par FTP au niveau du répertoire wp-content/plugins et changez son nom en pluginsxxx pour désactiver toutes les extensions. Même chose pour le thème dans wp-content/themes/nom-du-theme. Et réessayez.
    Pour retrouver les extensions et le thème, il suffira de remettre les noms par défaut des répertoires.

     

    #2158805
    EricStRoch
    Participant
    Initié WordPress
    17 contributions

    Bonjour et merci de votre réponse.

    L’URL des sites vous a cependant bien été communiquée dans le fichier joint à mon message. L’aviez=vous reçu ?

    Le thème utilisé pour les deux sites posant problèmes est WORDPRESS SAGA 1.0.2.

    Je ne puis modifier la redirection des URL de login sur aucun des deux sites, n’ayant pas pour l’instant accès à la gestion du plugin de sécurité.  Cependant, je vais commencer par suivre votre conseil, et désactiver tous les plugins par modification momentanée du nom du folder les contenant, via Filezilla.  Si cela ne suffit pas, je ferai de même pour le thème.

    Dans tous les cas de figure, je reviendrai vous donner des informations sur les suites de ce problème, afin que d’autres puissent profiter de ces recherches de résolution.

    Cordialement,

    EricStRoch

    #2158810
    EricStRoch
    Participant
    Initié WordPress
    17 contributions

    Bonsoir.

    J’ai travaillé sur un seul des deux sites. Résultat des investigations :

    La simple désactivation des plugins par renommage, via FTP,  du folder les contenant (‘plugins -> pluginsXXX’) , a fait réapparaître le cadre me permettant de me connecter sur le site.
    J’ai ensuite, TOUT EN RESTANT CONNECTE sur le site, réactivé tous les plugins par renommage du folder les contenant indiquant le nom d’origine (‘pluginsXXX’ -> ‘plugins’), et ai simplement rafraîchi ensuite ma page internet du site.  Tous les plugins sont réapparu dans la liste des extensions, mais je remarque qu’ils sont tous désactivés.

    J’ai réactivé le plugin de sécurité (All In One Security), ce qui m’a obligé à me relogger,  puis suis ensuite allé dans les paramètres de ce plugin pour désactiver momentanément la redirection de la page de login.
    Je me suis déconnecté, ai fermé mon navigateur, l’ai réouvert, et ai tenté avec succès, puisque le cadre contenant username et password était réapparu,  de me relogger.
    J’ai réactivé et mis  jour toutes les extensions. Je me suis déconnecté, fermé navigateur, et ai ensuite pu me relogger à nouveau.
    J’ai finalement réétabli la redirection de la page de login. Je me suis déconnecté, fermé navigateur, et ai à nouveau pu me relogger.

    … Problème résolu ! (quoique non déterminé…)

    Au tour du second site maintenant…

    Grand merci à vous,

    EricStRoch

     

    • Cette réponse a été modifiée le il y a 2 months et 2 weeks par  EricStRoch.
    #2158888
    EricStRoch
    Participant
    Initié WordPress
    17 contributions

    Bonjour,

    La résolution du second site me pose plus de problèmes.

    1. Le thème et les plugins n’étant PAS désactivés, (ou plutôt ayant simplement été désactivés et réactivés quelques fois), la tentative d’ouverture de page de login (redirigée) me donne maintenant un cadre de connexion, mais dans le coin supérieur gauche d’une page blanche (pas de background ni de mise en forme).
      Le remplissage de ces cases de connexion donne comme résultat une redirection vers une page blanche à  l’adresse IP du localhost 127.0.0.1 (avec évidemment le message d’erreur : Ce site est inaccessible – 127.0.0.1 n’autorise pas la connexion).
      CEPENDANT, il semblerait que la connexion se soit effectuée, car maintenant la connexion à    nomdusite.be   me donne la page d’acceuil de mon site, mais avec juste au-dessus la barre de menu noire de WordPress.  Je peux y passer la souris et les menus se déroulent (Tableau de bord, thèmes, menus    ou encore    Eric – modifier mon profil – Se déconnecter).  Mais un clic n’importe où sur cette barre de menu me dirige vers 127.0.0.1.  SEULE la déconnexion fonctionne et me ramène vers le cadre de connexion sans background.
    2. Lors des tentatives de désactivation des plugins et/ou du thème, la tentative d’ouverture de la page de connexion admin wp-login.php me redirige plus directement vers le localhost 127.0.0.1.

    Pourquoi cette redirection dans tous les cas vers le localhost ? Merci de votre assistance !

    Eric

    #2158953
    EricStRoch
    Participant
    Initié WordPress
    17 contributions

    C’est pas la joie… Mon site principal me posant des problèmes de visualisation d’images, j’ai réinstallé un back-up complet du 05 avril 2018 (d’il y a donc 2 mois), base de données via PhpMyAdmin et fichiers via Filezilla… Cela a fonctionné;. mais maintenant plus.  Et au même moment ou presque, je reçois un mail me disant que mon site principal a automatiquement été mis à jour vers WordPress 4.9.6…

    …et j’ai maintenant le même problème de connexion sur le site principal… 127.0.0.1

    Je suppose donc que mon site était allergique à cette mise à jour…

    Que faire ?

    • Cette réponse a été modifiée le il y a 2 months et 1 week par  EricStRoch.
    #2159190
    Noaneo
    Participant
    Maître WordPress
    28282 contributions

    Bonjour,
    Juste une petite question au niveau de FTP
    Vous avez ceci, les deux autres dossiers à la même hauteur que www ?
    1re configuration
    www
    Badens
    villabadens

    Ou les deux autres dossiers sont dans le dossier www ?
    2e configuration
    www
    Badens
    villabadens

    La première configuration est bonne et pas l’autre, à cause du fichier .htaccess présent dans chaque dossier.
    Dans la deuxième configuration le fichier .htaccess de www créé un conflit avec les fichiers .htaccess des dossiers Badens et villabadens.

    #2159239
    EricStRoch
    Participant
    Initié WordPress
    17 contributions

    Bonjour et merci de votre réponse.

    Les trois sites sont les uns à côté des autres, et ont donc trois .htaccess et trois wp-config.php différents.

    Le contenu des  .htaccess est identique pour les trois sites :

    order deny,allow
    deny from all

    Je vous avoue être assez ennuyé, car si les deux sites secondaires n’ont pas l’obligation d’être mis à jour, par contre le premier est un site de vente.  Et j’ai découvert un problème supplémentaire sur ce site de vente, que je ne sais pas résoudre pour l’instant par manque d’accès : Les articles vendus sont décrits sur une page et accompagnés de multiples photos.  Les pages existent toujours avec leur texte, mais pour certains articles (une vingtaine je suppose), les photos, quoique bien présentes sur le serveur, ne sont plus accessibles par WooCommerce (ou par WordPress, je ne sais).  C’est la raison pour laquelle j’avais effectué un restore des fichiers ET de la base de données datés du 05 avril, soit bien avant l’apparition de tous les problèmes, mais cela n’a résolu aucun de ceux-ci, ni de l’accès, ni des photos.

    Si on ne tient compte que du problème de connexion, il ne peut donc pas venir des fichiers ou de la base de données, qui ont été restaurés…  que reste-t-il ? Le programme WordPress lui-même.  Êtes-vous d’accord avec cette logique ?

    Pour le problème des photos, je ne pourrai tenter de le résoudre qu’en ayant un accès admin au site.

    Cordialement,

    Eric

    • Cette réponse a été modifiée le il y a 2 months et 1 week par  EricStRoch.
    #2159245
    EricStRoch
    Participant
    Initié WordPress
    17 contributions
    Cette réponse a été marquée comme privée.
    #2159246
    Li-An
    Modérateur
    Maître WordPress
    20001 contributions

    Bonjour, je ne suis pas d’accord avec votre logique car, bien avant WP, il y a les problèmes relatifs à l’hébergeurs. Et là, impossible de faire des tests et des vérifications.

    #2159577
    Noaneo
    Participant
    Maître WordPress
    28282 contributions

    Bonjour,
    On peut avoir une capture d’écran de votre FTP ?
    Pour les images, cela peut venir d’un plugin.
    Tout comme pour la connexion, le plugin All In One security.
    https://wordpress.org/support/topic/this-site-cant-be-reached-127-0-0-1-refused-to-connect/

    Les sites doivent maintenu à jour, rien que pour rester compatible avec la version PHP choisi.

    #2159886
    EricStRoch
    Participant
    Initié WordPress
    17 contributions

    Bonjour,

    Je vous joins donc une copie de mon FTP en pièce jointe, montrant bien que les trois sites ne sont pas imbriqués les uns dans les autres, mais sont bien les uns à côté des autres.

    Merci de votre soutien,

    Eric

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2160007
    EricStRoch
    Participant
    Initié WordPress
    17 contributions

    Je précise que j’ai souscrit une offre  mutualisée PERSO sur OVH  (1 nom de domaine, 100 Gb espace disque).

    La présence d’un fichier user.ini dans le www est due à un plugin « Wordfence », et comprend le texte suivant :

    ; Wordfence WAF
    auto_prepend_file = ‘/home/(nomduserveur)/www/wordfence-waf.php’
    ; END Wordfence WAF

    Eric

    • Cette réponse a été modifiée le il y a 2 months et 1 week par  EricStRoch.
    #2160196
    Noaneo
    Participant
    Maître WordPress
    28282 contributions

    Bonjour,

    Je me demande si ce n’est pas Wordfence, qui a causé les problèmes, mais dans le questionnaire, vous avez mis All In One WP Security et non WordFence, vous avez 2 plugins de sécurité ?

    https://wordpress.org/support/topic/fatal-error-cannot-redeclare-class-wfwafwordpressrequest/

    #2160253
    EricStRoch
    Participant
    Initié WordPress
    17 contributions

    Oui.
    All-in-One Security installé en 2017.    Wordfence installé le 05 avril 2018.
    Je serais d’accord de ne plus utiliser Wordfence.

    Ayant jeté un coup d’oeil sur le lien fourni, je tente de jouer au sorcier :

    1. Je constate que a. le fichier .user.ini contient :

    ; Wordfence WAF
    auto_prepend_file = ‘/home/manoirsail/www/wordfence-waf.php’
    ; END Wordfence WAF

    2. Le fichier wordfence-waf.php contient :

    <?php
    // Before removing this file, please verify the PHP ini setting auto_prepend_file does not point to this.

    if (file_exists(‘/home/manoirsail/www/wp-content/plugins/wordfence/waf/bootstrap.php’)) {
    define(« WFWAF_LOG_PATH », ‘/home/manoirsail/www/wp-content/wflogs/’);
    include_once ‘/home/manoirsail/www/wp-content/plugins/wordfence/waf/bootstrap.php’;
    }
    ?>

    3. Je renomme ces deux fichiers  .user.ini   et  wordfence-waf.php  afin de les désactiver et je fais de même pour le dossier wp-content/plugins/wordfence..

    <u>Résultat </u>: J’arrive toujours sur mon site sur la page de connexion (l’adresse le prouve), mais <u>toujours aucun cadre de connexion visible</u>.

    4. Je vérifie que le mot « wordfence » ne se trouve plus ni dans les noms des autres fichiers, ni dans le contenu d’aucun autre fichier présent sur www.
    5. Dans le fichier .htaccess, je découvre, à la suite de toutes des instructions de AIO Security, quelques lignes laissées par Wordfence, dont seules la première et la dernière sont du texte. Je les désactive toutes en les transformant en texte et en écrivant un « # » devant chacune d’elles :

    # Wordfence WAF
    #<Files « .user.ini »>
    #<IfModule mod_authz_core.c>
    #Require all denied
    #</IfModule>
    #<IfModule !mod_authz_core.c>
    #Order deny,allow
    #Deny from all
    #</IfModule>
    #</Files>
    # END Wordfence WAF

    <u>Résultat </u>: J’arrive toujours sur mon site sur la page de connexion (l’adresse le prouve), mais <u>toujours aucun cadre de connexion visible</u>.

    Y aurait-il moyen de réinstaller WordPress avec un thème de base, en récupérant toutes mes données et tous mes fichiers, et ensuite réinstaller le thème ad-hoc et les plugins (sauf Wordfence of course…) ?

     

    Merci,

     

    Eric

15 sujets de 1 à 15 (sur un total de 25)
  • Vous devez être connecté pour répondre à ce sujet.