page d’accueil de mon site wordpress introuvable sur le tableau de bord (Créer un compte)

  • WordPress :5.8
  • Statut : non résolu
  • Ce sujet contient 9 réponses, 2 participants et a été mis à jour pour la dernière fois par Flobogo, le il y a 20 secondes.
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #2407529
    Delm
    Participant
    Initié WordPress
    7 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : Cadence
    • Extensions en place :
    • Nom de l’hébergeur : Ionos
    • Adresse du site :

    Problème(s) rencontré(s) :

    Bonjour,

    J’ai créé un site internet wordpress par l’intermédiaire de l’hébergeur Ionos. Je me suis rendu compte récemment que la page d’accueil de mon site, (…) est une page vierge (il y a juste l’en-tête et le pied de page personnalisé avec un message d’erreur écrit en anglais masqué en partie par le logo de mon en-tête). Cette page n’apparait pas sur mon tableau de bord. J’aimerais pouvoir la supprimer ou la modifier en lui ajoutant un bouton de redirection vers ma véritable page d’accueil.

    Merci par avance pour votre aide.

    Édit modération : URL fantaisiste et inutile remplacée par (…)

    • Ce sujet a été modifié le il y a 4 jours et 22 heures par Flobogo. Raison: déplacé en rubrique "support WordPress" (pb sans rappport avec Gutenberg)
    • Ce sujet a été modifié le il y a 4 jours et 22 heures par Flobogo.
    • Ce sujet a été modifié le il y a 4 jours et 22 heures par Flobogo. Raison: édit modération
    #2407595
    Flobogo
    Modérateur
    Maître WordPress
    18412 contributions

    Vous avez très peu complété le questionnaire de configuration. Il n’est pas là pour vous embêter, ni pour faire les curieux, mais parce que les éléments de configuration sont nécessaires pour comprendre la situation et vous aider.

    Là, on veut bien vous croire, mais on ne peut même pas aller voir le site. On ne sait pas quelle est votre version du thème. On ne sait pas quelles extensions vous utilisez (peut-être tout simplement une extension de cache, qui n’affiche pas les modifications récentes).

    Donc, pour vous faire aider, une seule solution : complétez le questionnaire.

    Alors, merci de le copier-coller et compléter du mieux possible dans votre prochain post :

    Ma configuration WP actuelle
    – Version de WordPress :
    – Version de PHP/MySQL :
    – Thème utilisé :
    – Extensions en place :
    – Nom de l’hébergeur :
    – Adresse du site :

    Si vous ne savez pas répondre, vous pouvez installer cette extension: https://wordpress.org/plugins/forum-wordpress-fr/ (même un peu ancienne, elle fonctionne, et sa mise à jour est en préparation) et ensuite, récupérer les informations sur le tableau de bord de l’admin de votre site pour les copier-coller ici.
    Vous aurez juste à remplacer le terme « Apache » par le nom réel de l’hébergeur. (OVH / Ionos / O2Switch / Planethoster / … ou autre)

    Si besoin, consultez cette vidéo : https://youtu.be/XOFGpSbNCmY

    __________________________

    Et en plus, le sujet n’ayant rien à voir avec l’éditeur Gutenberg, je déplace dans la bonne rubrique

    #2407856
    Delm
    Participant
    Initié WordPress
    7 contributions

    Bonjour,

    Merci pour votre réponse. En effet, je n’avais pas les infos, mis à part le thème et l’hébergeur. Après recherche, voilà ce que j’ai pu trouver :

    Ma configuration WP actuelle
    – Version de WordPress : 5.9.3
    – Version de PHP/MySQL : MariaDB 10.5
    – Thème utilisé : Kadence
    – Extensions en place : easy appointments / Kadence blocks / Kadence starter templates
    – Nom de l’hébergeur : Ionos
    – Adresse du site : http://www.bulleetzen.fr

    Merci par avance pour votre aide.

    #2407866
    Flobogo
    Modérateur
    Maître WordPress
    18412 contributions

    Bonjour,

    Votre version PHP, c’est 8.0.19. Il faudrait peut-être revenir à PHP 7.4 chez votre hébergeur, car tous les thèmes ou extensions ne sont pas compatibles avec PHP 8.x

    Par ailleurs, j’ai été voir votre site : votre page d’accueil (celle du menu) n’existe pas, pas plus que les autres pages de votre menu. Ce contenu existait auparavant ?

    Votre thème Kadence permet de créer des en-têtes et pieds de page, mais pour les contenus, il faut utiliser les modèles de démarrage proposés. Vous avez essayé ? Vous avez consulté la doc de votre thème (en) ?

    Sinon, vous devriez activer un thème comme Twenty-Twenty. Ce serait peut-être plus simple pour démarrer.

    #2407924
    Delm
    Participant
    Initié WordPress
    7 contributions

    Bonjour,

    Merci pour votre retour. Je vais explorer le changement de version PHP que vous conseillez.

    Concernant le site, il est bien fonctionnel (je l‘avais mis en mode brouillon, mon activité n’étant pas encore commencée. Je le publie pour le tester et le remet en mode brouillon après). Je viens de le publier, si jamais vous vouliez y retourner. Quelques liens de boutons insérés dans des pages ne fonctionnent pas, je dois les re-paramétrer  mais le reste fonctionne normalement.
    Quand j’ai commencé le site, je me suis servi de la trame Kadence mais je l’ai beaucoup modifiée et j’ai l’impression d’avoir supprimé la page de base.

    Si je pars sur un autre thème, c’est tout le site que je dois recommencer ?

    Merci pour votre aide.

    #2408007
    Flobogo
    Modérateur
    Maître WordPress
    18412 contributions

    Bon, du coup, ce soir le site est accessible et vos contenus sont bien présents.

    Quand on clique sur l’onglet « accueil », il y a bien des contenus. Par contre, effectivement, l’URL de base de votre site mène à un contenu non-trouvé (donc vide), avec juste l’en-tête et pied de page, et un message (en anglais) pour la recherche qui en plus, n’est pas situé au centre de la page.

    Vous aviez créé une page spécifique pour l’accueil ? (différente de la page des articles, qui se trouve à l’onglet « accueil » ?)
    Et celle qui se trouve à l’onglet accueil, c’est une « page  » que vous avez créée, ou c’est celle qui regroupe automatiquement les derniers articles  ?

    Si c’est bien vous qui avez créé cette page d’accueil, et que vous voulez qu’elle corresponde à votre URL de base, il suffit de vous rendre dans « Réglages » > « Lecture », et vous avez en haut :

    « La page d’accueil affiche » :

    • Les derniers articles
    • Une page statique (choisir ci-dessous)

    Cochez la 2ème option et choisissez votre page « accueil » dans la liste déroulante des pages statiques.

    Inutile de changer de thème, puisque vos contenu sont bien présents, c’était juste ce petit problème de réglage de page d’accueil. (et comme vos contenus n’étaient pas publiés, on ne voyait rien 😁 )

    #2408083
    Delm
    Participant
    Initié WordPress
    7 contributions

    Bonjour,

    C’est bien moi qui avait créé une nouvelle page que j’avais nommé « accueil ». J’avais déjà essayé la semaine dernière la manipulation pour choisir ma page nommée accueil comme page statique mais cela n’avait pas fonctionné. Je viens de le refaire et c’est bon, ça a marché ! Les Permaliens apparaissent aussi correctement (mystère car je n’ai pas fait de nouvelles modifications sur leurs paramètres…).

    Par contre, la page « fantôme » avec le texte en anglais apparait dans le menu de choix de la page statique avec toutes les pages créées (mais elle n’apparait pas sur mon tableau de bord). Je vous ai mis une copie d’écran en PJ. Apparemment, elle s’appelle « page principale événements ».

    Merci pour votre aide, mes problèmes sont résolus apparemment !

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2408142
    Flobogo
    Modérateur
    Maître WordPress
    18412 contributions

    En effet, le retour des permaliens personnalisés et de la page d’accueil en liste déroulante est curieux, mais il doit bien y avoir une explication (que je n’ai pas) 🤔

    la page « fantôme » avec le texte en anglais (…) elle s’appelle « page principale événements ».

    Elle correspond certainement aux Evènements que vous pouvez ajouter (compris avec votre thème ?) : voir votre menu de gauche dans l’admin’, après l’onglet « Articles ».

    Il vous reste un réglage à faire : rediriger le site HTTP vers la version HTTPS : actuellement, les 2 versions existent, et ce n’est pas bon pour le référencement. Choisissez une de ces extensions pour forcer le passage au HTTPS.

    #2408251
    Delm
    Participant
    Initié WordPress
    7 contributions

    Bonsoir,

    Merci, j’ai fait le changement en https. A priori, tout fonctionne !

    Il y a en effet un onglet « événement » qui est vide actuellement.

    Merci encore pour votre aide.

    #2408257
    Flobogo
    Modérateur
    Maître WordPress
    18412 contributions

    Super 👍

    Je passe le sujet en « résolu ».

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.