Page d’accueil affiche “Rien de trouvé”

  • WordPress :5.2
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 15)
  • Auteur
    Messages
  • #2276346
    clo62400
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 5.2.3
    • Thème utilisé : Sydney
    • Extensions en place : Yoast seo, wp super cache, unite gallery lite, Sydney toolbox, siteorigin widget bundle, siteorigin page bulder, simple custom css, redirection, polylang, metaslider, maintenance, google analytics Dashboard, contactform 7, blackstudio tinyMCE widget, askimet antispam, Advanced no captcha & invisible captcha, 404 page
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://la-verdiere.fr

    Problème(s) rencontré(s) : Bonjour, j’ai créé le site ci-dessus lorsque j’étais en stage il y a 3 ans pour une maison d’hôtes/gîtes. Depuis quelques jours, la page d’accueil ne s’affiche plus. A la place : “rien de trouvé”. Le reste des pages du site s’affiche correctement. J’ai vu après quelques recherches que l’extension polylang pouvait en être la cause. Cependant quand je la désactive, je retrouve une page d’accueil en bug total : composée de quasi toutes les pages du site en version NL + quelques pages EN et FR. Rien n’a été fait sur le site, apparemment juste une sauvegarde automatique dont la date coïncide avec le bug… Avez-vous une idée de la source du problème et si oui, comment le résoudre ? Je suis un peu larguée, comme ce n’est pas mon site je ne baigne plus dans wordpress depuis des mois… Un grand merci par avance !

    #2276378
    clo62400
    Participant
    Initié WordPress
    8 contributions

    Bonjour, je me permets de revenir vers vous : personne n’a d’idée sur l’origine de mon problème ? Merci d’avance !

    #2276421
    PhiLyon
    Modérateur
    Maître WordPress
    23553 contributions

    Bonjour.

    Fais toutes les mises à jour sur ton site, thème, extensions.

    🙂

    #2276458
    clo62400
    Participant
    Initié WordPress
    8 contributions

    Bonsoir, merci beaucoup pour votre réponse ! J’ai effectué les MAJ en attente (2 extensions autres que polylang), désactivé et réactivé à nouveau polylang, mais aucun changement… Avez-vous une autre suggestion ?

    #2276460
    PhiLyon
    Modérateur
    Maître WordPress
    23553 contributions

    Désactives tes extensions une par une et vides ton/tes caches à chaque fois.

    🙂

    #2276660
    clo62400
    Participant
    Initié WordPress
    8 contributions

    Bonjour, j’ai désactivé toutes les extensions une par une, d’abord avec Polylang désactivé (étant donné que la page “rien de trouvé” disparait lorsque polylang est désactivé mais laisse place à un beug), puis avec Polylang activé. Aucun changement… Le problème peut-il provenir du thème ?

    • Cette réponse a été modifiée le il y a 1 week et 1 jour par  clo62400.
    #2276666
    PhiLyon
    Modérateur
    Maître WordPress
    23553 contributions

    Bonjour.

    Donc tu as essayé en laissant seulement Polylang activé et en activant les autres extensions une à une ?

    Tu vides ton/tes caches à chaque fois ?

    🙂

    #2276686
    clo62400
    Participant
    Initié WordPress
    8 contributions

    J’ai essayé de 2 manières, en vidant systématiquement mon cache :

    • Polylang activé : désactivation des extensions une par une : “rien de trouvé”
    • Polylang désactivé : désactivation des extensions une par une : page d’accueil en beug
    #2276720
    Hervel
    Participant
    Maître WordPress
    30140 contributions

    Bonjour,
    Pas de page statique ?

    https://docs.athemes.com/article/71-setting-a-static-front-page

    Plugin plus à jour

    https://wordpress.org/plugins/sydney-toolbox/

     

    Sans WP Super Cache, pareil ?

    Vous êtes bien sous PHP 7.3 ?

    #2276793
    clo62400
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    Merci beaucoup pour votre réponse.

    En ce qui concerne la version PHP : 7.3.6

    En ce qui concerne Sydney toolbox : le back-office m’indique que j’ai la dernière version installée. Voulez-vous dire que ce plugin est désormais obsolète et doit être supprimé ? En tout cas, quand je le désactive, cela ne change rien.

    EN REVANCHE, je suis allée voir dans la personnalisation du thème comme démontré dans votre vidéo, et j’ai constaté que la page statique et la page des articles renseignées étaient la même page (à savoir ma page d’accueil). J’ai donc modifié le champ “page des articles”, désactivé polylang, et désormais je retrouve ma page d’accueil ! Merci beaucoup ! Le problème venait donc de polylang + ce problème de réglage. Quelles sont mes alternatives vis à vis de Polylang ? car le site est traduit en 2 langues, je pense que le propriétaire tient à garder sa traduction…

    #2276794
    Hervel
    Participant
    Maître WordPress
    30140 contributions

    Bonjour,
    Pour le plugin , c’est indiqué sur wordpress.org
    “Cette extension n’a pas été testée avec plus de trois mises à jour majeures de WordPress. Elle peut ne plus être maintenue ou supportée et peut avoir des problèmes de compatibilité lorsqu’elle est utilisée avec des versions de WordPress plus récentes.”

    Désactiver, cela n’est pas forcément suffisant, cela arrive qu’un plugin continue de perturber un site malgré tout, il faut mieux supprimer.

    Jamais utilisé de plugin de traduction.

    #2276966
    Flobogo
    Modérateur
    Maître WordPress
    15778 contributions

    Bonjour,

    Je pense que le message “rien de trouvé” venait de la confusion “page d’accueil / page des articles”.

    Si c’est résolu (si vous n’avez plus ce message, en tous cas pas sur l’accueil), vous pouvez réactiver Polylang.

    #2276971
    clo62400
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    Merci pour vos réponses. Malheureusement, c’est bien polylang qui est source du problème “rien de trouvé”, car même en ayant réglé le page statique/page des articles, le problème persiste lorsque polylang est activé, mais pas quand il est désactivé… Je recherche une solution de substitution à cette extension, sachant que l’ensemble du site était traduit en anglais et en néerlandais via celle-ci… Si vous avez des pistes n’hésitez pas.

    Merci à tous pour votre aide, en tout cas !

    #2276974
    PhiLyon
    Modérateur
    Maître WordPress
    23553 contributions

    Bonjour.

    Après différents essais, j’avais le même problème, en réglant la langue dans la page d’accueil elle est enfin apparue, regardes si c’est bien réglé.

    🙂

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2277016
    clo62400
    Participant
    Initié WordPress
    8 contributions

    J’avais déjà vérifié plusieurs fois avant de désactiver Polylang ; la page d’accueil était bien configurée sur français, et était reliée à ses traductions anglaises et néerlandaises. J’ai quand même voulu checker à nouveau l’ensemble des réglages de langues suite à votre message et ai réactivé l’extension. Comme par magie, le site réapparait normalement, avec sa page d’accueil et sa version multilingue… J’avais pourtant tenté de réactiver plusieurs fois sans succès. Très étrange… Je vais surveiller que le problème ne réapparaisse pas, n’ayant pas le fin mot de l’histoire… Merci beaucoup pour votre aide !

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
15 sujets de 1 à 15 (sur un total de 15)
  • Vous devez être connecté pour répondre à ce sujet.