[Résolu] Page blanche sur mon site

  • WordPress :5.2
  • Statut : résolu
15 sujets de 91 à 105 (sur un total de 171)
  • Auteur
    Messages
  • #2276571
    Hervel
    Participant
    Maître WordPress
    30140 contributions

    Supprimer par FTP, les plugins trop vieux.

    Avez-vous encore les messages d’erreurs ?

    Si oui, supprimer ceux que je n’ai pas trouvé.

     

    Lors de la mise à jour de WordPress, vous avez bien supprimé les dossiers wp-admin et wp-includes ?

    Sur votre FTP, les dossiers wp-admin et wp-includes sont ceux de la dernière version de WordPress ?

    #2276572
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    Je ne pense pas avoir fait d’erreur sur les dossiers wp-admin et wp-includes mais je peux recommencer l’opération si vous voulez.

    Renvoyez-moi le lien pour télécharger la bonne version mais je crois que j’ai encore le zip.

    Je peux désactiver tout les pluggins via ftp pour voir ce qui se passe.

    Y-a t’il un moyen que vos messages s’affiche automatiquement sur le forum à chaque fois je dois vérifier ma boite mail.

    #2276573
    Hervel
    Participant
    Maître WordPress
    30140 contributions

    Si vous avez encore le zip, ou le dossier dézippé, recommencer pour les dossiers wp-admin et wp-includes.

    Supprimer les plugins que je n’ai pas trouvé et les plugins trop vieux.

    -Pas trouvé non plus Flash MP3 Player JW2.3, FLV Embed, MP3-Player, WPaudio, WP Editor.

    -Trop vieux Footer Putter, MyCSS, Simple Music, WP-Supersized.

    A part, actualiser la page en faisant F5 ou Ctrl+F5 sur Windows, je ne vois pas comment avoir mes messages automatiquement, le forum ne s’actualise pas tout seul.

    Pour Mac, voir là https://les-raccourcis-clavier.fr/raccourci-clavier-actualiser/

    Vous n’avez pas un logiciel de messagerie ?

    #2276574
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    J’ai renommer la pluspart des plugins qui ne me paraissaient pas in dispensables  il ne reste que ces codes

    avec un argument qui est obsolète depuis la version 2.0.0 ! L’utilisation des niveaux d’utilisateurs est dépréciée. Utilisez plutôt les permissions d’utilisateurs. in /home/courspar/www/wp-includes/functions.php on line 4652
    
    Notice: has_cap est appelé avec un argument qui est obsolète depuis la version 2.0.0 ! L’utilisation des niveaux d’utilisateurs est dépréciée. Utilisez plutôt les permissions d’utilisateurs. in /home/courspar/www/wp-includes/functions.php on line 4652
    
    Notice: has_cap est appelé avec un argument qui est obsolète depuis la version 2.0.0 ! L’utilisation des niveaux d’utilisateurs est dépréciée. Utilisez plutôt les permissions d’utilisateurs. in /home/courspar/www/wp-includes/functions.php on line 4652

    #2276575
    Hervel
    Participant
    Maître WordPress
    30140 contributions

    Je dis de supprimer des plugins et vous les renommez, pourquoi ?

    Ils ne sont plus à jour, vous ne pouvez pas les utiliser.

    Vous avez supprimé les dossiers wp-admin et wp-includes et renvoyer la dernière version des dossiers wp-admin et wp-includes ?

    http://downloads.wordpress.org/release/fr_FR/wordpress-5.2.3.zip

    Je demande cela, justement à cause des messages d’erreurs.

    #2276580
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    Je crois que j’ai désactivé tout cela : Il ne reste que ce message :

    Notice: get_settings est obsolète depuis la version 2.1.0 ! Utilisez get_option() à la place. in /home/courspar/www/wp-includes/functions.php on line 4435

    Je peux changer wp-include, j’ai encore le zip que je viens de dézipper.

    Après je m’arrête, j’ai deuux heures de cours à 17 heures 30

    #2276581
    Hervel
    Participant
    Maître WordPress
    30140 contributions

    Désactivé ??? Quoi ?

    Supprimer le dossier wp-includes et envoyer la dernière version du dossier wp-includes.
    Pareil pour le dossier wp-admin.

    #2276582
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    J’ai désactivé toute la liste de pluggins que vous m’avez envoyée et d’autres. Ils sont presque tous désactivés.

    Je viens de supprimer wp-includes, il y a toujours cette même ligne :

    Notice: get_settings est obsolète depuis la version 2.1.0 ! Utilisez get_option() à la place. in /home/courspar/www/wp-includes/functions.php on line 4435

    Jai 15 minutes, je fais le wp-admin

    #2276583
    Hervel
    Participant
    Maître WordPress
    30140 contributions

    Il ne faut pas juste désactiver les vieux plugins, il faut les supprimer, c’est mieux, cela évite les conflits avec les autres plugins.

    Vous avez supprimé entièrement le dossier wp-includes ?

    Et envoyer le dossier wp-includes de WordPress 5.2.3 ?

    #2276584
    Hervel
    Participant
    Maître WordPress
    30140 contributions

    Bon on verra demain, bon cours.

    #2276585
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    Entièrement supprimé et coller le wp-includes sur www et ainsi pour wp-admin

    Quand j’aurais la main sur mes extensions Je virerai tout ça.

    Toujours cette même ligne. Peut-être qu’il maque un fichier dans le wp.content.

    J’ai fait un collé de wp.content sur wp.content, je n’ai pas fait les fichiers un par un.

    On doit bien pouvoir trouver la cause de cette dernière erreur.

    Il me reste 5 minutes.

    #2276586
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    Merci pour tout, je suis vraiment soulagé que mon site soit visible et que j’ai la main sur l’interface wordpress.

    Je vais bosser.

    Merci pour tout.

    Et à demain

    #2276587
    Hervel
    Participant
    Maître WordPress
    30140 contributions

    En regardant le code source de la page, peut être est-ce lié au plugin FLV Embed (que j’ai dit de supprimer)

    <b>Notice</b>:  get_settings est <strong>obsolète</strong> depuis la version 2.1.0 ! Utilisez get_option() à la place. in <b>/home/courspar/www/wp-includes/functions.php</b> on line <b>4435</b><br />
    <script type="text/javascript" src="http://cours-particuliers-de-danse.com/wp-content/plugins/flv-embed/swfobject.js"></script>

    Je remets la liste des plugins à supprimer, en passant par FTP

    -Flash MP3 Player JW2.3, FLV Embed, MP3-Player, WPaudio, WP Editor,  Footer Putter, MyCSS, Simple Music, WP-Supersized.

    A demain

    #2276588
    Hervel
    Participant
    Maître WordPress
    30140 contributions

    Avez vous regardé les thèmes comme Spacious
    https://demo.themegrill.com/spacious/blog/

    Il suffit de ne pas activer la page de présentation, et vous avez le style “blog”, un des options est le choix pour Image la Une entre image large ou moyenne ou une fois l’image à gauche et l’autre fois à droite.

    Vous avez aussi ces thèmes (sans activer la page de présentation ou d’accueil).
    Cliquer sur les liens  “Page d’accueil du thème” pour voir les démos.

    https://fr.wordpress.org/themes/catch-responsive/

    https://fr.wordpress.org/themes/catch-base/

    https://fr.wordpress.org/themes/catch-evolution/

    #2276633
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    Bonjour,

    J’ai peu travaillé sur mon site hier soir, j’avais des cours…

    A l’ouverture de l’interface wordpress, j’ai ce message :

    avec un argument qui est obsolète depuis la version 2.0.0 ! L’utilisation des niveaux d’utilisateurs est dépréciée. Utilisez plutôt les permissions d’utilisateurs. in /home/courspar/www/wp-includes/functions.php on line 4652

    Au début du cadre stats du site, j’ai ce message

    Notice: has_cap est appelé avec un argument qui est obsolète depuis la version 2.0.0 ! L’utilisation des niveaux d’utilisateurs est dépréciée. Utilisez plutôt les permissions d’utilisateurs. in /home/courspar/www/wp-includes/functions.php on line 4652
    
    Notice: has_cap est appelé avec un argument qui est obsolète depuis la version 2.0.0 ! L’utilisation des niveaux d’utilisateurs est dépréciée. Utilisez plutôt les permissions d’utilisateurs. in /home/courspar/www/wp-includes/functions.php on line 4652
    
    Deprecated: Function create_function() is deprecated in /home/courspar/www/wp-content/plugins/jetpack/modules/stats.php on line 669

    Sur certaines options comme du menu de wordpress  j’ai des messages suplémentaires:

    Notice: screen_icon est obsolète depuis la version 3.8.0, aucune alternative n’est disponible. in /home/courspar/www/wp-includes/functions.php on line 4438
    
    Notice: get_screen_icon est obsolète depuis la version 3.8.0, aucune alternative n’est disponible. in /home/courspar/www/wp-includes/functions.php on line 4438

    Et l’option enplus de la liste des pluggins désactivés sur filezilla m’indique ce message un peu diférent :

    Warning: Illegal string offset 'deactivate' in /home/courspar/www/wp-content/plugins/wp-editor/classes/WPEditor.php on line 333
    
    Warning: array_push() expects parameter 1 to be array, string given in /home/courspar/www/wp-content/plugins/backupwordpress/admin/menu.php on line 77
    
    Warning: Illegal string offset 'deactivate' in /home/courspar/www/wp-content/plugins/wp-editor/classes/WPEditor.php on line 333
    
    Fatal error: Uncaught Error: [] operator not supported for strings in /home/courspar/www/wp-content/plugins/broken-link-checker/core/core.php:369 Stack trace: #0 /home/courspar/www/wp-includes/class-wp-hook.php(288): wsBrokenLinkChecker->plugin_action_links('<', 'broken-link-che...') #1 /home/courspar/www/wp-includes/plugin.php(208): WP_Hook->apply_filters('<', Array) #2 /home/courspar/www/wp-admin/includes/class-wp-plugins-list-table.php(741): apply_filters('plugin_action_l...', Array, 'broken-link-che...', Array, 'all') #3 /home/courspar/www/wp-admin/includes/class-wp-plugins-list-table.php(574): WP_Plugins_List_Table->single_row(Array) #4 /home/courspar/www/wp-admin/includes/class-wp-list-table.php(1244): WP_Plugins_List_Table->display_rows() #5 /home/courspar/www/wp-admin/includes/class-wp-list-table.php(1175): WP_List_Table->display_rows_or_placeholder() #6 /home/courspar/www/wp-admin/plugins.php(619): WP_List_Table->display() #7 {main} thrown in /home/courspar/www/wp-content/plugins/broken-link-checker/core/core.php on line 369
    
    Le site rencontre des difficultés techniques. Veuillez relever la boîte de messagerie du compte administrateur du site pour obtenir des instructions.

    Seulement 4 extensions s’affichent, pas de deuxiéme page imossible de voir les autres et de gérer par l’interface les extensions, le bouton: “Option de l’écran” est inactif.

    En mode admin lorsque je vais sur la page, avant j’avais possibilité de modifier la page. Après l’affichage de la date et du nom de l’auteur; j’avais l’option : “modifier la page” ; je ne la vois plus

    • Cette réponse a été modifiée le il y a 1 week et 1 jour par  EQUANIME.
    • Cette réponse a été modifiée le il y a 1 week et 1 jour par  EQUANIME.
    • Cette réponse a été modifiée le il y a 1 week et 1 jour par  EQUANIME.
15 sujets de 91 à 105 (sur un total de 171)
  • Le sujet ‘[Résolu] Page blanche sur mon site’ est fermé à de nouvelles réponses.