[Résolu] Page blanche sur mon site

  • WordPress :5.2
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 171)
  • Auteur
    Messages
  • #2276128
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    Bonjour,

    Ma configuration WP actuelle

    Problème(s) rencontré(s) :

    Bonjour,

    J’ai une page blanche sur mon site ou plutôt ce message :

    Page blanche :<b>Fatal error</b>: Call to undefined function untrailingslashit() in <b>/home/courspar/www/wp-includes/option.php</b> on line <b>136</b>

    J’ai déjà essayé de renommer le dossier plugin.

    J’ai ouvert le fichier option.php qui comporte bien la value :”untrailingslashit()<b>”</b>

    Je n’ai rien fait de nouveau sur mon site à part ajouter le 2 septembre le pluggin : “Classic editor”

    Appeler OVH qui me conseille de faire une sauvegarde FTP pour remettre mon site en marche mais cela ne corrigera pas le problème.

    Si quelqu’un connait le problème. (Pas trouver dans les recherches avancées)

    Je vous en remercie par avance.

    Cordialement

    • Ce sujet a été modifié le il y a 1 week et 5 jours par  EQUANIME.
    #2276145
    ferman
    Participant
    Maître WordPress
    1010 contributions

    Bonjour,

    Je ne connais pas cette erreur mais je vois que votre version php (5.5) est vieille et si vous avez les dernières versions wordpress (5.0,1,2) ce n’est plus compatible. Chez ovh, essayez  de passer (au moins pour commencer) , en 5.6, voire 7 depuis votre espace client.

    • Cette réponse a été modifiée le il y a 1 week et 5 jours par  ferman.
    #2276148
    Li-An
    Modérateur
    Maître WordPress
    22373 contributions

    Bonjour, en effet de fortes chances que ce soit dû à la version du php.

    #2276161
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    Merci de votre réponse,

    Mais j’ai déjà essayé avec l’assistant OVH et en modifiant le ficher : “.ovhconfig” et cela augmente les erreurs j’ai un “fatal error” à rallonge.

    Si vous avez d’autres propositions, je serai ravi.

    Très cordialement.

    R. Brunaux

    • Cette réponse a été modifiée le il y a 1 week et 5 jours par  EQUANIME.
    #2276163
    PhiLyon
    Modérateur
    Maître WordPress
    23553 contributions

    Bonjour.

    De quand date ton thème, apparemment il ne doit pas être compatible avec WordPress 5.2.3 ?

    C’est ce thème ? https://en.blog.wordpress.com/2007/02/26/new-theme-mistylook/

    🙂

    • Cette réponse a été modifiée le il y a 1 week et 5 jours par  PhiLyon.
    #2276184
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    Oui c’est ce thème.

    5.2.3 est-ce bien ma version de wordpress ? Je n’ai plus accés ?

    Je n’ai pas essayé de désactivé le thème

    #2276189
    PhiLyon
    Modérateur
    Maître WordPress
    23553 contributions

    Bonjour.

    Et bien essaies en activant le thème de base Twenty Seventeen par exemple.

    🙂

    #2276197
    Hervel
    Participant
    Maître WordPress
    30140 contributions

    Bonjour,
    Pour changer la version de PHP chez OVH, c’est par votre espace client, pas besoin de toucher au fichier .ovhconfig.

    https://docs.ovh.com/fr/hosting/configurer-le-php-sur-son-hebergement-web-mutu-2014/

    Le thème Mystic Look ne fait plus partie de wordpress.com, trop vieux ?

    https://wordpress.com/themes?s=misty+look

    Si vous avez bien un thème de wp sur votre site, vérifier en utilisant un logiciel FTP et aller dans wp-content/themes/

    Il y a bien un thème Twenty- ??

    Si oui, renommer mysticlook en mysticlookX.

    Puis actualiser plusieurs fois votre page d’accueil.

    En utilisant le système de cache de Google

    view-source:http://webcache.googleusercontent.com/search?q=cache:trCQK3nharYJ:cours-particuliers-de-danse.com/+&cd=1&hl=fr&ct=clnk&gl=fr

    WordPress 5.1.1 (13 mars 2019)
    Les plugins ne sont pas à jour non plus, par All in One SEO Pack 2.10.1, dernière version 3.2.5

    #2276320
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    Bonjour,

    MERCI POUR VOS REPONSES. CA FAIT DU BIEN…!!

    Je désespérait d’une réponse, mais j’attendais un mail que je n’ai pas reçu. Heureusement, je suis venu voir ici.

    J’ai essayé la version PHP : 5.6, en utilisant l’nterface OVH : Sans succés.

    J’ai essayé de renommer le thème : “Misty look” en ajoutant un 1 au nom pour le désactiver, là aussi, j’ai toujours le même message d’erreur.

    J’ai même essayé d’enlever la valeur : ” untrailingslashit<b>” dans : “option.php</b>” en modifiant le fichier.

    Y a bien des thèmes twenty et un misty lake plus récent que je voulais mettre à la place du misty look mais comment les activer avec seulement filezilla ?

    Je ne connais le truc du cache, je ne sais pas très bien comment actualiser mais je vais retenter pour voir.

    Alors la nouveauté, je suis allé voir pour faire la restauration ftp sur l’interface OVH; je voulais voir si j’attendais trop longtemps si il y aurait encore des sauvegardes et là croyez moi où pas mais la fenêtre s’est fermé toute seule et la demande de restauration a été enregistrée.

    Pour l’instant je n’ai aucun message de OVH.

    En week-end peut-être ?

    Merci de vos réponses et de me répondre à nouveau.

    Cordialement.

     

    #2276321
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    J’ai renommer misty look en mistyclook actualiser la page du cache dés que je clique sur un lien même le showhide toujours le même message d’erreur.

    #2276324
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    Je sais que j’ai un tas de plugins pas à jour sur mon site et même un paquet dont je ne sais plus si je les utilise encore ou pas.

    J’avais délaissé mon site depuis 2017 et j’y suis retourné le 2 septembre, j’ai juste ajouté le plugin : “Classic éditor” et mis à jour mes pages principales.

    J’ai vu un paquet de trucs pas mis à jour et je n’ai pas eu le temps de le faire, 3 jours après j’avais une page blanche.

    #2276325
    Li-An
    Modérateur
    Maître WordPress
    22373 contributions

    Passez php en 7.3+ Les restaurations de OVH prennent leur temps il me semble. Ne modifiez pas les fichiers du core de WP !

     

    #2276326
    ferman
    Participant
    Maître WordPress
    1010 contributions

    Bonjour,

    Pour activer un thème quand on n’a pas accès au tableau de bord il faut passer par la base de données (deux lignes à remplir). C’est facile et bien expliqué ici mais normalement vous ne devriez pas avoir à faire ça: inactiver le thème misty look devrait automatiquement activer un thème par défaut (twenty quelque chose). Le problème vient sans doute d’ailleurs.

    Edit: je viens de voir votre réponse.

    Je sais que j’ai un tas de plugins pas à jour sur mon site et même un paquet dont je ne sais plus si je les utilise encore ou pas.

    Il faut aussi renommer le dossier plugins (vous l’avez fait au début du sujet; c’est toujours renommé?) et faire le ménage.

    • Cette réponse a été modifiée le il y a 1 week et 3 jours par  ferman.
    • Cette réponse a été modifiée le il y a 1 week et 3 jours par  ferman.
    • Cette réponse a été modifiée le il y a 1 week et 3 jours par  ferman.
    #2276327
    EQUANIME
    Participant
    Chevalier WordPress
    140 contributions

    Quand je vais sur l’interface ovh pour remettre en 5.6; il me remet en 5.5, j’ai l’impression qu’il ne veut pas et cela avant de faire la demande de restauration.

    #2276333
    Li-An
    Modérateur
    Maître WordPress
    22373 contributions

    Donnez-nous le contenu de votre fichier .ovhconfig

15 sujets de 1 à 15 (sur un total de 171)
  • Le sujet ‘[Résolu] Page blanche sur mon site’ est fermé à de nouvelles réponses.