[Résolu] Page blanche sur ma Home page + autres bugs

  • WordPress :5.0
  • Statut : résolu
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #2241116
    Fabilo
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.1 / <span data-ng-bind= »element.type »>MYSQL</span> <span data-ng-bind= »‘v’ + ctrlTabDatabases.constructor.formatVersion(element.version) » data-ng-if= »element.version »>v.5.5</span>
    • Thème utilisé : thème enfant de Newspaper 9.2.2
    • Extensions en place : Jetpack, Askimet, All in one SEO, contact form, Broken link checker, google sitempa…
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://www.jogging-plus.com

    Problème(s) rencontré(s) :

    Bonjour, ce soir alors que je n’ai pas touché à mon site de la journée, j’ai constaté que la page d’accueil affichait une page blanche et que le reste du site était dégradé. Après vérification, je constate que toutes les options dans le Thème Panel de Newspaper ont été effacées (logo, couleurs) et que tous mes widgets ont disparu. J’ai remis les options du thème, mais il me reste encore quelques problèmes pour lesquels je sollicite votre aide :

    • ma page d’accueil est toujours blanche…. Alors que d’autres pages fonctionnent (exemple : jogging-plus.com/map ) Et elle reste blanche même quand je change la page désignée comme page d’accueil dans les réglages « lecture » de wordpress. Par contre j’arrive bien à accéder à la page de modification de cette page d’accueil (heureusement j’avais noté l’id). Quand je vide le contenu de la page, rien n’y fait, elle reste blanche. Quand je modifie ma page avec l’interface visuelle, je vois bien le contenu de ma page… (cf. PJ)
    • l’interface d’admin permettant d’ajouter les widgets bug : quand j’ajoute un widget, le volet des options ne s’ouvre pas et je ne peux pas enregistrer le widget…
    • quand je clique sur la page ci-dessous dans chrome, j’ai une page blanche et quand je l’ouvre dans firefox, j’ai une pop-up qui me dit « Vous avez choisi d’ouvrir [espace blanc] qui est un fichier de type : application/octer-stream (20 octets) à partir de jogging-plus.com. Que doit faire Firefox avec ce fichier ? »  : http://www.jogging-plus.com/calendrier/courses-5-10-15-km/france/

    Je n’y comprends rien !

    Merci d’avance pour votre aide.

    Fabien

    #2241134
    Noaneo
    Participant
    Maître WordPress
    29793 contributions

    Bonjour,
    Essayer d’être sous PHP 7.2
    Désactiver tous vos plugins, pareil ?
    Via FTP, dans wp-content/themes/ renvoyer le thème Newspaper.

    #2241179
    Fabilo
    Participant
    Initié WordPress
    13 contributions

    Bonjour, merci bcp pour votre réponse.

    Suis repassé en PHP 7.2, j’ai désactivé tous mes plugins et changé de thème, rien n’y fait… :'(

    Une autre idée ?

    Merci…

    #2241183
    Fabilo
    Participant
    Initié WordPress
    13 contributions

    Pour le bug de cette page : http://www.jogging-plus.com/calendrier/courses-5-10-15-km/france/

    Je l’ai supprimé puis recréé pour tester. Résultat je me rends compte que c’est l’URL qui pose pb… Quand je mets france ça plante, mais dès que j’ajoute un caractère c’est bon. Pourquoi ???

    merci…

    #2241205
    Noaneo
    Participant
    Maître WordPress
    29793 contributions

    @fabilo ,
    Il faut quelques minutes pour que le site soit bien sous PHP 7.2.
    Vous avez désactivé vos plugins via le tableau de bord ?
    Je n’avais pas dit de changer de thème, mais de renvoyer le thème Newspaper par FTP.
    Vous avez, à chaque fois, bien vidé le cache de votre navigateur ?
    Si vous repassez directement par le thème parent et non le thème enfant, pareil ?
    La base de données est optimisée ?

    S’il vous plaît, un problème à la fois, déjà résoudre le problème de la page blanche pour l’accueil.

    L’autre problème est une histoire de page puis de sous-page.
    Je ne sais pas du tout, peut-être un problème de permalien, avec le permalien par défaut, pareil ?

    #2241244
    Fabilo
    Participant
    Initié WordPress
    13 contributions

    merci pour votre réponse, je viens de contacter OVH, ils m’ont d’abord dit que l’erreur venait de mon wordpress. J’ai ensuite isolé tous mes fichiers dans un sous répertoire de backup sous www puis j’ai créé un nouvel index.php à côté et ça ne marchait toujours pas. J’ai rappelé OVH, et du coup ils ont creusé un peu plus. Ils m’ont fait vidé le cache du CDN via mon interface admin OVH et tout s’est résolu… Un peu peu perplexe, mais bon, ça marche maintenant…

    merci bcp pour le temps passé à m’aider

    Amitiés

    Fabien

    #2241270
    Noaneo
    Participant
    Maître WordPress
    29793 contributions

    Bonjour,
    Ravi pour vous, une petite question, vous avez quelle offre chez OVH ?
    L’option CDN, pour moi, est une option en plus à payer, je ne pensais pas que vous l’aviez.
    Merci

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.