OVH, installation du multisite, sous domaines types machin.cheztruc.fr

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 36)
  • Auteur
    Messages
  • #484950
    romainsuard
    Participant
    Initié WordPress
    30 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.01
    – Version de PHP/MySQL :
    – Thème utilisé : theme perso via artisteer
    – Extensions en place : 6 diverses ( SEO pack, Next gen gallery … )
    – Nom de l’hebergeur : OVH
    – Adresse du site : http://www.romainsuard.fr

    Problème(s) rencontré(s) :

    Bonjour,
    Souhaitant séparer mon site pro de mon portfolio et de mon blog infos,
    J ai donc décidé d activer le multisite sous wp3.01
    l’activation c’est passé sans souci, j ai bien tout mes sous domaines dans l’admin wordpress

    Mon premier souci fut des cibles inexistantes ( serveur non trouve et patati patata )

    J ai donc fouiller sur le forum et je suis aller creer mes sous domaines a la main dans mon manager ovh en ciblant le dossier /www.

    Du coup j ai bien une page a l adresse de mes sous domaines mais celle ci est blanche
    ex : http://clients.romainsuard.fr

    Je suis du coup un peu perdu, ne sachant pas si mon probleme vient d OVH ou de WP,
    merci,

    #735506
    Aphrodite
    Participant
    Maître WordPress
    4751 contributions

    la réponse est assez simple. Pour installer un multisite il faut activer ce que l’on appelle les Wildcard DNS qui permet la génération de sous domaines à la volée. Sur un mutualisé c’est très rare que les hébergeurs acceptent ca. Nous on le fait puisque nos serveurs sont dédiés WP multisite, avec tous les modules PHP qui vont bien. Mais en mutualisé “normal” non.

    D’autre part, quel est ton projet ? Pour un “petit” multisite, genre quelques dizaines de sites, un mutualisé acceptant le wildcard fera l’affaire sans souci. Pour un projet plus lourd (plusieurs centaines voire milliers de sites) c’est impensable et surtout pas sérieux. De toute manière l’hébergeur ne l’acceptera pas du fait des ressources que cela demande.

    Tous le souci du multisite est donc la, l’activation de ce fameux wildcard, sinon il faut traiter en mode sous répertoires. C’est moins sexy, mais ca dépend du site a vrai dire. Ca peut au contraire être avantageux.

    #735507
    romainsuard
    Participant
    Initié WordPress
    30 contributions

    Super cool et merci de ta reponse,
    En effet il s agit d un tout petit multisite, 5-6 sites maximum !
    Ou je peux activer cette wildcard chez ovh ? il faut que je les mails ?
    D autre part, lors de l’activation du multisite sous wp3.01 il m a dit,
    en gros, “votre site est deja installer et utiliser nous n activerons pas les sous repertoire mais les machin.cheztruc.fr seulement”
    donc je ne sais pas comment faire marche arriere !
    merci encore,

    #735508
    Aphrodite
    Participant
    Maître WordPress
    4751 contributions

    non on ne peut pas. le choix sous domaine/sous repertoire est définitif. Ca doit etre possible en bidouillant plein de fichiers mais je n’ai pas la moindre idée de quoi faire.

    Demande toujousr à OVH s’ils peuvent activer le wildcard sur ton domaine ca coute rien de demander 🙂

    #735509
    romainsuard
    Participant
    Initié WordPress
    30 contributions

    Hello,

    alors j ai demander a Monsieur OVH et la réponse fut:
    il est possible de l activer -la wildcard- en créant une zone DNS “A”
    comme cela *.cheztruc.fr et en pointant vers l ip du site,

    J ai donc fait ceci, c est apparemment actif, mais cela ne fonctionne pas :-(

    mes réglages sont donc *.romainsuard.fr A 213.186.33.19

    je ne sais plus que faire …

    #735510
    romainsuard
    Participant
    Initié WordPress
    30 contributions

    Je re capitule, car j’ai des avancées,

    J ai donc “activer” une wildcard sur mon domaine mutualise OVH :

    http://romainsuard.fr

    en ajoutant une zone DNS :
    *.romainsuard.fr A 213.186.33.19

    J ai ajouter un site dans wordpress pour tester :

    http://test.romainsuard.fr

    Premiere remarque, j’arrivais sur mon webmail d’OVH

    J ai donc créer un sous domaine a la main dans la manager d’OVH afin que
    http://test.romainsuard.fr cible /www

    Je n ai donc plus le webmail d OVH ………….. mais une page blanche et vide de tout code source …

    😉 <- C'est moi a l'heure actuelle !

    #735511
    Aphrodite
    Participant
    Maître WordPress
    4751 contributions

    si si si le webmail tu l’as en faisant /webmail a la fin normalement 🙂 ca me fit ca sur mon serveur aussi ^^

    #735512
    romainsuard
    Participant
    Initié WordPress
    30 contributions

    et que dois je faire pour avoir mes sites du coup ?
    merci Aphrodite

    #735513
    Aphrodite
    Participant
    Maître WordPress
    4751 contributions

    mais si tu as le wildcar les domaines manuels heuuu a éviter quoi.

    Quesque tu as comme panneau de controle chez ovh ? il manque un truc pour le wildcard la

    il faut dans ton panneau inséré le sous domaine manuell suivant *.mondomaine.com

    #735514
    romainsuard
    Participant
    Initié WordPress
    30 contributions

    ok,
    donc je supprime mes domaines fait a la mano et je met un sous domaine *.romaisuard.fr
    je test et je reviens

    #735515
    romainsuard
    Participant
    Initié WordPress
    30 contributions

    voila,

    j ai donc dans ma zone dns :
    *.romainsuard.fr A 213.186.33.19

    et dans ma gestion des sous domaines :
    http://*.romainsuard.fr cible /www

    Edit : et boom, je tombe sur le web mail pour tout les sous domaines …. dur

    #735516
    Aphrodite
    Participant
    Maître WordPress
    4751 contributions

    maintenant on veut savoir si ca marche !

    #735517
    chamomor
    Participant
    Maître WordPress
    1914 contributions

    😆
    D’autant que ça me semble bizarre de mettre en cname l’IP plutôt que le nom. Mais je n’ai pe pas tout compris des restrictions imposées par ovh.

    #735518
    romainsuard
    Participant
    Initié WordPress
    30 contributions

    voila, je tombe sur le webmail pour tout mes sous domaines ?! RE 😉

    #735519
    romainsuard
    Participant
    Initié WordPress
    30 contributions

    @chamomor

    je copie le mail d ovh :

    Bonjour,

    Vous pouvez activer l’option wildcard sur votre nom de domaine romainsuard.fr, il suffit de créer un champs A *.romainsuard.fr redirigeant vers l’adresse ip souhaitée, depuis le manager, section domaine et dns, zone dns.

    Cordialement, Richard H

    Voila, explication succinte que j ai réaliser, sans succès …

    @Aphrodite

    alors que penses tu de mon absence résultat ?

15 sujets de 1 à 15 (sur un total de 36)
  • Vous devez être connecté pour répondre à ce sujet.