[Résolu] option de tri images sur multi-sites (Créer un compte)

  • WordPress :5.2
  • Statut : résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2301762
    Nedh
    Participant
    Initié WordPress
    21 contributions

    Bonjour,

    Ma configuration WP actuelle :

    • Version de WordPress : 5.3.2 multi-site
    • Version de PHP/MySQL : 7.1.33 / 10.2.31
    • Thème utilisé : Twenty Twenty, hydrogen gantry
    • Extensions en place : Extensions réseau en place : All In One SEO Pack (3.3.5), Blacklist Updater (0.0.5), Classic Editor (1.5), Contact Form 7 (5.1.6), File Manager Advanced (3.3), Forum_wordpress_fr (4.2), Gantry 5 Framework (5.4.32), UpdraftPlus – Backup/Restore (1.16.22), WP-Optimize – Clean, Compress, Cache (3.0.16)
    • Nom de l’hébergeur : Apache
    • Adresse du site : https://ecofabrique.com et yaallah.fr

    Problème(s) rencontré(s) :

     

    Bonsoir,

    Je déplace mon sujet ici puisque mon problème ne concerne que le multi-sites.

    Dans les réglages media, la case à cocher : tri des images par mois/année n’est pas disponible en multi-sites.

    Je veux la supprimer, je l’ai donc modifiée à partir des réglages de sites dans le panneau administrateur. onglet réglages, j’ai remplacé le 1 par 0 comme indiqué sur ce tuto.

    Le problème : Ça ne fonctionne que sur le site principal, pour les autres, il est impossible de télécharger les images. J’obtiens :

    Une erreur est survenue lors du téléversement. Veuillez réessayer plus tard.

    Quelqu’un a une idée de ce qui manque pour que ça fonctionne sur tous mes sites.

    Merci !

    #2301796
    Nedh
    Participant
    Initié WordPress
    21 contributions

    Bonjour,

    Mon sujet n’a emballé personne !? Et bien voilà ce que j’ai trouvé et qui a fonctionné pour moi.

    dans functions.php insérer la ligne suivante :

    add_filter( 'option_uploads_use_yearmonth_folders','__return_false', 100 );
    désactiver tri de fichiers par mois/année

    #2301801
    ferman
    Participant
    Maître WordPress
    2511 contributions

    Bonjour,

    Mon sujet n’a emballé personne !?

    Je crois plutôt que personne n’a trouvé et de fait ça n’a pas dû être facile à trouver (c’est là?). Comme quoi le proverbe “on n’est jamais si bien servi…” a du vrai.

    Merci pour avoir donné l’information qui sera sans doute très utile aux administrateurs de multisite (dont je ne fais pas partie).

    • Cette réponse a été modifiée le il y a 2 mois et 3 semaines par ferman.
3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.