Option : Champs personnalisés ne s’affiche ou ne s’active pas

  • WordPress :5.2
  • Statut : non résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2285092
    LMdiet
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.3.6
    • Thème utilisé : Wellspring
    • Extensions en place : contact7, bbpress, duplicate post, envento market, loco, yaost, éditeur de page et quelques autres
    • Nom de l’hébergeur : Planethoster
    • Adresse du site : https://lmdiet.fr/

    Problème(s) rencontré(s) :

    bonjour tout le monde

    D’habitude je lis beaucoup, et je trouve la solution. Mais là, depuis 3 jours – Rien ne fonctionne

    Je veux activer les champs personnalisés de WP.

    -Si je suis en mode éditeur, dans options de la page/article en haut, il n’existent tout simplment pas. Donc je ne peux pas cocher ce qui n’existe pas.

    -Si je suis en mode Gutenberg, il y a bien l’option dans les options avancées. Quand je coche la case, un message m’informant que la page va se recharger pour activer les champs personnalisés, apparait. Je clique. la page se recharge. La case reste désespérement non cohée. je renouvelle x fois. j’obtiens x fois le même résultat.

    J’ai trouvé quelques lignes de code à insérer dans fonction.php. Aucun succès.

    //champs perso
    add_filter(‘acf/settings/remove_wp_meta_box’, ‘__return_false’);

    add_action(‘wp_insert_post’, ‘wpc_champs_personnalises_defaut’);
    function wpc_champs_personnalises_defaut($post_id) {
    if ( $_GET[‘post_type’] = ‘page’ ) {
    add_post_meta($post_id, ‘meta_title’, ”, true);
    add_post_meta($post_id, ‘meta_description’, ”, true);
    }
    return true;
    }

    Bref, une âme charitable pourrait m’aider SANS plugin supplémentaire svp ?

    Merci d’avance

     

     

    #2285096
    PhiLyon
    Modérateur
    Maître WordPress
    24147 contributions

    Bonjour.

    Je viens de tester, ça fonctionne, c’est soit une extension, soit ton thème qui bloquent.

    🙂

    #2285107
    ferman
    Participant
    Maître WordPress
    1531 contributions

    Bonjour,

    Une autre possibilité: sous quel format a été copié/collé le code par @lmdiet? Le format dans le forum n’est pas bon et quand le colle dans notepad++, il n’est pas bon non plus  (guillemets du type`au lieu de ‘).

    • Cette réponse a été modifiée le il y a 4 semaines et 1 jour par ferman.
    #2285117
    LMdiet
    Participant
    Initié WordPress
    3 contributions

    Merci pour vos réponses rapides.

    Je n’ai pas fait attention au format. J’ai fait un copié-collé avec le clic de la souris et collé dans notepad++ …

    Je vais essayer de modifier le code

    #2285120
    LMdiet
    Participant
    Initié WordPress
    3 contributions

    Toujours rien……….. 🙁

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.