[Résolu] OceanWP – Retirer Bulle + “Commentaires fermés”

  • WordPress :5.2
  • Statut : résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2256133
    Reyhz
    Participant
    Initié WordPress
    18 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 4.7.4
    • Thème utilisé : OceanWP
    • Extensions en place : Elementor / Essential Addons for Elementor / Disable Comments / Yoast SEO / Google fonts for WordPress
    • Nom de l’hébergeur : Serveur Local
    • Adresse du site : /

    Problème(s) rencontré(s) :

    Bonjour,

     

    Je souhaitais désactiver totalement les commentaires sur mon site, c’est pourquoi j’ai installé le plugin Disable Comments, qui je l’espérais , ferait disparaître le “compteur” de commentaire en dessus d’un article unique.

    Seulement maintenant je ne me retrouve plus avec un compteur effectivement, mais toujours avec une icône de bulle et avec le texte “commentaires fermés”.. (voir pièce-jointe)

    J’ai été chipoté le fichier comments.php mais rien n’a l’air de se produire, par avant j’ai produit un thème enfant pour effectuer les modifications sur la feuille de style et à ce niveau là les modifs impactent bel et bien mon site.

    		// Display comments closed message
    		if ( ! comments_open() && get_comments_number() ) : ?>
    			<p class="no-comments"><?php esc_html_e( 'Comments are closed.' , 'oceanwp' ); ?></p>
    		<?php endif; ?>

    Ici c’est le code que je “pensais” pouvoir modifier pour résoudre mon problème ..

     

    Merci d’avance pour votre aide !

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2261051
    Reyhz
    Participant
    Initié WordPress
    18 contributions

    Après plus d’un mois je me permets de poster un petit “up” car mon problème est toujours d’actualité .. 🙁

    #2261266
    ferman
    Participant
    Maître WordPress
    1384 contributions

    Bonjour,

    Pour moi sans  voir le site c’est quasi impossible de suggérer quelque chose de concret  mais plutôt que de “bidouiller php” il doit être possible de masque les cas et le texte non désirés avec des CSS .

    #2261380
    ferman
    Participant
    Maître WordPress
    1384 contributions

    Bonsoir,

    Sans aucune garantie, essayez ce code d’abord en omettant le “!important” et si ça ne marche pas ajoutez le. Si ça ne marche toujours pas désactivez le plugin “Disable comments” et réessayez.

    .recent-posts-comments { display:none !important;}

    #2275713
    Reyhz
    Participant
    Initié WordPress
    18 contributions

    Hello, désolé pour la réponse tardive mais ça a bel et bien fonctionné,

    Un grand merci pour votre aide ! Sujet résolu

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.