Mot de passe pas toujours exigé en mode local

  • WordPress :4.8.2
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 38)
  • Auteur
    Messages
  • #1922471

    SEB92400
    Participant
    Chevalier WordPress
    128 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : MAMP V 3.5
    • Thème utilisé : NISARG
    • Extensions en place :
    • Nom de l’hébergeur : LOCAL MAMP
    • Adresse du site :

    Problème(s) rencontré(s) : Je fais des test d’articles et page avec des mots de passe. Lorsque je donne le mot de passe, j’entre effectivement sur l’article ou la page, (logique) mais ensuite si je fermez l’article ou la page de le mot de passe n’est plus demandé, et i l me semble qu’en me déconnectant et en se reconnectant, le mot de passe n’est toujours plus redemandé.
    Pourquoi ?
    Comment être certain que le mot de passe sera toujours demandé en conditions normales ?
    Ces problème est il lié au fait que je suis en local MAMP ?

    Merci pour votre aide

    Cordt

     

    #1922473

    PhiLyon
    Modérateur
    Maître WordPress
    16152 contributions

    Bonjour.

    Ces problème est il lié au fait que je suis en local MAMP ?

    C’est surtout dû au fait que ton navigateur le garde en mémoire.

    Vides le cache et essaies.

    🙂

    #1922482

    SEB92400
    Participant
    Chevalier WordPress
    128 contributions

    essayé, mais pas de différence (j’utilise firefox Mac)

     

    #1922483

    SEB92400
    Participant
    Chevalier WordPress
    128 contributions

    je vois sur les préférences Firefox MAC

    Modifier la gestion automatique du cache, qui est coché.

    Faut il décocher ?

    #1922691

    C_Lucien
    Participant
    Maître WordPress
    2993 contributions

    Bonjour,

    décocher en effet la case et vérifier dans « Sécurité » qu’aucune case cochée n’autorise l’enregistrement des mots de passe.

    Mieux, dans l’onglet « Vie privée » cocher « Toujours utiliser le mode de navigation privée », vous aurez plus de chance, disons moins de risques de ne pas être pisté.

    #1923128

    SEB92400
    Participant
    Chevalier WordPress
    128 contributions

    Merci C_Lucien, mais pas vu où se trouve

    l’onglet « Vie privée » cocher « Toujours utiliser le mode de navigation privée », ( j’utilise Firefox version OS MAC )

     

    #1923134

    SEB92400
    Participant
    Chevalier WordPress
    128 contributions

    j’ai décoché  « gestion automatique du cache » mais rien de nouveau. (après avoir indiqué le mot de passe d’un article protégé ce mot de passe n’est plus demandé, comme il devrait  l’être)

    Que faire ?

    Question annexe, si mon site était en ligne (au lieu du mode local), est ce que ce souci disparaîtrait ?

     

     

     

     

     

     

    #1923139

    SEB92400
    Participant
    Chevalier WordPress
    128 contributions

    Je voudrais ajouter que j’ai le même problème  avec le bouton « suite », c’est à dire qu’on clique une fois pour lire la suite d’un article ou page, mais ensuite on ne retrouve pas le bouton on a tout l’article directement.
    NB, ceci toujours den moide localavec MAMP

    Merci de votre aide

    Cordt

    #1923147

    C_Lucien
    Participant
    Maître WordPress
    2993 contributions

    Bonjour,

    pas vu où se trouve

    l’onglet « Vie privée » cocher « Toujours utiliser le mode de navigation privée », ( j’utilise Firefox version OS MAC )

    dans les Préférences, la colonne de gauche…

    si mon site était en ligne (au lieu du mode local), est ce que ce souci disparaîtrait ?

    je n’ai jamais vu de différences dans WordPress entre l’environnement MAMP et le site en ligne.

    Ah, mais je viens de voir !

    Ma configuration WP actuelle

    • Version de PHP/MySQL : MAMP V 3.5

    Cette version de MAMP est largement périmée. Sauf si le système Mac OS X est ancien et n’accepte pas la dernière version de MAMP, il faut le mettre à jour. En effet “Requirements: min. Mac OS X 10.10 & 64-Bit processor (Intel)

     

    #1923170

    SEB92400
    Participant
    Chevalier WordPress
    128 contributions

    Mon système est Sierra 10.12.6
    J’ai essayé d’installer  MAMP 4.2.1

    mais échec, quelle version de MAMP convient le mieux à mon système ?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #1923212

    Joss47
    Participant
    Maître WordPress
    2583 contributions

    Bonjour,

    L’echec que tu montres en capture c’est car tu as déjà MAMP qui est en lancé sur ton MAC.

    #1923220

    C_Lucien
    Participant
    Maître WordPress
    2993 contributions

    Bonjour,

    difficile à dire sans voir l’état du Mac, d’autant que je ne connais pas Sierra. Il vaut mieux faire l’installation dans une session administrateur.

    Oui, cette version convient à votre système ; avez-vous pensé à quitter l’application MAMP avant de faire la mise à jour ?

    Là, on s’éloigne de l’aide pour WordPress…

    NB : Les échanges avec le support MAMP se font en anglais. Si cette langue ne vous est pas accessible, un traducteur en ligne fera tout à fait l’affaire.

     

    #1923286

    SEB92400
    Participant
    Chevalier WordPress
    128 contributions

    Re bonjour,
    Merci Joss47, oui c’était le problème (MAMP déjà lancé) , entre temps j’ai pu installer la version MAMP 4.2.1, mais je vois un message (voir copie écran)
    J’avoue ne pas bien comprendre de quoi il s’agit et si vraiment nécessaire de faire ce qui est dit ?

    Mon site en local tourne toujours ce qui est rassurant, par contre les problèmes évoqués au début de cette discussion, demeurent !!

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #1923298

    C_Lucien
    Participant
    Maître WordPress
    2993 contributions

    Oui, c’est à faire. Cela signifie que la nouvelle version de MAMP s’accompagne d’une mise à jour soit de MySql, soit de la manière de structurer la base de données. N’ayant jamais fait un tel saut de version, je n’avais pas le souvenir de ce message –ou bien je l’ai oublié.

     

    #1923441

    SEB92400
    Participant
    Chevalier WordPress
    128 contributions

    Merci C_Lucien, c’est fait et d’ailleurs tout simple (automatisé) !

    Par contre, cette mise à jour de MAMP n’a rien amélioré sur mon souci de base (voir  titre)

    Une histoire de cache sans doute, mais comment faire concrètement ?

    Merci pour votre aide

    Cordt

     

15 sujets de 1 à 15 (sur un total de 38)
  • Vous devez être connecté pour répondre à ce sujet.