[Résolu] Mon site ne s’ouvre pas sur la bonne page d’accueil. (Créer un compte)

  • WordPress :6.4
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 16)
  • Auteur
    Messages
  • #2467614
    Iseberg
    Participant
    Initié WordPress
    9 contributions

    Bonjour,

    Ma configuration WP actuelle.

    • Version de PHP/MySQL : 8.1
    • Thème utilisé : Kadence
    • Extensions en place : uniquement Kadence blocks
    • Nom de l’hébergeur : Hostinger
    • Adresse du site : musiquesinfideles.fr

    Problème(s) rencontré(s) : Bonjour, je commence tout juste la construction de mon tout premier site (oui je débute !), j’ai créé une page d’accueil et supprimé, hélas, celle qui s’affichait au départ et que j’ai prise pour un simple exemple.

    Je pensais définir ma nouvelle page d’accueil comme cible à l’ouverture du site dans réglage/lecture, mais mon site continue à s’ouvrir sur la page d’accueil par défaut et non sur celle que j’ai créée.

    Je ne parviens ni à rétablir la page d’accueil d’origine, ni à la supprimer définitivement : je n’y ai plus accès car elle n’apparaît plus dans mes pages.

    Elle est présente dans Apparence/menu sans que je puisse agir sur elle. J’ai lu dans ce forum qu’il faudrait, je crois, la définir comme page enfant et mettre la mienne en parent, mais je ne vois pas comment faire.

    Merci d’avance pour toute réponse !

    #2467618
    momofr@free.fr
    Modérateur
    Maître WordPress
    6666 contributions

    Salut, tu as bien paramétré le réglage de lecture de ton WordPress ?

    #2467625
    Iseberg
    Participant
    Initié WordPress
    9 contributions

    Bonjour, et merci de ce retour rapide. Oui, je suis allé sur réglage/lecture pour définir une page statique comme page d’accueil et j’ai choisi celle que j’ai nommée ACCUEIL (en majuscule) mais c’est toujours Accueil (minuscule) la page initiale du site, qui apparaît à l’ouverture du site.

    #2467633
    Flobogo
    Modérateur
    Maître WordPress
    19965 contributions

    Bonjour,

    Vous ne pouvez pas avoir 2 pages avec le même nom « Accueil ». En minuscules ou majuscules, peu importe, ce qui compte c’est le « slug », c’est à dire ce qui vient après votre nom de domaine dans l’URL.

    Recopiez votre 2ème page d’accueil sur une nouvelle page, que vous appelez « Bienvenue » (dans le menu, vous pourrez ensuite l’appeler accueil si ça vous convient), et vous pourrez la définir comme … page d’accueil dans les réglages.

    #2467647
    Iseberg
    Participant
    Initié WordPress
    9 contributions

    Bonjour Flobogo, et merci de vous pencher sur mon triste sort !

    En effet je comprends que je ne peux pas avoir deux pages d’accueil avec le même slug. Mais si je crée une page « bienvenue » et que je la règle pour être page d’accueil, mon site continue de pointer sur la page par défaut de Kadence, et affiche « Page d’exemple » dans le menu du header (image 1 sur le doc joint). Je suis bloqué là-dessus. Comme je l’ai dit, pour moi cette page est supprimée et ne devrait pas apparaître. Je n’y ai plus accès (elle n’est pas dans la rubrique PAGES). Je l’appelle ma page fantôme.

    Si je veux créer une page que j’appelle ACCUEIL, cette fois, dans ma création de menu (Réglage/menu) 2 pages apparaissent : la mienne, et cette page fantôme de Kadence (image 2 de mon doc). Que je mette l’une ou l’autre dans mon menu de header, le résultat est le même : mon site s’ouvre sur la page fantôme. La différence est que dans ce cas, si je clique sur « page exemple » du menu du header, je vois apparaître mon site. Mais ce n’est pas satisfaisant pour autant bien sûr !

    J’ai essayé de désactiver Kadence, j’ai dû pour ça mettre un autre thème, (Twenty-twenty-one un peu au hasard) mais la page de Kadence perdure quoique je fasse comme page d’accueil. J’ai réinstallé Kadence sans plus de succès (j’ai appris à utiliser Kadence et pour le moment j’aimerais garder ce thème)

    Je suppose qu’en faisant l’erreur de créer une page nommée ACCUEIL et de supprimer celle qui était proposée, j’ai créé un bug dont je ne parviens pas à me débarrasser. Mon site n’étant pas encore créé (je commence juste à y travailler et c’est mon tout premier…) je n’avais rien à perdre à réinitialiser avec la toute première sauvegarde, ce que j’ai fait en partant des sauvegardes automatiques de mon hébergeur (Hostinger). Mais l’erreur était déjà commise et je reviens donc à mon problème.

    Ma question serait donc : puis-je me débarrasser de cette page fantôme, ou sinon, est-il possible de réinitialiser mon WordPress et comment dois-je m’y prendre ?

    Merci !

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2467694
    Flobogo
    Modérateur
    Maître WordPress
    19965 contributions

    Vous mélangez plein de choses, ce qui entraîne des erreurs ou des incompréhensions :

    • ce que vous appelez « page d’accueil » de Kadence, c’est en fait la page de catégorie par défaut : elle contient l’article « Bonjour tout le monde ».
    • je vous ai demandé de créer une page appelée « bienvenue » : si vous l’avez fait, montrez-moi la liste de vos pages (onglets « pages » du menu admin’ du site) → cela permettra aussi de voir si il y a une ou plusieurs pages « accueil » dans votre liste de pages
    • contrairement à ce que vous avez répondu à Momofr, il semble donc que votre « accueil de site » pointe vers la page « blog » (page des articles) et non pas vers une autre page statique comme « bienvenue »
    • l’une de vos captures écran montre un menu vide, donc il ne contient que la page d’exemple … que vous avez intitulée « programme » … mais dont le « slug » est toujours « /page-d-exemple« 
    #2467733
    Iseberg
    Participant
    Initié WordPress
    9 contributions

    Bonjour,

    Merci pour vos explications. J’ai essayé dans ma précédente réponse d’expliquer mes différentes démarches mais je crains d’avoir été peu clair en effet.

    Voici où j’en suis :

    J’ai créé une page appelée « Bienvenue » comme vous l’aviez suggéré et j’ai donc quatre pages :

    J’ai défini la page bienvenue comme page statique d’accueil. Mais pour le moment mon site s’ouvre toujours sur l’article de blog « Bonjour tout le monde… ». En haut à droite de cette page, en fait de menu, j’ai uniquement « Page d’exemple » et si je clique dessus m’apparaît le titre « Programme » et dessous le texte « Ceci est une page d’exemple… »

    Je vous joins des captures d’écran si ça peut aider.

    Merci encore !

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2467752
    momofr@free.fr
    Modérateur
    Maître WordPress
    6666 contributions

    Salut, on dirait que tu utilises des en-têtes conditionnels, quel paramètres utilises-tu dans ce thème ? C’est la version gratuite ou PRO ?

    #2467757
    Iseberg
    Participant
    Initié WordPress
    9 contributions

    J’utilise la version gratuite. Je ne sais pas ce que sont les en-têtes conditionnels, tout ce que je peux dire c’est que je n’ai pas ajouté d’extensions et pas fait autre chose que créer des pages… et supprimé la page Accueil proposée au départ.

    Ok, je viens de lire ce que sont les en-têtes conditionnels. Non je n’en ai pas installés

    • Cette réponse a été modifiée le il y a 1 semaine et 2 jours par Iseberg.
    #2467760
    Flobogo
    Modérateur
    Maître WordPress
    19965 contributions

    OK, je comprends mieux votre souci.

    Actuellement, l’URL « votre-site/bienvenue » renvoie bien vers l’URL de base, donc elle fonctionne comme accueil.
    Mais que contient la page « bienvenue » ? Je pense (mais je peux me tromper) que si elle n’a aucun contenu, elle renvoie automatiquement vers la page « blog » (que vous n’avez pas créée non plus), c’est à dire vers le ou les articles.

    Dans vos captures écran ci-dessus, on voit sur la capture 2 (liste des pages) aussi que vous avez 2 pages en « corbeille » : vous y trouverez probablement la page d’accueil par défaut que vous aviez supprimée. Vous pouvez toujours la récupérer dans la corbeille ( = la restaurer) et la modifier à votre guise, puis la définir comme page d’accueil réelle, à la place de « bienvenue ».

    #2467767
    Iseberg
    Participant
    Initié WordPress
    9 contributions

    La page bienvenue n’avait en effet aucun contenu. Je viens d’y ajouter rapidement une image et un semblant de texte mais ça ne change rien au problème.

    Quant à la corbeille, elle ne contient malheureusement que la page d’Accueil que j’avais créée et que j’ai remplacée par la page bienvenue, et une autre page que j’ai jetée également, mais pas la page Accueil origine, qui a peut-être disparu quand j’ai désactivé puis réactivé Kadence (simple supposition. Mais en tout cas je n’ai pas volontairement vidé la corbeille)

    #2467774
    Iseberg
    Participant
    Initié WordPress
    9 contributions

    Je ne sais pas si ça peut aider, mais sur un vieux forum WordPress j’ai trouvé une personne qui avait semble-t-il le même problème. (Malheureusement ça date de 2009 !) On lui conseille de jouer avec la fonction « page parent » mais je ne suis pas sûr que ça puisse répondre à mon problème.  Quoi qu’il en soit voici le lien : https://wordpress.com/fr/forums/topic/comment-supprimer-la-page-dacceuil-par-defaut/

    #2467784
    Flobogo
    Modérateur
    Maître WordPress
    19965 contributions

    Et sur la page « bienvenue », avez-vous la possibilité de choisir sur la droite de modèle de page ? Si oui, pouvez-vous choisir quelque chose comme « Home » ?

    Concernant la piste de définir une page parent, pourquoi pas (même si ça date et que ça concerne un autre thème, on pouvait essayer … mais vous n’avez plus accès à cette fameuse « page Accueil », donc impossible de lui définir un parent.

    Pour ma part, je commence à être à court d’idée. Vous pourriez solliciter le support du thème (en anglais).

    #2467788
    Iseberg
    Participant
    Initié WordPress
    9 contributions

    A modèle de page, je trouve MODÈLE : MODÈLE PAR DÉFAUT et si j’ouvre la rubrique, on me propose juste de créer de nouveaux modèles : « Décrivez le modèle, p. ex. : « Publication avec colonne latérale ». Un modèle personnalisé peut être appliqué à n’importe quelle publication. »

    Contacter le support du thème est peut-être une bonne idée, mais même si je me débrouille bien en anglais, pour une discussion technique ça va être un peu difficile. Mais si je ne trouve pas d’autre solution, j’essaierai ça.

    Quoi qu’il en soit merci tout de même d’avoir  pris le temps d’essayer de m’aider !

    #2467874
    Iseberg
    Participant
    Initié WordPress
    9 contributions

    Ouf ! Je pense que mon problème est résolu.

    En allant voir le forum en anglais (merci à Flobogo pour le lien) j’ai pu trouver un post concernant un problème à peu près semblable au mien : https://wordpress.org/support/topic/im-unable-to-remove-the-default-auto-generated-homepage-for-my-website/

    C’était une histoire de cache. Je suis allé sur le gestionnaire de cache de mon hébergeur et j’ai simplement purgé tout comme le suggérait le post ci-dessus. Sur le moment ça n’a donné aucun résultat mais quand j’ai ré-ouvert mon site ce matin tout était bon.

15 sujets de 1 à 15 (sur un total de 16)
  • Vous devez être connecté pour répondre à ce sujet.