Mon site est très très lent !!! (Créer un compte)

  • Statut : non résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #478204
    icerunner
    Participant
    Initié WordPress
    41 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.9.1
    – Thème utilisé : Simple Magazine
    – Extensions en place :
    – Nom de l’hebergeur : one.com
    – Adresse du site : http://www.alainmathot.be

    Problème(s) rencontré(s) :

    Bonsoir,

    Je viens vers vous car j’ai un problème avec le site que je suis occupé à développer. En effet celui-ci est très lent à charger. Il faut parfois attendre 10 secondes avant d’avoir une page. J’ai effectué des recherches sur ce forum avant de poster mais je n’ai pas trouver de solution à mon problème.

    Ce que j’ai fait jusqu’à présent :

    – désactiver les plugins installés (10 au total) mais l’affichage reste assez lent. Voici les plugins: Akismet, cforms, Events Calendar, Exclude Pages from Navigation, Google XML Sitemaps, Maintenance Mode, Newsletter, NextGEN Gallery, Search Everything, Sidebar Login.

    – Contacter mon hébergeur (one.com): après vérification de leur part, ils disent que tout est ok chez eux.

    – J’ai recréé ma base de données mais sans succès

    J’avoue que je suis un peu perdu.

    Quelqu’un aurait-il une idée?

    Merci d’avance.

    #711098
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Installe l’extension Firebug dans ton Firefox, l’onglet Réseau te donnera plein d’infos. L’extension YSlow de Firebug est aussi très utile.

    Par exemple :
    – le plugin “multi level navigation” a plusieurs fichiers qui mettent longtemps à charger
    – le fichier http://www.alainmathot.be/style.css est introuvable

    #711099
    icerunner
    Participant
    Initié WordPress
    41 contributions

    Bonjour,

    J’ai bien l’extension Firebug installée cependant je n’avais jamais utilisé l’onglet Réseau. Je vois effectivement le temps de chargement de mes pages (assez lent par rapport aux sites utilisant wordpress). J’en ai profité pour suivre ton conseil et ai installé YSlow.

    Par contre je ne comprends pas pourquoi mon fichier “style.css” est introuvable. Crois-tu que cela à une incidence sur le temps de chargement des pages?
    J’ai aussi supprimé le plugin “multi level navigation”.

    D’après ce que tu as vu avec Firebug, aurais-tu des suggestions afin que j’améliore la rapidité d’affichage du site?

    Merci pour ton aide

    #711100
    Lumiere de Lune
    Participant
    Maître WordPress
    19378 contributions

    Tu peux aussi éviter un plugin comme Contact Forms, qui est assez lourd, si tu as juste un simple formulaire de contact à mettre en place.

    #711101
    Li-An
    Modérateur
    Maître WordPress
    24338 contributions

    Vous êtes bien en php5 ? Pas normal que ça rame (changer d’hébergeur 🙂 ?)

    #711102
    icerunner
    Participant
    Initié WordPress
    41 contributions

    Je suis bien en php 5 (mon hébergeur va d’ailleurs passer de la version 5.2 à la 5.3 dans quelques jours). De plus, je viens juste de prendre l’hébergement chez one.com.

    En ce qui concerne le formulaire de contact, je vais essayer de trouver un autre plugin. Peux-être as-tu en tête un formulaire de contact moins lourd et assez complet? Merci

    #711103
    Anonyme 2
    Participant
    Maître WordPress
    10589 contributions

    Bonjour,

    question bête : vous optimisez votre base de donnée, de temps en temps ?

    #711104
    icerunner
    Participant
    Initié WordPress
    41 contributions

    Le site étant toujours en construction, la base données est presque vide.
    Cependant je l’ai effacée et recréée hier, je l’ai également optimisée. Ça n’a rien changé. :(

    #711105
    Anonyme 2
    Participant
    Maître WordPress
    10589 contributions

    dés qu’on modifie un article cela créé des “mouvements” dans la base de donnée.
    je ne le trouve pas si lent moi,il apparait rapidement,pas de l’instantané mais normal.

    #711106
    icerunner
    Participant
    Initié WordPress
    41 contributions

    J’ai aussi l’impression qu’il est un peu plus rapide depuis la suppression de certains plugins. Parfois le temps d’affichage est correct mais parfois ça peut prendre 10 secondes. J’ai testé sur différentes machines avec de connexions différentes et ça fait la même chose…

    #711107
    icerunner
    Participant
    Initié WordPress
    41 contributions

    Un petit up pour ce post…

    Après une petite amélioration de quelques jours, il semble que le problème soit revenu. Entre 15 et 25 secondes pour afficher une page.
    Quelqu’un a une idée? Cela fait-il la même chose chez vous?

    Merci

    #711108
    icerunner
    Participant
    Initié WordPress
    41 contributions

    Bonjour,

    Je me permets d’insister et de revenir à la charge encore une fois 🙂

    Il y a une chose que je n’arrive pas à comprendre, et qui a été souligné par Xavier (voir plus haut). Lorsque je teste le site avec l’outil réseau de Firebug, celui-ci me dit que le fichier http://www.alainmathot.be/style.css est introuvable, et cela sur toutes les pages. Pourquoi est-il introuvable alors que mon site est bien en forme avec les styles définis dans la css?
    Comment faire pour que celui-ci ne soit plus introuvable?

    Merci d’avance pour votre aide.

    #711109
    Franck (fge)
    Modérateur
    Maître WordPress
    9576 contributions

    Il y a rarement une seule feuille de style pour le site, WordPress a les siens, les thèmes et les plugins aussi. Une feuille de style qui manque ne mettra pas forcément en vrac ton site. Une feuille de style peut aussi ne concerner qu’un navigateur. Il y a de nombreuses autres raions pour que cela passe inaperçu.
    D’abord as-tu vérifié sa présence par FTP ? Pour qu’il ne soit plus introuvable, il faut essayer de le recharger par FTP à l’endroit nécessaire (apparemment à la racine).

    #711110
    icerunner
    Participant
    Initié WordPress
    41 contributions

    La feuille de style du thème utilisé se trouve bien à la racine de mon site. C’est la raison pour laquelle que je ne comprends pas qu’elle soit introuvable par l’application “réseau” de Firebug. De même, les autres feuilles de styles relatives aux plugins utilisés se trouvent bien dans leur dossier respectif.
    Je me posait cette question au niveau de la css introuvable car je ne vois plus que ça comme explication à la lenteur du site bien que je doute fort que ce soit cela.
    Pour info, j’ai également installé le plugin “WP super cache” afin d’améliorer la vitesse d’affichage. On peut noter une légère amélioration mais je trouve que c’est malgré tout trop long à charger. Qu’en pensez-vous?

    A partir de combien de plugins installés cela devient-il trop lourd pour WP? Je sais qu’un plugin n’est pas l’autre au niveau lourdeur. J’en ai 11 fonctionnels dont CForms qui selon certain est assez gourmant…

    Merci

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.