Mon site en HTTPS dans le back-office MAIS il est en HTTP sur le front-office (Créer un compte)

  • WordPress :4.9.4
  • Statut : non résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #2134575
    Tricia
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    Ma configuration WP actuelle :

    • – Version de WordPress : 4.9.5
    • – Version de PHP/MySQL : 7.0.27 / 5.6.34
    • – Thème utilisé : Twenty Seventeen (thème par défaut avant de mettre le thème choisi)
    • – Thème URI : https://wordpress.org/themes/twentyseventeen/
    • – Extensions en place : Forum_wordpress_fr (4.1), WP Maintenance (4.0.1)
    • – Adresse du site : https://www.garage-legrandcedre.fr
    • – Nom de l’hébergeur : Apache

    Problème(s) rencontré(s) :

    Bonjour,
    J’ai installé WordPress sur mon site. Après je suis allée dans “Réglage Général” pour changer le http en https comme je fais habituellement quand je crée des sites.
    Dans le back-office, je vois bien l’URL qui indique : Sécurité https://www.garage-legrandcedre.fr avec le thème par défaut que nous donne wordpress, PAR CONTRE dans le front-office l’URL est la suivante : Non sécurisé http://www.garage-legrandcedre.fr  Pourquoi ?

    J’ai appelé mon hébergeur OVH qui m’a dit que ce que j’avais fait pour changer l’http en https était correct, que chez eux (OVH) tout était bien mis en place, même le SSL (Let’s Encrypt). Mais ce qui est incroyable, c’est quand la personne d’OVH écrit l’URL de mon site en tant qu’internaute (front-office), l’adresse URL est bien écrite en HTTPS donc sécurisé. Alors pourquoi sur mon MAC, cela ne se fait pas ?
    J’ai également essayé sur mon smartphone en 4G et non en wifi et j’ai le même problème, le https ne se met pas et OVH ne comprend pas et c’est eux qui m’ont renvoyé sur votre forum.

    Merci par avance pour votre aide.
    Tricia

    #2134618
    jessica.chekroun@gmail.com
    Participant
    Initié WordPress
    24 contributions

    De mon coté lorsque je clique sur tes liens. Les deux fonctionnent. En fait, il me semble, pour être en train de travailler dessus, qu’il faut que tu opéres une redirection de toutes tes adresses en http, vers leurs homologues https.
    OVH ont un guide pour cela. C’est un script à coller sur le fichier htaccess…
    https://docs.ovh.com/fr/hosting/eviter-les-pieges-du-ssl-avec-mon-site-web/#le-mixed-content
    Bon courage !

    Jessica

    #2134635
    Tricia
    Participant
    Initié WordPress
    5 contributions

    Merci beaucoup, je vais essayer et vous tient au courant.
    Patricia

    #2134653
    jessica.chekroun@gmail.com
    Participant
    Initié WordPress
    24 contributions

    De mon coté, je me référe à l’article de super marmite qui est assez complet sur la question : https://wpmarmite.com/wordpress-https/

    Je me suis rendue compte que le lien que je vous ai donné n’est pas très détaillé…

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.