[Résolu] Mon blog et PHP (Créer un compte)

  • WordPress :5.5
  • Statut : résolu
  • Ce sujet contient 2 réponses, 2 participants et a été mis à jour pour la dernière fois par Darloup, le il y a 8 mois.
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2367785
    Darloup
    Participant
    Chevalier WordPress
    219 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 5.2.40 (7.2.34 sur le serveur)/10.2.36-MariaDB-log
    • Thème utilisé : Twenty Sixteen
    • Extensions en place : Beaucoup !
    • Nom de l’hébergeur : Web Hosting Hub
    • Adresse du site : http://www.darloup.com/blog/

    Problème(s) rencontré(s) :

    Bonjour,

    Sur mon serveur, j’utilise le programme « Multiphp Manager » pour choisir la version de PHP qui régira mes noms de domaines.

    Dans un passé relativement lointain, j’avais eu des problèmes avec mon blog et une version de PHP, et un technicien de mon serveur avait alors « bridé » la version de PHP utilisé par mon blog en ajoutant quelque chose dans un des fichiers de ce blog.

    Il m’avait expliqué que « Multiphp Manager » indique la version de PHP à utiliser pour un nom de domaine, mais qu’il était possible d’indiquer spécifiquement à chaque sous-domaine quelle version de PHP utiliser.

    J’aimerais maintenant enlever cette restriction qui affecte mon blog (disponible dans le sous-domaine http://www.darloup.com/blog/).

    Tout ce que je sais est qu’il me faut enlever/indiquer quelque chose dans l’un de ces fichiers : .htaccess, php.ini ou .user.ini – mais je ne sais pas le(s)quel(s) et je ne sais pas quoi faire.

    Pouvez-vous SVP m’indiquer la marche à suivre ?

    La version PHP actuelle sur mon serveur est 7.2.34 alors que celle utilisée par mon blog est 5.2.40 (et j’ai un message d’avertissement que cette version est caduque).

    Comme d’habitude, je vous remercie d’avance !

    Cordialement,

    Henry

    P.S. Ma version de Word Press est 5.6 mais elle n’apparait pas dans la liste déroulante…

    #2367796
    mathieu42
    Participant
    Maître WordPress
    870 contributions

    c’est le serveur HTTP qui définit la version de PHP et qui indique à PHP quel fichier utiliser (par exemple le fichier index.php à la racine de wordpress).

    donc s’il y a une configuration de la version de PHP, cela se fait dans les fichiers de configuration d’Apache, si vous y avez accès ou alors le fichier .htaccess. montrez nous le contenu de ce fichier, d’habitude il ne contient aucun code d’accès, clé de hachage ou autre information confidentielle donc vous pouvez le montrer en entier.

    #2368018
    Darloup
    Participant
    Chevalier WordPress
    219 contributions

    Bonjour Mathieu et merci de votre réponse.

    J’ai réussi à résoudre le problème avec l’aide d’un technicien de WHH qui m’a montré comment utiliser un programme qui s’appelle Multiphp Manager et qui permet s’appliquer différentes versions de PHP à mes différents domaines !

    Problème résolu !

    Encore merci !

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.