Mon backend est inaccessible à cause d’une redirection infini (Créer un compte)

  • WordPress :5.8
  • Statut : non résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #2408369
    Papou83
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : gecko
    • Extensions en place :
    • Nom de l’hébergeur : ionos
    • Adresse du site : https://anges-lib.com/

    Problème(s) rencontré(s) :

    Bonjour.

    Je rencontre actuellement un problème ERR_TOO_MANY_REDIRECTS lié à une erreur http 302.

    J’ai essayé de supprimer les cookies, de vider le cache du navigateur, je suis aller fouiller dans le .htaccess pour retrouver cette redirection mais rien.

    J’ai un serveur dédié Linux chez ionos.

    Le frontend fonctionne très bien, toutes les pages et les fonctions changent correctement, mais je n’ai plus du tout accès à aucune fonction de mon tableau de bord.

    Quelqu’un a t’il déjà rencontré ce problème ?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2408447
    Papou83
    Participant
    Initié WordPress
    8 contributions

    Voici l’URL vers laquelle est rédigé ma connexion à chaque fois que je veux me rendre dans le tableau de bord :

    Connexion à Angeslib

    #2408449
    Papou83
    Participant
    Initié WordPress
    8 contributions

    « https://anges-lib.com/connexion-a-angeslib/?redirect_to=https%3A%2F%2Fanges-lib.com%2Fwp-admin%2Fadmin.php%3F »

    #2408452
    ferman
    Participant
    Maître WordPress
    5610 contributions

     

    Bonjour,

    https : //anges-lib.com / connexion-a-angeslib/?redirect_to=https %3A%2F%2Fanges-lib.com%2F wp-admin %2Fadmin.php%3F

    Redirige vers une page de login personnalisée (faite avec une extension?) Et c’est là que vous essayez de vous connecter et que le problème apparaît?

    Avez-vous essayé de vous connecter en tapant directement https: // anges-lib .com /wp-login.php ?

    #2408477
    Papou83
    Participant
    Initié WordPress
    8 contributions

    La fonction de connexion est d’inscription dépendent de peepso, normalement il ne devrait pas y avoir de redirection sur cette sauf en cas de déconnections…

    Mon problème n’est pas au niveau de fonction sur le frontend, elles sont toutes actives, on peut se déconnecter et s’inscrire à volonté…

    Mon problème est que je pense que l’option forcer le SSL sur la page d’inscription prévu dans les réglages peepso sont la cause de l’erreur 302, mais comme je ne peux plus aller dans le back office je suis un peu ennuyé 🤣

    C’est les chien qui se mord la queu, le problème est dans le backend, mais c’est le backend qui est victime de la redirection lol…

    De plus restaurer une sauvegarde d’avant le problème, me ferait perdre une semaine d’activité du site sans parler des abonnements…

    J’espérais trouver l’erreur sur le htaccess, malheureusement il fallait que ce soit dans la seule zone à laquelle je n’ai pas accès (c’est pas drôle sinon lol)

    #2408478
    Papou83
    Participant
    Initié WordPress
    8 contributions

    J’essaie de me connecter à cette URL :

     

    https://anges-lib.com/wp-admin/admin.php?

    #2408480
    Papou83
    Participant
    Initié WordPress
    8 contributions

    Si je suis connecté au site, ça me ramène sur la page d’erreur, si je ne suis pas connecté, j’arrive normalement sur la page de connexion…

     

    #2408501
    ferman
    Participant
    Maître WordPress
    5610 contributions

    https : // anges-lib. com/wp-admin/admin.php?

    Ça ne sert à rien. Essayez l’url que je vous donnais dans ma dernière réponse (enlevez les espaces que j’ai ajoutés pour que la vraie url n’apparaisse pas sur le forum). Sinon, il vous faudra aller par FTP au niveau des dossiers de votre site et désactiver toutes les extensions (y compris Peepso ) en renommant le dossier plugins en plugins-old. Si c’est un problème de plugin, vous devriez alors pouvoir retourner sur votre administration. Si c’est le cas, vous renommez votre plugins-old en plugins puis vous réactivez les extensions l’une après l’autre (ou plusieurs à la fois) en vérifiant à chaque fois que vous pouvez vous déconnecter/reconnecter. Ça vous permet de trouver le coupable (si c’est un plugin). Si vous soupçonnez peepso, vous commencez par lui.

     

     

     

    #2408516
    Papou83
    Participant
    Initié WordPress
    8 contributions

    Je viens de tester de me connecter via le lien que vous m’avez donné, malheureusement ça n’a pas fonctionné non plus.

    Je regarderais demain via le serveur FTP.

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2408808
    Papou83
    Participant
    Initié WordPress
    8 contributions

    Je tenais à vous remercier 😉

    La méthode que vous m’avez donné fonctionne.

    Malheureusement le plugin qui génère le problème est indispensable pour le paiements des abonnements au contenu du site, fort heureusement il survient uniquement après avoir effacé les cookies du site…

    La résolution de ce problème m’a aussi montré d’autres problèmes que je vais devoir corriger de le htaccess et aussi l’apparition d’un autre beug concernant les vidéos qui jusqu’à présent avaient comme limite 1024mo et qui sont aujourd’hui limitées à 100mo alors que le réglages n’ont pas changé…

    Mais pour l’heure, avoir de nouveau accès au tableau de bord est déjà un soulagement.

    Merci à vous

     

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.