[Résolu] Modifier les liens en fonction de l’onglet choisi.

  • WordPress :5.2
  • Statut : résolu
9 sujets de 16 à 24 (sur un total de 24)
  • Auteur
    Messages
  • #2274732
    C_Lucien
    Modérateur
    Maître WordPress
    4250 contributions

    Bonjour,

    avec les éléments que vous communiquez, je ne comprends pas d’où vient le problème.

    La page “Des mots” a-t-elle pour adresse exactement http://www.eric-baisson.fr/des-mots/ ? La page de contact a-t-elle cette adresse exactement http://www.eric-baisson.fr/contact/

    En allant voir dans la liste des pages, vérifiez que chaque page a bien la même adresse que celle quand vous survolez les items du menu.

    Il doit y avoir un détail qui vous échappe, et nous on ne peut pas le deviner à distance.

    Je note par exemple que si votre site est en https les pages sont en http. Pourquoi ? Ce mixed content pose des problèmes, notamment au regard des moteurs de recherche, c’est à régler sans tarder.

    #2274751
    Le Solitaire Seul
    Participant
    Initié WordPress
    40 contributions

    “Bonjour,

    avec les éléments que vous communiquez, je ne comprends pas d’où vient le problème.”

     

    Bonjour,

    Merci pour votre réponse.

    Nous sommes deux à ne pas comprendre 🙁

     

    “La page “Des mots” a-t-elle pour adresse exactement http://www.eric-baisson.fr/des-mots/ ? La page de contact a-t-elle cette adresse exactement http://www.eric-baisson.fr/contact/

    Non. Toutes les Pages commencent par : httpS

    Elles sont configurées ainsi dans Apparences / Menus et dans Pages.

    Je les vois ainsi dans mon Navigateur.

     

    Je me pose donc des questions quand vous écrivez :

    “Je note par exemple que si votre site est en https les pages sont en http. Pourquoi ? Ce mixed content pose des problèmes, notamment au regard des moteurs de recherche, c’est à régler sans tarder.”

    HEIN ! Aurais-je oublié de faire une manipulation pour les Pages soient en https pour les visiteurs du site Internet ?

    Ce qui est certain, c’est que je ne comprends plus rien et surtout pourquoi mes Pages “Des Mots” et “Contact” qui ont été éditées ne s’affichent pas.

    Merci d’avance de vos retours.

     

    #2274752
    C_Lucien
    Modérateur
    Maître WordPress
    4250 contributions

    re,

    un début d’explication –peut-être– la liaison sécurisée (certificat SSL) pointe vers l’adresse provisoire cluster021.hosting.ovh.net. Il faut voir avec le support OVH comment rectifier cela, je ne sais pas faire.

    Si OVH tarde à répondre (fréquent…) voir à partir de leur compte Twitter, où c’est plus réactif.

    #2274777
    Le Solitaire Seul
    Participant
    Initié WordPress
    40 contributions

    Re,

    Réponse rapide d’OVH. Mais pas celle que j’espérais… 🙁

    Bonjour,
    Je vous remercie de votre retour.

    Cela vient pas du SSL, comme vous pouvez le constater sur la copie d’écran que je vous transmet en pièce jointe, le SSL n’est pas actif sur l’adresse du cluster.

    Si besoin pour corriger cela, je vous invite à contacter un webmaster, si besoin vous pouvez en trouver parmi nos partenaires :</div>

    https://partners.ovh.com/

    🙁

     

    • Cette réponse a été modifiée le il y a 3 mois et 2 semaines par Le Solitaire Seul.
    • Cette réponse a été modifiée le il y a 3 mois et 2 semaines par Le Solitaire Seul.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2274800
    C_Lucien
    Modérateur
    Maître WordPress
    4250 contributions

    re,

    Voici ce que répond mon navigateur lors d’un accès à https://www.eric-baisson.fr

    http://www.eric-baisson.fr utilise un certificat de sécurité invalide. Le certificat n’est valide que pour les noms suivants : cluster021.hosting.ovh.net, http://www.cluster021.hosting.ovh.net 

    Je ne sais qu’en conclure.

    #2274828
    Le Solitaire Seul
    Participant
    Initié WordPress
    40 contributions

    Re,

    J’avais eu le même message avec Firefox et j’ai opté un peu vite pour le choix “faire confiance”.

    Je vais faire suivre à OVH qui a un peu botté en touche un peu vite à mon goût.

    Il faudra attendre lundi pour espérer une réponse…

    Merci de m’avoir rafraîchi la mémoire.

    À suivre…

    #2275040
    Le Solitaire Seul
    Participant
    Initié WordPress
    40 contributions

    Bonjour,

    Réponse d’OVH :

    ” Bonjour

    Je vous remercie de votre retour.

    Oui cela vient du fait que le SSL n’est pas installé su votre hébergement, je vous invite donc à l’installé et si vous le souhaitez mettre votre site en HTTPS, pour cela, je vous invite à consulter le guide OVH suivant :

    https://docs.ovh.com/fr/<wbr />hosting/passer-site-internet-<wbr />https-ssl/  

    A priori, j’ai fait ce qu’il faut pour le SSL et mon site est bien en HTTPS.

    Par contre, quand je clique sur le lien, ce n’est pas beau à voir… : https://www.eric-baisson.fr/

    Il faut cliquer un peu partout, pour retrouver le site Internet… avant toutes les modifications faites par mes soins 🙁

    De plus, les onglets ne sont toujours pas “actifs”…

    Bref, je ne suis pas doué et j’ai été bien prétentieux de penser que je pouvais faire un site Internet “simple” avec WordPress.

    🙁

     

    • Cette réponse a été modifiée le il y a 3 mois et 1 semaine par Le Solitaire Seul.
    #2275106
    ferman
    Participant
    Maître WordPress
    1483 contributions

    Bonjour,

    Pour que ça fonctionne, il y a deux choses à faire après être passé en https. .  Regardez ce sujet. Les avez vous faites?

    #2275190
    Le Solitaire Seul
    Participant
    Initié WordPress
    40 contributions

    Bonjour ferman,

    Merci pour votre lien, mais je n’en suis plus là…

    J’ai en effet tout supprimé dans mon FTP et désinstallé le Module WordPress.

    Je viens de réinstaller le module (non sans peine, avec l’aide d’OVH), mais je suis toujours comme une poule devant une pendule devant WordPress… 🙁

    J’en suis là : http://www.eric-baisson.fr/

    Je ne sais plus comment modifier mes Onglets. Je ne les trouve plus dans l’interface… Même Contact que j’avais mis assez vite en ligne avec Form 7, je n’y arrive plus. (mise à jour échouée).

    Je n’arrive pas à me connecter à mon serveur FTP avec les informations d’OVH. 🙁

    Bref, je pense que je vais abandonner. Je suis visiblement trop bête pour WordPress 🙁

9 sujets de 16 à 24 (sur un total de 24)
  • Vous devez être connecté pour répondre à ce sujet.