Modifier le contenu de permaliens créés de façon « automatique » par le thème

  • WordPress :4.9.4
  • Statut : non résolu
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Messages
  • #2150168
    Bertrand44
    Participant
    Initié WordPress
    27 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : AIT / BUSINESS FINDER+
    • Extensions en place : Yoast SEO –  WP Fastest Cache –  Slider Revolution  – AIT Languages
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://sejours.izeedor.fr

     

    Problème(s) rencontré(s) :

    Je suis en train de créer un annuaire de centres de vacances, en utilisant le thème BUSINESS FINDER +, de AIT.

    Chaque centre de vacances correspond à un « élément », ou item, dont le contenu s’affiche en réponse à la demande formulée via le moteur de recherche interne. Et chaque centre de vacances peut présenter en détail ses séjours, sous forme d’un Portfolio.

    Les URL correspondant aux différents centres de vacances sont générées en partie automatiquement. Il en est de même des URL correspondant aux différents Portfolios.

    Concrètement, l’URL d’un centre de vacances s’affiche sous la forme : https://sejours.izeedor.fr/item/nom-du-centre/

    Et l’URL d’un porfolio s’affiche sous la forme : https://sejours.izeedor.fr/portfolio-item/colo-voile-ete-2018/

    J’ai bien entendu la possibilité de choisir les parties de permaliens « nom-du-centre » et « colo-voile-ete-2018 » lorsque j’enregistre les différents éléments.

    Par contre les parties de permaliens « item » ou « portfolio-item » sont générées automatiquement, à partir du moment où je crée un nouvel élément, ou un nouveau Portfolio. Il en est de même des permaliens des catégories « cat », ou emplacements « loc ».

    J’aimerais pouvoir modifier les termes de ces permaliens pour optimiser le référencement. Par exemple, remplacer « item » par « organisateur », « porfolio-item » par « programme », et « loc » par « situation ».

    Pour que mon adresse actuelle https://sejours.izeedor.fr/item/nom-du-centre/ devienne https://sejours.izeedor.fr/organisateur/nom-du-centre/

    Et que https://sejours.izeedor.fr/portfolio-item/colo-voile-ete-2018/ devienne https://sejours.izeedor.fr/programme/colo-voile-ete-2018/

    L’option Réglages/Permaliens de WP ne permet pas d’agir à ce niveau là.

    Quel fichier dois-je modifier ????? Et qui est caché où ??

    Merci beaucoup !

    Bertrand

    #2150208
    Bertrand44
    Participant
    Initié WordPress
    27 contributions

    Re,

     

    je poursuis mes recherches, explications et étonnements, pour ceux qui pourraient m’éclairer.

    J’ai réussi à modifier les permaliens, en intervenant sur le functions.php du thème enfant. Suivant scrupuleusement la méthode préconisée par l’éditeur. Cf ici : https://www.ait-themes.club/knowledge-base/how-can-i-change-items-slug-and-slug-of-other-custom-post-types/

    Sauf que… cela ne marche qu’à moitié, c’est à dire pas…

    • Si je crée un nouvel Elément (centre de vacances), sur l’interface admin, le permalien indiqué est bien désormais https://sejours.izeedor.fr/organisateur/nom-du-centre/    Le « slug » est bien « organisateur » en lieu et place de « item », comme souhaité. Donc jusque là, ça va.
    • Mais si je clique sur ce lien, j’arrive à une erreur 404 ! Et là ça va plus…
    • Par contre, la page sera visible à l’adresse https://sejours.izeedor.fr/item/nom-du-centre/    qui n’est pas celle souhaitée.

    Bref, c’est assez mystérieux….

    Un avis ?

     

2 sujets de 1 à 2 (sur un total de 2)
  • Vous devez être connecté pour répondre à ce sujet.