Modification impossible du WordPress (Créer un compte)

  • Statut : non résolu
15 sujets de 16 à 30 (sur un total de 37)
  • Auteur
    Messages
  • #974798
    edouardjenny
    Participant
    Initié WordPress
    21 contributions

    Bon mon site est maintenant inaccessible, le fichier config a été remplacé donc pas le lien avec la base SQL

    #974799
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Il suffit d’éditer le fixchier wp-config.php avec notepad++ (encodé en UTF8 sans BOM) en indiquant les identifiants et mots de passe

    // ** Réglages MySQL – Votre hébergeur doit vous fournir ces informations. ** //
    /** Nom de la base de données de WordPress. */
    define(‘DB_NAME’, ‘votre_nom_de_bdd’);

    /** Utilisateur de la base de données MySQL. */
    define(‘DB_USER’, ‘votre_utilisateur_de_bdd’);

    /** Mot de passe de la base de données MySQL. */
    define(‘DB_PASSWORD’, ‘votre_mdp_de_bdd’);

    /** Adresse de l’hébergement MySQL. */
    define(‘DB_HOST’, ‘localhost’);

    Ainsi qu’en plaçant des clés d’authentification ici :

    define(‘AUTH_KEY’, ‘put your unique phrase here’);
    define(‘SECURE_AUTH_KEY’, ‘put your unique phrase here’);
    define(‘LOGGED_IN_KEY’, ‘put your unique phrase here’);
    define(‘NONCE_KEY’, ‘put your unique phrase here’);
    define(‘AUTH_SALT’, ‘put your unique phrase here’);
    define(‘SECURE_AUTH_SALT’, ‘put your unique phrase here’);
    define(‘LOGGED_IN_SALT’, ‘put your unique phrase here’);
    define(‘NONCE_SALT’, ‘put your unique phrase here’);

    Il existe un générateur aléatoire de clés ici :
    https://api.wordpress.org/secret-key/1.1/salt/

    Il suffit de cliquer sur le lien et de nouvelles clés sont générées aléatoirement qu’il suffit de copier-coller dans wp-config;php

    #974800
    edouardjenny
    Participant
    Initié WordPress
    21 contributions

    Bon le site est accessible mais les plugins sont toujours désactivés par contre l’accès à la console d’admin m’est refusé.
    J’ai un message avec la base de données WordPress à mettre à jour et qui recommence dès la base de données mise à jour
    http://les-demoiselles-de-compagnie.fr/wp-admin/

    #974801
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Activez le thème par défaut en renommant via FTP le dossier wp-content/themes/votre_thème en wp-content/themes/votre_thèmeX, ce qui activera le thème par défaut, c’est à dire twenty fourteen.

    #974802
    edouardjenny
    Participant
    Initié WordPress
    21 contributions

    Je n’ai pas ce fichier là, dans thème j’ai seulement les versions de twenty11,12,13,14 un dichier DS STore et Index

    #974803
    bill57
    Participant
    Maître WordPress
    858 contributions
    #974804
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Le site aussi

    #974805
    edouardjenny
    Participant
    Initié WordPress
    21 contributions

    Oui mais une fois connectée j’arrive sur une page qui me dit :
    Mise à jour de la base de données requise

    WordPress a été mis à jour ! Avant de vous laisser continuer, nous devons mettre à jour la base de données.

    Le processus de mise à jour peut prendre un certain temps, merci donc pour votre patience.

    Mettre à jour la base de données de WordPress

    Un fois que je mets à jour la base, je retombe dessus

    #974806
    edouardjenny
    Participant
    Initié WordPress
    21 contributions

    Impossible d’accéder à l’admin

    #974807
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Certainement que lors de la mise à jour via FTP certains fichiers n’ont pas été transférés.

    recommencez la mise à jour via FTP :
    USAGE DE FILEZILLA :
    Dans Filezilla, tout en bas, il y a 3 onglets :
    – Fichiers en file d’attente
    – Transferts échoués
    – Transferts réussis

    Lorsqu’un transfert a échoué, on le voit dans l’onglet correspondant. Il suffit de le remettre dans la file d’attente par un clic droit qui ouvre un petit menu.
    Puis lorsque le fichier et à nouveau en file d’attente, il suffit de faire un clic droit pour relancer le transfert.

    Faire ainsi jusqu’à réussite du transfert de tous les ficihiers.

    #974808
    edouardjenny
    Participant
    Initié WordPress
    21 contributions

    J’ai résolu le problème en changeant le numéro de version dans wp-includes/version.php qui était différent du numéro de version présent dans wp-options sur PhpMyAdmin.
    Je peux donc accéder à nouveau à mon écran de log, sauf que maintenant j’ai une nouvelle loop avec ce chemin qui me fait tourner en rond
    http://les-demoiselles-de-compagnie.fr/wp-login.php?redirect_to=http%3A%2F%2Fles-demoiselles-de-compagnie.fr%2Fwp-admin%2F&reauth=1

    #974809
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Cela montre que la mise à jour ne s’est pas faite normalement.

    Essayez de la refaire en suivant les instructions détaillées du CODEX : http://codex.wordpress.org/fr:Details_de_mise_a_jour

    #974810
    edouardjenny
    Participant
    Initié WordPress
    21 contributions

    Je viens de refaire la MàJ et je reviens au même problème qu’avant avec une loop sur la mise à jour de la base de données, pb que je règle en changeant le db_version

    #974811
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Sur Filezilla, affichez les fichiers cachés et vérifiez s’il n’existe pas sur votre site un dossier ou un fichier non légitime qui fout le bordel.

    #974812
    edouardjenny
    Participant
    Initié WordPress
    21 contributions

    Tout vérifier, toujours pas de solution

15 sujets de 16 à 30 (sur un total de 37)
  • Vous devez être connecté pour répondre à ce sujet.