Modification du CSS par Elementor (Créer un compte)

  • WordPress :5.7
  • Statut : non résolu
  • Ce sujet contient 0 réponse, 1 participant et a été mis à jour pour la dernière fois par jpc, le il y a 3 mois.
Affichage de 1 message (sur 1 au total)
  • Auteur
    Messages
  • #2380132
    jpc
    Participant
    Initié WordPress
    1 contributions

    Bonjour à toutes et à tous,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.4.16
    • Thème utilisé : Hannah CD Child
    • Extensions en place : Elementor, WooCommerce, Contact Form 7, Display Posts, Envato Elements, Image Hover Effects Ultimate, LiteSpeed Cache, Loco Translate, MC4WP, MonsterInsights, OptinMonster, SecuPress, Starter Templates, WP Show Posts, WP Super Cache, WPForms Lite, Yoast Duplicate Post
    • Nom de l’hébergeur : Hostinger

    Problème(s) rencontré(s) :

    Suite à une petite mise à jour d’Elementor, tous les articles et pages que j’avais modifiés avec Elementor (icone bleu “Elementor” en face du titre) ont subi des modifications anormales du CSS :

    • Les icones “fa” des réseaux sociaux ont disparu d’un petit menu latéral, alors que sur les pages/articles non modifiés avec Elementor, les icones apparaissent normalement,
    • Les titres des articles dans la zone “Articles récents” sont passés en taille 1 px … mais ok sur les pages/articles non modifiés avec Elementor,
    • Le texte pour se connecter pour laisser un commentaire ou le texte de remplacement indiquant qu’on est connecté, idem, taille 1 px …
    • Idem pour la zone “Article suivant”.
    • Et peut-être d’autres modification que je n’ai pas vues.

    Après une recherche sur le net, la solution proposant d’aller dans les réglages d’Elementor puis dans Avancé pour mettre à Oui le support de Font Awesone 4, n’a pas fonctionné. C’était déjà sur Oui, j’ai essayé de mettre sur Non, vider tous les caches, puis remettre Oui … pas mieux.

    Et c’est en fouillant mieux dans l’inspecteur d’éléments de Google que j’ai fini pas trouver le causeur de trouble. Une classe nommée “.elementor-kit-21317” semble overider le CSS du thème. Cf pièce jointe.

    Si je supprime dans l’inspecteur cette classe dans le body class=, tout redevient normal.

    J’utilise la version gratuite d’Elementor, je n’ai donc pas accès au CSS additionnel de cette extension. J’ai tenté de chercher dans les fichiers du site dans wp-content/plugins/elementor si je trouvais cette fichue class pour la killer … autant chercher une aiguille dans une grange.

    Etant loin d’être un expert sur WP, je viens donc ici pour trouver de l’aide, savoir comment trouver cette class pour la supprimer et comment éviter que ça se reproduise lors d’une prochaine mise à jour d’Elementor.

    Grand merci par avance !

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
Affichage de 1 message (sur 1 au total)
  • Vous devez être connecté pour répondre à ce sujet.