[Résolu] Mise en ligne wordpress

  • WordPress :5.2
  • Statut : résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #2273574
    kevinp
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.3.1/5.7.24
    • Thème utilisé : Firefly

    Problème(s) rencontré(s) :

    J’ai conçu un site en local mais au moment de le mettre en ligne chez ovh en utilisant wp migration, je suis limité en espace de téléchargement et donc je ne peux utiliser ce module. Ensuite j’ai essayé duplicator qui n’arrive pas à intégrer toutes les fonctionnalités.

    Je suis donc en train de faire une copie manuel du site. J’ai modifié les éléments de la base de données grâce aux requête ci-dessous.

    UPDATE wp_options SET option_value = replace(option_value, 'http://www.ancien-domain.com', 'http://www.nouveau-domaine.com') WHERE option_name = 'home' OR option_name = 'siteurl';
    UPDATE wp_posts SET guid = replace(guid, 'http://www.ancien-domaine.com','http://www.nouveau-domaine.com');
    UPDATE wp_posts SET post_content = replace(post_content, 'http://www.ancien-domaine.com', 'http://www.nouveau-domaine.com');

    Malheureusement cela ne suffit pas, la page d’accueil du site fonctionne mais uniquement celle-ci, la page admin est toutes les autres pages sont inaccessible. J’ai aussi changé chaque ligne dans la base qui faisait encore appel à un lien local mais ça ne suffit pas.

    Si vous auriez des idées pour résoudre mon problème, je vous remercie.

    #2273575
    C_Lucien
    Modérateur
    Maître WordPress
    4250 contributions

    Bonjour,

    voir l’outil d’Interconnectit. À supprimer aussitôt après avoir vérifié la réussite de la migration.

    Si vous rencontrez déjà des problèmes d’espace disque, vous risquez de vous retrouver bloqué à une autre occasion. Le changement d’offre d’hébergement s’imposera tôt ou tard.

    #2273577
    kevinp
    Participant
    Initié WordPress
    14 contributions

    C’est l’espace de téléchargement via une page web qui est limité, l’espace disque est largement suffisant pour ce qui demandé. La restriction d’ovh limite à 128mb.

    #2273579
    ferman
    Participant
    Maître WordPress
    1250 contributions

    Bonjour,

    Etes-vous sûr que les requêtes sont bonnes. Pour une migration de local chez l’hébergeur, j’attendrais plutôt quelque chose comme  ‘http://localhost/ancien-domain’  , ‘http://www.nouveau-domain.com’

    D’autre part je n’utiliserais pas de requêtes pour faire ces changements mais soit le script indiqué par C_Lucien soit le plugin “Better-search-replace”. (également à supprimer une fois le travail fait). Dans le cas du plugin, dans la base de données, dans la table wp-options mettre manuellement les nouvelles urls pour home et site url (ou faire la première de vos requêtes avec les bonnes adresses) cela donne l’accès au site. Ensuite 2. télécharger le plugin et le faire fonctionner. Et naturellement, modifier wp- config.

    • Cette réponse a été modifiée le il y a 2 mois et 1 week par  ferman.
    #2273581
    kevinp
    Participant
    Initié WordPress
    14 contributions

    Le logiciel ne parvient pas à modifier wp_option, j’ai cette erreur :

    The script encountered an error while running an AJAX request. If you are using your hosts file to map a domain try browsing via the IP address directly. If you are still running into problems we recommend trying the CLI script bundled with this package. See the README for details.

    #2273632
    kevinp
    Participant
    Initié WordPress
    14 contributions

    J’ai réussi à faire les modifications avec le logiciel mais le problème est toujours le même. Aucune page n’est accessible sauf l’index

     

    #2273636
    ferman
    Participant
    Maître WordPress
    1250 contributions

    Bonjour,

    Je recommencerais tout de la manière suivante.

    1. Faire une nouvelle installation de wordpress .

    2. Quand elle fonctionne, supprimer les tables de la base de données (mais pas la base elle même), exporter/importer la base de données locale. Pas de message d’erreur?

    3.  Transférer le dossier wp-content local (remplacer celui de base chez l’hébergeur),

    4. Dans la base de données, dans wp-options, mettre les adresses correctes pour home et site url

    5. Utiliser “better search replace” pour changer tous les autres liens.

    Cela devrait fonctionner ou alors il y a un autre pb non lié à la migration.

    #2273694
    kevinp
    Participant
    Initié WordPress
    14 contributions

    Est ce que avant de faire l’étape 2 j’ajoute les extensions ? Certaines ont des fichiers dans la base de données locale donc je ne voudrais pas qu’il y ai de conflit.

    #2273705
    ferman
    Participant
    Maître WordPress
    1250 contributions

    Non, n’ajoutez aucun plugin et n’activez pas un autre thème que celui par défaut qui l’est déjà. Plugin et thèmes seront rétablis lors de l’étape 3. Pour être sûr, vous pouvez désactiver les plugins en local et ensuite exporter la base de données et l’importer dans celle de l’hébergeur préalablement vidée (supprimez bien les tables; ne vous contentez pas de les vider). Ensuite vous faites les autres étapes . Vous réactiverez les plugins et votre thème après l’étape 5. Si jamais vous voyez des erreurs lors du transfert des fichiers ou de l’importation la base de données (vous ne devriez pas en voir), notez les.

    J’oubliais: ne transférez pas wp-config ni .htaccess locaux. Conservez ceux qui sont chez l’hôte. Et mieux encore copiez-les sur votre PC par mesure de sécurité.

    • Cette réponse a été modifiée le il y a 2 mois et 1 week par  ferman.
    • Cette réponse a été modifiée le il y a 2 mois et 1 week par  ferman.
    • Cette réponse a été modifiée le il y a 2 mois et 1 week par  ferman.
    #2273735
    kevinp
    Participant
    Initié WordPress
    14 contributions

    Merci, avec vos conseils j’ai enfin réussi à tous modifier et le site est fonctionnel.

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.