[Résolu] Mise en ligne du site – changement d’URL (Créer un compte)

  • WordPress :5.7
  • Statut : résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #2381920
    Kimakito
    Participant
    Padawan WordPress
    90 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Thème utilisé : Thème enfant – OceanWP
    • Extensions en place : Elementor, CPTUI, ACF, Essential addons for elementor, tarteaucitron.js, All-in-one-Seo
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://lejusteplan.fr/staging/

    Problème(s) rencontré(s) : Je viens vers vous pour avoir un coup de main pour la démarche à suivre afin de mettre officiellement en ligne mon site.
    Je l’ai pour le moment mis dans un dossier test dans www.

    Ce dossier s’appelle Staging comme vous pouvez le voir dans l’url. On l’a créé pour que le client fasse ses modifs et modifier le site en fonction de ses demandes et retours.
    Or, je dois publier le site aujourd’hui et là… j’angoisse un peu, la personne avec qui je l’ai créé est en vacances, du coup j’aimerai juste un petit coup de main pour m’y retrouver.

    Sur le principe, je sais qu’il faut que je glisse les éléments du dossier staging dans www.
    Ensuite je vais dans outils > exporter afin de télécharger le fichier qui contient les détails de mon site, au cas où.

    Seulement, là ou je me perds un peu c’est pour :
    – Aller dans la base de données et changer les urls.
    – Savoir comment faire pour mettre à jour tous les urls du site.

    Du coup, j’aimerais beaucoup, vos avis, retours d’expérience, marches à suivre etc.
    J’imagine que pour vous c’est du basique, mais ça me rassurerait d’avoir ce genre de détails. J’ai vraiment peur de cette étape et je serai vraiment seule pour la réaliser…

    Merci pour toute aide, temps passé à m’aider.

    Bon après-midi !

    #2381926
    Li-An
    Modérateur
    Maître WordPress
    25235 contributions

    Bonjour, il y a des tonnes de tutos sur le Web (cherchez “déménager WP dans le répertoire parent”). Vous pouvez passer par une extension de déménagement ou le script https://interconnectit.com/search-and-replace-for-wordpress-databases/. Regardez si une vous inspire, mettez sa référence ici et on vous dira si c’est bon ou pas. Ce tuto me parait fort correct (avec une extension que j’ai testée et qui marche bien) https://www.wpbeginner.com/wp-tutorials/how-to-properly-move-wordpress-from-subdomain-to-root-domain/ (vous pourrez ignorer la dernière étape sur le htaccess).

    Pensez à faire avant toute manip une sauvegarde des fichiers et SURTOUT de la base de données, ce qui vous permettra de revenir en arrière un cas de problème.

    #2382023
    Kimakito
    Participant
    Padawan WordPress
    90 contributions

    Merci @Li-An, je passe à l’action cet après-midi. j’ai vraiment peur de faire une erreur.
    Voici les étapes que je compte mettre en place :

    – Dans un premier temps je fais un export des paramètres du site dans Outils > exporter (je coche tout)
    – Je vais sur OVH, base de données
    – Connection à PHPmyAdmin
    – Export de toutes les tables en .sql
    – Je garde ce fichier en sauvegarde au cas ou
    – J’en ouvre une copie et je change les url (rechercher / remplacer)
    – J’importe ce fichier dans PHPmyAdmin
    – Sur le serveur FTP, je copie le contenu du dossier www/staging/ dans www

    -Ensuite, faut il manuellement changer toutes les urls des pages du site ? (j’ai également vu le plugin Velvet Blues Update URLs ) dans le lien que vous m’avez conseillé.

    Cela vous semble bon ? Y a t il des oublis ?

    Mille mercis 🙂

    • Cette réponse a été modifiée le il y a 19 heures et 30 minutes par Kimakito.
    • Cette réponse a été modifiée le il y a 19 heures et 29 minutes par Kimakito.
    #2382034
    Kimakito
    Participant
    Padawan WordPress
    90 contributions

    Lorsque j’importe la base de données modifiée, j’ai cette erreur.

    Pouvez-vous m’aider s’il vous plaît ?

    #2382038
    Li-An
    Modérateur
    Maître WordPress
    25235 contributions

    Bonjour, Velvet permet de modifier la base sans que vous le fassiez “manuellement” sur votre ordi.

    Alors le truc : après avoir installé WP dans son nouveau répertoire, vous supprimez toutes les tables et vous importez la base de données qui vous intéresse. Il n’y aura plus de problème de conflit (j’ai l’impression qu’il y a mieux, quelqu’un me corrigera peut-être mais c’est comme ça que je fais).

    La modif des URL peut se faire via l’extension Velvet après installation. Mais soit vous le faites avec un éditeur sur votre ordi soit vous le faites via une extension – quoique vous ne  risquez pas grand chose.

     

    #2382041
    ferman
    Participant
    Maître WordPress
    4248 contributions

    D’accord avec Li-An, il faut supprimer (ne pas se contenter de vider) toutes les tables, c’est aussi ce que je fais (mais attention: pas la base de données).

    #2382042
    Kimakito
    Participant
    Padawan WordPress
    90 contributions

    Merci beaucoup de m’aider.
    J’ai bien renommé les url dans le fichier.sql
    J’ai supprimé les tables de la base, désormais lorsque je charge la base de données, j’ai cette erreur… Je ne comprends vraiment pas ! Est-ce OVH qui plante, qu’est-ce que j’ai fait ?

    Dans filezilla j’ai passé mes dossiers et fichiers depuis www/staging vers www et renommé index.html en index_old.html comme ceci 

    Je ne sais plus quoi faire… Je pensais avoir tout fait correctement, je dois le mettre en ligne d’ici une heure et je me sens perdue.

    #2382046
    Li-An
    Modérateur
    Maître WordPress
    25235 contributions

    Vous faites bien l’import via phpMyAdmin ?

    #2382047
    Kimakito
    Participant
    Padawan WordPress
    90 contributions

    Oui tout à fait, via OVH, mais oui PHPmyAdmin.
    Au bout de plusieurs tentatives ça a fonctionné. Par contre mon style a totalement sauté. Il a gardé mes polices, mes images, les liens, mais les réglages du thème sont partis… J’ai fait un import du fichier sauvegarde xml mais du coup j’ai toutes les pages en doubles, le style n’est pas ré apparu…

    https://lejusteplan.fr/

    • Cette réponse a été modifiée le il y a 13 heures et 49 minutes par Kimakito.
    #2382050
    Li-An
    Modérateur
    Maître WordPress
    25235 contributions

    Le style du thème ce n’est pas dans le fichier CSS ? Si le thème est à options, vérifiez que celui-ci propose un export de ses réglages. Mais si vous avez bien copié l’entièreté de la base, il devrait y avoir vos réglages. Posez éventuellement la question au développeur.

    #2382063
    Kimakito
    Participant
    Padawan WordPress
    90 contributions

    Bonjour Li-An, merci pour votre réponse.

    C’était un souci vraiment étrange, en fait, j’ai bien importé mon fichier xml avec les paramétrages du site mais les réglages inhérents au thèmes avaient tous sauté. (couleur de fond, menus, …) mais les css personnalisés étaient bien en place, comme les paramètres élementor et les polices !

    Bref, il m’a fallu quelques heures de correction et tout semble ok ce matin.

    Donc, je tiens à vous remercier grandement pour votre aide.
    Bonne journée 🙂

    #2382064
    Li-An
    Modérateur
    Maître WordPress
    25235 contributions

    Beaucoup de problèmes un peu bizarres – bon, avec OVH je ne m’étonne plus de rien. Content que vous vous en soyez sorti.

    #2382065
    Kimakito
    Participant
    Padawan WordPress
    90 contributions

    C’est ce que j’ai cru comprendre… Un ami développeur senior a eu le même souci que moi sur un site qu’il mettait en ligne il y a quelques temps. Je pensais avoir eu tout faux en terme de méthodologie et que le problème venait de moi mais il semblerait qu’en fait pas mal de monde rencontre des problèmes avec OVH.
    (bon évidemment, je n’exclue pas avoir fait des erreurs, étant novice…)

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.