mise à jour wordpress version php obsolète

  • WordPress :5.2
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 16)
  • Auteur
    Messages
  • #2264185
    Webmaster59
    Participant
    Chevalier WordPress
    163 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : oceanchild
    • Extensions en place :
    • Nom de l’hébergeur : ovh
    • Adresse du site : lille-metropole-traiteur.com

    Problème(s) rencontré(s) : bonjour, un message m’informe de la mise à jour wordpress, mais il semble que cela est impossible du à une version php antérieure. Pouvez-vous me dire quelles sont les pré requis pour faire la mise à jour sans encombre ? J’ai fais un backup du site et de la base de donnée! Merci

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2264265
    Webmaster59
    Participant
    Chevalier WordPress
    163 contributions

    UP

    #2264267
    C_Lucien
    Modérateur
    Maître WordPress
    4250 contributions

    Bonjour,

    depuis votre Manager, vous pouvez activer une version de Php récente, Php 7.2 et au-delà.

    #2264269
    Webmaster59
    Participant
    Chevalier WordPress
    163 contributions

    Question un peu bête mais qu’appelez-vous le manager ? Le tableau de bord ?

    #2264394
    Flobogo
    Modérateur
    Maître WordPress
    15786 contributions

    Bonjour,

    Non, depuis le panneau de gestion (ou CPanel, ou autre terme), chez votre hébergeur.

    Si vous avez encore une version 5.x.y de PHP, je vous conseille de passer d’abord en PHP 7.0.x ou 7.1.x, car un saut de version important pourrait ne pas plaire à vos extensions. Certaines ne seront peut-être pas compatible avec PHP 7.2, et il faudra envisager de les remplacer par des extensions plus récentes.

    En principe, en PHP 7.0.x ou 7.1.x, vous devriez pouvoir mettre WordPress à jour. D’ailleurs, de la même façon, si vous avez du retard dans les mises à jour de WordPress, ne passez pas trop brutalement à la dernière version. Il vaut mieux y aller de version majeure en version majeure (par ex 4.9.x –> 5.0.1 –> 5.1.1 –> 5.2.1)

    #2264490
    Webmaster59
    Participant
    Chevalier WordPress
    163 contributions

    Ok. Pour la version ph, ne faudrait-il pas modifier directement à partir du fichier wp-config ou plutôt ovhconfig (selon l’hébergeur) ?

    #2264492
    PhiLyon
    Modérateur
    Maître WordPress
    23579 contributions

    Bonjour.

    Pour OVH c’est expliqué là https://docs.ovh.com/fr/hosting/configurer-le-php-sur-son-hebergement-web-mutu-2014/

    D’origine, dans le wp-config, il n’y a rien concernant le PHP.

    🙂

     

    #2264498
    yvandupuy
    Participant
    Chevalier WordPress
    163 contributions

    Bonjour, voir dans le fichier ci-joint, où il faut intervenir.

    Inutile de toucher au ovh.config, cela se fait en automatique dès que vous switchez.

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2264501
    Webmaster59
    Participant
    Chevalier WordPress
    163 contributions

    Merci yvandupuy Par contre, je n’ai pas de configuration php … (photo en pj)

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2264685
    Flobogo
    Modérateur
    Maître WordPress
    15786 contributions

    Bonjour,

    Fouillez dans les options de votre panneau de gestion chez OVH … ou adressez-vous à eux directement !

    #2264977
    Webmaster59
    Participant
    Chevalier WordPress
    163 contributions

    Oui j’ai contacté OVH …

    #2265428
    Webmaster59
    Participant
    Chevalier WordPress
    163 contributions

    J’ai finalement réussi à faire la mise à jour wordpress en créant le fichier .ovhconfig pour la mise à jour php.

    • Cette réponse a été modifiée le il y a 3 mois et 1 week par  Webmaster59.
    #2265441
    johnjohn52
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Qu’avez-vous noté dans ce fichier pour que cela fonctionne ?

    Par avance merci pour votre réponse.

     

    #2274139
    espoontintin
    Participant
    Maître WordPress
    806 contributions

    Bonjour Webmaster59.

    Je rencontre le même problème que vous avec l’hébergeur OVH (qui est impossible à joindre, en plus avec 3€ l’appel…).
    Je souhaiterais savoir comment vous avez procédé dans le détail pour mettre à jour ma version de PHP svp.

    Un grand merci à vous

    #2274152
    ferman
    Participant
    Maître WordPress
    1023 contributions

    Bonjour,

     

    Alez dans votre espace client ovh puis dans votre hébergement > options générales et là, normalement  il y a une fenêtre avec votre version de php (pièce-jointe). Vous pouvez changer votre version php là. Sinon il faudra modifier ovh-config. Ce n’est pas difficile mais je ne l’ai jamais fait.

    • Cette réponse a été modifiée le il y a 1 mois par  ferman.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
15 sujets de 1 à 15 (sur un total de 16)
  • Vous devez être connecté pour répondre à ce sujet.