Mise à jour – Perte produits

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 15)
  • Auteur
    Messages
  • #542953
    syldo
    Participant
    Initié WordPress
    48 contributions

    Bonjour,

    Ma boutique woocommerce tourne actuellement sur la version 2.1.12.
    Lorsque je tente une mise à jour vers la 2.2.6, la mise à jour s’effectue correctement.

    Mais, lorsque je retourne sur ma boutique, mes catégories existent toujours, mais les produits ont disparus.
    Et pourtant les produits sont toujours là (y compris le compteur sur les vignettes des catégories).

    Produits avant mise à jour :

    Avant-mise-à-jour.jpg

    Produits après mise à jour :
    Après-mise-à-jour.jpg

    Catégories avec compteurs produits après la mise à jour :
    Catégories-après-mise-à-jour.jpg

    Une idée de ce qui peut provoquer ce problème ?

    Je précise qu’après la mise à jour, voyant ce problème, j’ai actualisé les permaliens, sans succès…

    Merci d’avance

    Ma configuration WP actuelle
    – Version de WordPress : 4.0
    – Thème utilisé : Flavor

    #976947
    Hervel
    Participant
    Maître WordPress
    30288 contributions

    bonjour,

    La taille des vignettes n’a pas changé ?
    Même en utilisant le plugin Regenerate Thumbnails, les vignette n’apparaissent pas ?

    #976948
    syldo
    Participant
    Initié WordPress
    48 contributions

    Comment ça ? Je ne comprends pas bien…
    Car sans parler des vignettes il n’y a rien qui s’affiche, y compris le texte…

    PS: Le problème n’est pas qu’il n’y a pas de visuels sur les vignettes des catégories (je n’ai pas encore configurer cela), mais plus que les articles ne sont plus listés sur la page de chaque catégorie (alors que les produits sont encore présents dans la base – et apparaissent dans le décompte du compteur de catégories).
    Je ne sais pas si je suis assez clair ?

    Merci d’avance,

    #976949
    Hervel
    Participant
    Maître WordPress
    30288 contributions

    non pas clair ce n’est pas ce que je vois sur votre site.

    http://cinepassionmeyzieu.com/categorie-produit/affiches-de-films/affiches-aventure
    là je vois comme sur votre première image
    image+titre+prix+ bouton “ajouter au panier”

    vous avez bien vidé le cache de votre navigateur ?

    #976950
    Lumiere de Lune
    Participant
    Maître WordPress
    19385 contributions

    Avez vous tenté de refaire la mise à jour en manuel ? Vérifié qu’il n’y a pas d’incompatibilités de plugins

    #976951
    Hervel
    Participant
    Maître WordPress
    30288 contributions

    Sur le site c’est encore l’ancienne version de WooCommerce ?
    Ah oui, pas regarder le code source de la page, désactiver tous les plugins, supprimer woocommerce 2.1.12

    puis télécharger sur votre ordinateur la dernière version de WooCommerce
    https://wordpress.org/plugins/woocommerce/

    par FTP dans wp-cotnent/plugins/
    envoyer la dernière version de WooCommerce, puis dans le tableau de Bord , activer le plugin.

    Bien être sous PHP5.4, mémoire allouée non dépassé.

    Ma configuration WP actuelle
    – Version de WordPress :
    – Version de PHP/MySQL :
    – Thème utilisé :
    – Extensions en place :
    – Nom de l’hebergeur :
    – Adresse du site :
    il aurait fallu répondre à toutes les questions.
    https://wordpress.org/plugins/forum-wordpress-fr/

    #976952
    syldo
    Participant
    Initié WordPress
    48 contributions

    Oui, ce qui est sur le site c’est l’ancienne version de woocommerce. Je suis revenu en arrière étant donné que je n’avais aucun produit d’affiché…
    Je n’ai pas essayé la méthode manuelle… (il me faut juste télécharger et uploader les fichiers, c’est ça ?)…

    Pour ce qui est des incompatibilités plugins, pas de meilleure solution que de les activer un à un c’est bien ça ?

    Merci en tout cas pour ces quelques pistes…

    #976953
    Hervel
    Participant
    Maître WordPress
    30288 contributions

    comme je vous ai expliqué, il faut télécharger le plugin qur votre ordinateur puis avec un logiciel FTP envoyé le plugin dans wp-content/plugins/

    mais avant désactiver tous les plugins et un par un et supprimer l’ancienne version de WooCommerce.

    Si votre mémoire allouée est basse, un plufin peut la saturer et ne pas fonctionner correctement.
    Si vous avez PHP5.2 trop bas, la configuration minimum pour WooCommerce est
    WordPress 3.8 or greater
    PHP version 5.2.4 or greater

    #976954
    syldo
    Participant
    Initié WordPress
    48 contributions

    Merci noaneo… Nos messages se sont croisés.

    Alors, voici ce que j’ai fait :
    1. Désactiver toutes les extendions
    2. Mise à jour de PHP vers la version 5.4.33 puis redémarrage de la machine
    3. Suppression des fichiers woocommerce
    4. Installation manuelle, par FTP, de la mise à jour de woocommerce…

    Au final, avec seulement l’extension woocommerce activée, le résultat est exactement le même, aucun produit n’apparait !

    C’est dingue cette histoire…

    #976955
    Hervel
    Participant
    Maître WordPress
    30288 contributions

    Bonjour,

    Peut être le thème alors, il faudrait si d’autres qui utilisent ce thème, on le même souci ou poser la question à l’auteur du thème.

    #976956
    Hervel
    Participant
    Maître WordPress
    30288 contributions

    Je suis un peu tatillon, mais par prudence vos plugins sont bien compatible WP4.0 ou la dernière mise à jour 2014 ?

    certains plugins même désactivés peuvent continuer à perturber un site c’est parfois on demande de renommer sur FTP le dossier plugins par pluginsX.
    Vous pouvez essayer renommer le dossier plugins en pluginsX
    puis créer un nouveau dossier plugins et mettre dedans que WooCommerce.

    #976957
    syldo
    Participant
    Initié WordPress
    48 contributions

    Je reviens après les tests…

    J’ai bien changé le nom du répertoire plugin, puis créé à nouveau ce répertoire en ne copiant que le dossier woocommerce dedans…
    Une fois la mise à jour effectué, la mise à jour des traductions, la mise à jour de la base de données (nécessaire), le problème reste le même !

    Je viens de questionner le concepteur du thème… et selon sa réponse je serai fixé… Je reviens poster la réponse d’ici quelques jours.
    Merci bien en tout cas…

    #976958
    Hervel
    Participant
    Maître WordPress
    30288 contributions

    Bonjour,

    merci de nous tenir au courant.

    #976959
    syldo
    Participant
    Initié WordPress
    48 contributions

    Ah… ça semble s’éclaircir un peu.
    Le créateur du thème n’est pas certain que son thème soit compatible avec la dernière version.

    Il doit vérifier et travailler dessus. Donc mon problème pourrait bien venir de cela…

    Je poste la réponse dès que je l’ai.

    Merci pour toute l’aide en tout cas.

    A bientôt,

    #976960
    Hervel
    Participant
    Maître WordPress
    30288 contributions

    Bonjour,

    merci

15 sujets de 1 à 15 (sur un total de 15)
  • Vous devez être connecté pour répondre à ce sujet.