[Résolu] Mise à jour impossible vers 5.3

  • WordPress :5.2
  • Statut : résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2285743
    Patrick69
    Participant
    Initié WordPress
    21 contributions

    Bonjour,

    Ma configuration WP actuelle 5.2

    • Version de PHP/MySQL : 7.2.24
    • Thème utilisé : WPocean 1.7.2
    • Extensions en place : Woocommerce, All In on Seo, Jet pack (désactivé), REST API (désactivé), Store front Designer (désactivé), Askimet (désactivé).
    • Nom de l’hébergeur : Ex2
    • Adresse du site : patrickhuet.net

    Problème(s) rencontré(s) :

    Bonsoir,

    Je vous contacte, car depuis plusieurs jours, j’essaie d’effectuer la mise à jour vers WordPress 5.3, en cliquant sur le bouton, mise à jour automatique, mais cela ne fonctionne pas.

    L’image de travail (petits points qui tournent) tourne 8 ou 10 secondes, puis s’arrête.

    A tout hasard, j’avais aussi désactivé All In one seo, aucun incidence, je l’ai alors mis à jour hier, rien non plus.

    – Quand je reclique sur le bouton de “mise à jour”, je vois apparaître la mention “mise à jour en cours”, mais en définitive rien se se passe.

    J’avais Jetpack, je l’ai désactivé. De même que Rest API. Mais aucune incidence.

     

    Ce qui m’étonne, c’est que j’ai un autre site chez le même hébergeur (mais version PHP inférieure  – 7.2.23), avec Jet Pack et All In one SEO, et la mise à jour s’est effectuée en quelques secondes.

    Alors, je ne comprends pas.

    Quelqu’un pourrait-il m’aiguiller au sujet de ce problème ? Je vous en remercie par avance.

    • Ce sujet a été modifié le il y a 3 semaines et 5 jours par Patrick69.
    #2285796
    momofr@free.fr
    Modérateur
    Maître WordPress
    2808 contributions

    Salut, je vois que ton thème n’est pas à jour, les mises à jours des thème et extensions fonctionnent ?

    #2285967
    Patrick69
    Participant
    Initié WordPress
    21 contributions

    Bonsoir momofr,

    J’avais attendu que la mise à jour de WordPress se fasse avant de procéder à celle du thème.

    Comme la dernière version de WPocean a été publiée après celle de WordPress 5.3, je pensais qu’il fallait faire de Worpress avant de passer à la mise à jour de “ocean”  (pour des raisons de compatibilité) Mais peut-être que je me trompe, car je ne connais pas le domaine.

    En ce qui concerne les extensions,  je n’ai que All in one SEO en actif. Et pour lui, j’ai effectué la dernière mise à Jour.

    Il ne reste que Woocommerce (mais rien n’est prévu).

    Réponse surprenante aujourd’hui.

    A propos, je viens de renouveler le bouton de mise à jour voici quelques minutes, et cette fois, j’ai obtenu une réponse qui me déroute.

    J’en fais ici un copier/coller :
    <h1 class=”western”>Mettre à jour WordPress</h1>
    Téléchargement de la mise à jour depuis https://downloads.wordpress.org/release/fr_FR/wordpress-5.3.zip…

    L’authenticité de wordpress-5.3.zip n’a pas pu être vérifiée car aucune signature n’a été trouvée.

    <b>Warning</b>: Error while sending QUERY packet. PID=8466 in <b>/home/patrickhuet/public_html/wp-includes/wp-db.php</b> on line <b>2007</b>
    <h1 class=”western”>Erreur de reconnexion à la base de données</h1>
    Cela signifie que nous avons perdu le contact avec le serveur de base de données à l’adresse localhost. Cela peut signifier que le serveur de votre base de données ne fonctionne plus.

    • Confirmez-vous que le serveur de la base de données fonctionne correctement ?
    • Confirmez-vous que le serveur de la base de données n’est pas en train de plier sous le nombre de requêtes ?

    Si vous n’êtes pas sûr de connaître ces termes, vous devriez probablement contacter votre hébergeur.

     

    En résumé, je ne comprends pas la réponse.

     

    Donc, à part le

     

     

    #2285968
    Patrick69
    Participant
    Initié WordPress
    21 contributions

    Petite précision,

    Je suis actuellement connecté à mon C(Panel.

    J’ai remarqué que je possède deux base de données. J’ai cliqué dessus pour demander leur vérification, et toutes les sont “OK”.

    Donc, apparemment, tout est bon de ce côté.

    De même, comme je peux me connecté -en anonyme- sur mon site, je pense que c’est OK aussi du côté du serveur.

     

    Pensez-vous que je doive faire la mise à jour du thème ?

    Ou bien cela peut-il générer des problèmes de compatibilité avec Mon WordPress 5.2 ?

    #2285969
    Patrick69
    Participant
    Initié WordPress
    21 contributions

    Bonne nouvelle !

    j’ai essayé à l’instant une quatrième fois en l’espace de 20 minutes, et. cela a marché !

    Je ne connais pas le fin fond de l’affaire, mais la mise à jour a fonctionné.

    Merci momofr pour ton aide.

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.