[Résolu] mise à jour de php pour les nuls (Créer un compte)

  • WordPress :6.4
  • Statut : résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2474468
    jeromebouin
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.0.33
    • Thème utilisé : lucienne,
    • Extensions en place : jetpack, askimet, health check & troubleshooting, hellodolly, smash ballooninstagram feed
    • Nom de l’hébergeur : ovh
    • Adresse du site : jeromebouin.fr

    Problème(s) rencontré(s) :

    Bonjour, je ne suis pas à l’aise avec la gestion de mon petit site perso et je constate ce message :

    « Votre site fonctionne sur une version obsolète de PHP (7.0.33), qui ne reçoit pas de mises à jour de sécurité et ne sera bientôt plus prise en charge par WordPress. Assurez-vous que PHP est à jour sur votre serveur dès que possible. Sinon, vous ne pourrez plus mettre à niveau WordPress à l’avenir. »

    Y a-t-il une façon de faire cela simplement ? Un tuto pas à pas pour les nuls ? Les infos dispos sur wordpress me semblent peu accessibles à quelqu’un comme moi.

    Je vous remercie.

    #2474469
    ferman
    Participant
    Maître WordPress
    6998 contributions

    Bonjour,

    Y a-t-il une façon de faire cela simplement ?

    Ce n’est pas compliqué: vous allez dans votre hébergement chez ovh. Vous verrez un écran contenant ce qui est montré en pièce jointe. Dans « configuration » , « version globale PHP » vous cliquez sur les trois points puis vous suivez les indications. Il y a deux étapes et vous arrivez sur la liste des versions PHP disponibles. Vous verrez aussi une fenêtre « environnement ». Dans votre cas il y aura probablement écrit « stable ».  Vous choisissez PHP 7.4. Ensuite retournez sur le site et vérifiez que tout fonctionne; en effet, votre thème n’a pas été mis à jour depuis longtemps et risque de ne pas supporter les versions modernes de PHP (mais devrait accepter 7.4 sans problème).

    Si aucun problème n’apparaît sur votre site, mettez à jour les extensions (vous ne pourrez malheureusement pas mettre à jour le thème).

    PHP 7.4 sera bientôt obsolète et il faudra donc passer rapidement à une version supérieure de php (8 ou plus). Vous pourrez déjà essayer de le faire depuis l’espace OVH. Il faudra choisir « environnement stable 64 », puis passer en 8.0. Si c’est bon, essayez 8.1 voire 8.2 ou 8.3. Le problème risque de venir du thème qui ne suivra peut-être pas. Dans ce cas il faudra simplement revenir à la dernière version PHP acceptée. Et penser à chercher un nouveau thème.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2474622
    jeromebouin
    Participant
    Initié WordPress
    2 contributions

    Bravo. Merci !

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.