[Résolu] mise à jour de PHP 7.x

  • WordPress :5.2
  • Statut : résolu
  • Ce sujet contient 10 réponses, 2 participants et a été mis à jour pour la dernière fois par Hervel, le il y a 2 semaines.
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #2292367
    Willou
    Participant
    Initié WordPress
    29 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : PHP = 5.6.40-0+deb8u7 / MySQL = ver 14.14, distrib 5.5.62 sur Debian 8
    • Thème utilisé : BlackFyre
    • Nom de l’hébergeur : VPS OVH

    Bonjour à tous,

    Mon problème concerne WordPress mais indirectement. Comme vous le savez WordPress demande à présent une mise à jour de PHP 7.0 minimum. Je cherche donc un tuto pour m’aider a upgrader de PHP 5.6 vers PHP 7.0 ou supérieur sur debian 8.

    J’ai trouvé plusieurs tuto mais qui ne fonctionnent pas, peut-etre parce que “Dotdeb” n’est plus supporté…

    J’ai essayé cela : https://phil.writesthisblog.com/php-7-debian/

    et : https://fr-wiki.ikoula.com/fr/Installer_PHP_7_sur_son_serveur_d%C3%A9di%C3%A9

    Mais rien à faire, cela ne fonctionne pas. Auriez-vous le lien d’un tuto qui fonctionne ou un site plus adapté pour y formuler ma demande ?

    En vous remerciant,

    Wil

    #2292398
    Willou
    Participant
    Initié WordPress
    29 contributions

    J’ai trouvé ce qui ne fonctionnait pas sur ces deux tutos : la 1ere ligne pour mettre à jour dotdeb.list est fausse, le chemin n’est pas valide, alors j’ai modifié via le FTP ce dotdeb.list en ajoutant moi-même “deb http://packages.dotdeb.org jessie all”

    J’ai suivi alors la procédure du 2eme lien et faisant cohabiter les deux versions de PHP parce que sinon j’ai vu ailleurs que MySQL serait à réinstaller également (j’ai déja essayer en upgradant vers debian 9 et cela n’a pas fonctionné).

    Du coup, j’ai fait la mise a jour et un ‘php -v’ me dit bien que je suis à présent sous PHP 7.0.

    Néanmoins lorsque je retourne sur WordPress, cela me dit tjrs : “Mise a jour de PHP necessaire” “Wordpress a détecté que votre site tourne sur ‘un’ version non sécurisée de PHP”.

    Avez-vous des suggestions ?

    • Cette réponse a été modifiée le il y a 2 semaines et 1 jour par Willou.
    • Cette réponse a été modifiée le il y a 2 semaines et 1 jour par Willou.
    #2292408
    Hervel
    Participant
    Maître WordPress
    30689 contributions

    Bonjour,
    Prérequis est PHP 7.3
    https://fr.wordpress.org/about/requirements/

    Le fichier info.php indique quelle version ?

    <?php
    phpinfo();
    ?>

    https://gist.github.com/tattali/58564a8c7233098fd207bcf42ed14821

    Ou poser la question sur le forum d’OVH, section VPS
    http://community.ovh.com/c/cloud/vps

    D’après cette discussion, il faut migrer vers Debian 9, voir 10, si je comprends bien.
    http://community.ovh.com/t/probleme-vps-wordpress-php-5-6/13847

     

    #2292412
    Hervel
    Participant
    Maître WordPress
    30689 contributions
    #2292414
    Willou
    Participant
    Initié WordPress
    29 contributions

    Merci pour tous ce temps et ces liens que vous m’avez fournis, il serviront peut-être a quelqu’un qui possède un hébergement Web, mais comme j’ai un VPS, ils ne peuvent pas me servir.

    J’ai essayé les lignes de commandes que vous m’avez fourni, pour la seconde ‘sudo add-apt-repository -y ppa:ondrej/php’ et j’obtiens un “command not found”.

    Je vais suivre votre conseil aller sur le forum d’OVH et sinon me louer un VPS sous debian 9, ca sera encore plus simple.

    En vous souhaitant une bonne fin de journée,

    Merci encore pour le temps que vous m’avez accordé,

    Bien cordialement,

    Wil

    #2292416
    Hervel
    Participant
    Maître WordPress
    30689 contributions

    @willou-2 ,
    Pourquoi ne pas faire la migration de Debian 8 à Debian 9 ou Debian 10 ?

    #2292422
    Willou
    Participant
    Initié WordPress
    29 contributions

    J’ai déjà essayé, il m’est demandé bcp d’informations sur phpmyadmin pour le reconfigurer et cela a échoué. La base de donnée était donc cassé et les sites ne répondaient plus.

    Je suis très content de l’option Snapshot que j’ai prise chez OVH, c’est une source d’apaisement qd tout est cassé 🙂

    • Cette réponse a été modifiée le il y a 2 semaines et 1 jour par Willou.
    #2292424
    Hervel
    Participant
    Maître WordPress
    30689 contributions

    Ok, c’est pour ça que je n’ai jamais pris un VPS, il faut des connaissances.
    Merci de nous tenir au courant.

    #2292427
    Willou
    Participant
    Initié WordPress
    29 contributions

    Le pb avec les serveurs mutualisés c’est leur lenteur. De plus le nombre de base de données disponible sur les hébergement  web d’OVH est de 4, alors que je fais tourner 6 sites WordPress. Sur un VPS le nombre de bases de données n’est pas limité.

    Je vous tiendrai au courant, cela pourra servir aux autres.

    #2292548
    Willou
    Participant
    Initié WordPress
    29 contributions

    Bonjour,

    je reviens a nouveau vers vous comme convenu !

    Finalement, j’ai loué un nouveau VPS chez OVH. J’ai pris une Debian 10 ! Par contre cette version de l’OS est livré “nue” c’est à dire sans application : il faut alors installer tous les services sur cette version de Linux. Si on souhaite avoir une config “clé en main” adaptée a WordPress, c’est uniquement la location d’un VPS en Debian 8…

    Du coup je me fais aidé par la communauté OVH sur le forum : https://community.ovh.com/t/upgrade-vers-debian-9/24088/9

    Les conseils prodigués par les internautes sont très pertinents (surtout l’un d’entre eux pour l’instant).

    Je me sers des tutos : https://www.cyberciti.biz/faq/how-to-install-lamp-on-debian-10-buster/ et https://www.digitalocean.com/community/tutorials/how-to-set-up-a-firewall-with-ufw-on-debian-10 et https://www.digitalocean.com/community/tutorials/initial-server-setup-with-debian-10

    Là je dois rechercher si je dois installer MariaDB ou MySQL parce que mes sites sont actuellement installés sous MySQL et je ne sais pas si la restauration de mes sites fonctionnera avec MariaDB. Cette nouvelle version de base de donnée à l’air de devenir le standard avec bcp d’améliorations de MySQL, mais la compatibilité existe t’elle, pour l’instant je n’ai pas la rréponse… En tout cas, Maria DB fait drôlement envie quand on lit ça : https://mariadb.com/kb/fr/mariadb-vs-mysql-features/

    A+ !

     

     

    • Cette réponse a été modifiée le il y a 2 semaines par Willou.
    #2292565
    Hervel
    Participant
    Maître WordPress
    30689 contributions

    Bonjour,
    Merci de nous tenir au courant.
    Depuis 1997, j’ai toujours eu que des hébergements mutualisés, je n’ai jamais ressenti une lenteur si grande, mais bon, chacun voit midi à sa porte, je respecte votre avis.
    On peut commander des bases de données supplémentaires, si besoin.
    https://docs.ovh.com/fr/hosting/24-days/day06/#creation-dune-base-de-donnees-mutualisee

    Il y a d’autres hébergeurs, parfois mieux.

    Par exemple WPFR est chez o2switch.
    https://www.o2switch.fr/hebergement-illimite/

    Planethoster
    https://www.planethoster.com/fr/Hebergements-World

    Très souvent, j’ai lu que le top était Infomaniak.
    https://www.infomaniak.com/fr/hebergement/web-et-mail/hebergement-web-et-mail

    Si vous pouvez avoir un VPS et tout installer, tant mieux pour vous.
    Restaurer votre site avec MySQL puis après migrer sur MariaSQL.

    Bonne continuation, bon courage.

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.