Mise à jour de Paypal

  • WordPress :4.9.4
  • Statut : non résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2160981
    Karsatag
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : ?
    • Thème utilisé : onepress
    • Extensions en place : plusieurs
    • Nom de l’hébergeur : wordpress
    • Adresse du site : the-red-joker.com

    Problème(s) rencontré(s) :

    Bonjour,

    Pour Juin 2018, PayPal effectue des mises à jour de sécurités sur ses serveurs.

    Je suis invitée à contacter mon hébergeur afin de m’assurer que votre serveur dispose bien de tout les prérequis.

    1 – Mise à niveau vers TLS 1.2 et HTTP/1.1 : Votre serveur doit pouvoir prendre en charge ces protocoles.

     

    Remarque : il vous faudra au minimum une version d’OpenSSL supérieure ou égale à 1.0.1 ainsi que si vous utilisez cURL, une version supérieure ou égale à 7.34.0.

     

    Vérifiez également que votre serveur dispose des certificats racine (Root certificate) Verisign G5 : https://knowledge.symantec.com/support/mpki-for-ssl-support/index?page=content&actp=CROSSLINK&id=SO5624

     

    2 – Mise à niveau du certificat SSL : Afin de pouvoir décrypter les nouveaux certificats, votre site Web doit pouvoir prendre en charge l’utilisation de l’algorithme de signature SHA-256.

     

    ==> Pour les 2 points ci-dessus, je vous invite à contacter votre hébergeur pour vérifier si tout est en ordre.

     

    3 – Norme HTTPS pour les envois de vérifications (Post Back) IPN

    Ceci ne signifie pas que votre site doit être en HTTPS, cela signifie juste que lorsque votre script IPN envoie sa réponse à PayPal, celui-ci doit utiliser des normes de sécurités correctes.

    Afin de s’en assurer, je vous invite à contacter le développeur de votre script IPN afin de s’assurer que la connection se fasse correctement.

     

    Il est donc important que vous vérifiez que, pour tous les appels API ainsi que pour les post-back IPN, votre site soit capable de prendre en charge ces nouvelles normes.

    Est-ce ok ? Ou mieux, puis-je vérifier par moi-même ?

    Merci, belle fin de journée

    #2161003
    Li-An
    Modérateur
    Maître WordPress
    19615 contributions

    Bonjour, cela n’a rien à voir avec WP, je déplace votre sujet. Et seul votre hébergeur peut vous répondre.

    #2161008
    Karsatag
    Participant
    Initié WordPress
    3 contributions

    Ah ! Je ne suis pas sur le forum de la Communauté WordPress ?

    Mon hébergeur est WordPress…

    Où a été déplacé le sujet, s’il vous plaît ?

    Merci

    #2161010
    Li-An
    Modérateur
    Maître WordPress
    19615 contributions

    En effet, vous êtes chez WP.com, vous n’êtes pas au bon endroit. Ce forum ne traite que du logiciel WordPress et ne peut pas vous aider pour un site hébergé chez WordPress.com. Allez directement sur leur propre forum : https://fr.forums.wordpress.com/

    #2161016
    Karsatag
    Participant
    Initié WordPress
    3 contributions

    Je vous remercie.  Je suis le lien proposé.

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.