Mise a jour base de données Woocommerce

  • WordPress :5.2
  • Statut : non résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #2298069
    Dge
    Participant
    Chevalier WordPress
    103 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.5.3
    • Thème utilisé : perso
    • Extensions en place : woocommerce
    • Nom de l’hébergeur : local
    • Adresse du site : local

    Problème(s) rencontré(s) :
    <div id=”gdbbx-quote-wrapper-164723″>

    Bonjour la communauté.

    Je dois mettre à jour un site qui existe depuis un certain temps.
    j’ai donc installé une copie du site et sa bdd en local sur wamp. J’ai mis à jour WordPress, WooCommerce et les plugins présent. Tout est à jours mais dans l’admin, woocommerce demande la mise à jour de sa base de données.
    Lorsque je clique sur le bouton pour faire cela des erreurs php s’affichent. Voir ci dessous.

    erreur php

    Et la mise à jour ne se fait pas.

    Une autre méthode est suggérer en utilisant wp_cli
    Mais là j’ai beau lire de nombreux tuto je ne comprend pas comment faire. Je ne comprend même pas ou et comment l’utiliser.
    Avez vous déjà été confronté a ce problème ? Et surtout comment avez vous réussi a le résoudre.

    Merci par avance.
    ++ Dgé

    </div>

    #2298223
    ferman
    Participant
    Maître WordPress
    1859 contributions

    Bonjour,

    Je n’ai pas eu ce problème mais d’autres l’ont eu. Regardez cet article et Essayez les modifications proposées. Si ça ne suffit pas regardez aussi cet article . Il y a aussi un lien pour CLI (dans le premier article) mais là je ne peux pas dire; je n’ai pas eu besoin d’installer ça. Je n’utilise pas wamp mais xampp mais il y a des ressemblances et  là aussi pour que ça fonctionne parfaitement il y a des paramètres à modifier  dans les dossiers apache et mysql (voir pièce jointe).

    J’espère que ça vous sera utile. Merci de faire un retour si ça marche (pour les autres participants du forum).

    • Cette réponse a été modifiée le il y a 3 jours et 22 heures par ferman.
    • Cette réponse a été modifiée le il y a 3 jours et 22 heures par ferman.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2298397
    Dge
    Participant
    Chevalier WordPress
    103 contributions

    Cela ne fonctionne pas. Je suis en panique

     

    #2298410
    ferman
    Participant
    Maître WordPress
    1859 contributions

    Bonjour,

    Il y a beaucoup d’exemples de cette erreur sur le net. Je comprends qu’elle sera peut-être éliminée avec woocommerce 4.

    Pour le moment un “snippet “est proposé. Copiez/collez le code contenu dans la dernière réponse de ce lien. Comme vous êtes en local ça ne pose pas de problème. Je suppose que vous avez une copie des fichiers de votre site local et de sa base de données sinon faites les sauvegardes nécessaires.  Mettez ensuite le code directement dans functions.php de votre thème.

    Si ça ne marche pas, si c’était moi, je réinstallerais WAMP, modifierais les paramètres  comme indiqué précedemment et referais l’installation de wp /woocommerce.

    Je dois mettre à jour un site qui existe depuis un certain temps.

    Depuis longtemps: sans mise à jour? C’était un site en ligne? Il peut y avoir un problème de compatibilité entre mysql chez l’hébergeur et mysql chez vous si les versions sont trop différentes.

    Je commencerais par essayer le “snippet”.

     

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.