Miniatures qui ne renvoient plus aux articles associés

  • WordPress :5.2
  • Statut : non résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #2277828
    BatLock
    Participant
    Initié WordPress
    6 contributions

    Bonjour,

    Ma configuration WP actuelle :

    – Version de WordPress : 5.2.3
    – Version de PHP/MySQL : 5.6.40 / 5.6.39
    – Thème utilisé : Nirvana
    – Thème URI : https://www.cryoutcreations.eu/wordpress-themes/nirvana
    – Extensions en place : AddToAny Share Buttons (1.7.37), Cryout Serious Theme Settings (0.5.10), Forum_wordpress_fr (4.2), GCZ Facebook Page Like Box (1.0), HTML5 Responsive FAQ (2.8.3), Insert Pages (3.4.6), Instagram Feed (1.12.2), Maintenance (3.7.1), MC4WP: Mailchimp for WordPress (4.5.4), MetaSlider (3.14.0), Nimble Portfolio (3.0.1), Nimble Portfolio – Default+ Skin (1.0.5), Post Expirator (2.4.0.1), Quick Page/Post Redirect Plugin (5.1.8)
    – Adresse du site : https://www.theatredelaplume.fr
    – Nom de l’hébergeur : Apache

    Problème(s) rencontré(s) :

    Alors que tout fonctionnait encore bien hier, depuis ce matin, quand on va sur la page “Evenements”, les miniatures ne renvoient plus aux articles (nimble-portofolio) associés, j’ai le message d’erreur suivant : “Image cannot be loaded. Make sure the path is correct and image exist.”

    Ce que je ne comprends pas, c’est que le code sur la page “Evenement” est le même (avec un shortcode particulier bien sûr) que celui de la page “Bébé” (par exemple) où la les miniatures renvoient sans problèmes aux articles associés.

    J’ai vérifié les pages, les articles portfolio associés, rien n’a changé. Je n’ai pas fait de mise à jour ni même touché au site depuis plus d’une semaine… D’où peut bien venir ce nouveau problème ? Et comment le régler?

    Merci d’avance

     

    BatLock

    • Ce sujet a été modifié le il y a 3 weeks et 6 jours par  BatLock.
    #2277868
    ferman
    Participant
    Maître WordPress
    1188 contributions

    Bonjour,

    Voilà ce qu’on observe:

    Entre ce qui marche et ce qui ne marche pas , les images ne sont pas appelées de la même façon.

    Ce qui marche, par exemple:  http://www.theatredelaplume.fr/portfolio/leoudoudou/” target=”” rel=”nimblebox[nimble_portfolio_gal_pro]”
    Ce qui ne marche pas, par exemple: http://www.theatredelaplume.fr/portfolio/improvizart/” data-rel=”nimblebox[nimble_portfolio_gal_pro]”

    Dans le premier cas, le lien fonctionne que l’on soit en http ou https.
    Dans le second cas , le lien fonctionne uniquement si l’on remplace http:// par https:// ou simplement// (ou data-rel= par target=””rel=”).

    Par ailleurs, vous avez beaucoup de contenu mixte: en fait toutes les images du portfolio et bien d’autres qui sont de la forme: http://www.theatre de la plume…etc.

    Donc pour résumer: Vous devriez déjà (après avoir sauvegardé votre base de données. important!) passer tous vos liens en https. Pour cela, il y a plusieurs possibilités. J’utilise l’extension “better search replace”. Téléchargez l’extension et utilisez-la comme indiqué ici et dans cette vidéo (regarder la partie entre 3mn15 et 4mn30.) Par rapport à cette vidéo: sélectionnez toutes les tables.

    Dans le champ rechercher mettez: http://www.theatredelaplume.fr

    et dans le champ remplacer: https://www.theatredelaplume.fr

    et faites d’abord un essai à blanc comme indiqué.

    Cela devrait rétablir les liens et supprimer le triangle jaune d’avertissement sur votre cadenas.
    Une fois terminé, désactivez et supprimez l’extension.

    Ensuite ,mais c’est un autre problème, il faudra créer des redirections afin que votre site ne soit plus accessible qu’en https.

    Comment avez-vous fait votre passage http/https?

    • Cette réponse a été modifiée le il y a 3 weeks et 6 jours par  ferman.
    • Cette réponse a été modifiée le il y a 3 weeks et 6 jours par  ferman.
    • Cette réponse a été modifiée le il y a 3 weeks et 6 jours par  ferman.
    #2277884
    BatLock
    Participant
    Initié WordPress
    6 contributions

    Bonjour,

     

    Tout d’abord merci pour votre réponse !

    J’ai utilisé l’extension “Better Search Replace” (après avoir sauvegardé ma base de données) et passé tous les liens donc en https au lieu de http.. mais ça n’a pas réglé le problème semble-t-il. J’ai toujours le même message d’erreur quand je clique sur les miniatures de “Evenements”.

    Autre étrangeté, si je fais un clique droit sur la miniature et “ouvrir le lien dans un nouvel onglet”,  l’article associé s’ouvre et s’affiche sans problème.

    A vrai dire je débute dans le domaine. Par exemple, je n’ai aucune idée de l’endroit où vous avez trouvé les codes énoncés au début de votre réponse ( “http://www.theatredelaplume.fr/portfolio/leoudoudou/&#8221target=”” rel=”nimblebox[nimble_portfolio_gal_pro]”), et de fait je ne peux pas modifier ces codes pour qu’ils correspondent à ce que vous notez comme étant une solution au problème.

    Concernant votre question en fin de message : comment j’ai fait le passage http/https ? Je ne l’ai pas fait. Il me semble avoir vu passer un message sur mon tableau de bord m’indiquant que le site n’était pas protégé mais je n’ai aucun souvenir d’avoir fait une quelconque manipulation pour y remédier. J’ai simplement mis WordPress à jour (la personne qui s’occupait du site avant moi ne l’avait pas fait) ainsi que les extensions.
    J’ai toujours un souci avec le PHP qui n’est pas à jour mais je poserai les questions concernant ce point dans un autre sujet 🙂

     

     

     

     

    • Cette réponse a été modifiée le il y a 3 weeks et 6 jours par  BatLock.
    #2277887
    ferman
    Participant
    Maître WordPress
    1188 contributions

    Bonsoir,

    Vous pouvez voir qu’au moins votre cadenas est maintenant vert sans message d’erreur. C’est déjà un progrès non négligeable.

    Quant au problème des liens non fonctionnels, Je craignais  un peu que le changement avec better search replace ne suffise pas  mais il fallait essayer. Donc maintenant, c’est quand on remplace https par http ou simplement //  que cela fonctionne (ou target rel par… ) comme dit précédemment.

    Par exemple, je n’ai aucune idée de l’endroit où vous avez trouvé les codes énoncés au début de votre réponse

    Je ne vous l’ai pas dit car c’est un peu long à expliquer et ça n’apporte pas grand chose. C’est dans l’inspecteur Firefox . Là on peut voir beaucoup de choses et simuler des changements. Mais on ne peut pas les pérenniser. Autrement dit, on peut diagnostiquer (parfois) le problème, voir ce qu’il faudrait faire pour y remédier , mais hélas pas y remédier.

    Pour cela, il faut vous rendre dans  votre extension Nimble portfolio (est-elle à jour?) et voir  les liens des images. Et rectifier en tenant compte de ce qui précède. Ce doit être un réglage mais c’est sans garantie; je ne connais pas ce plugin et je n’ai pas de portfolio pour tester . Une autre possibilité est d’effacer/remettre les images, en faisant attention à la syntaxe du lien.

    EDIT: Bon, je viens de regarder la page de l’extension, ce que je n’avais pas encore fait. Le plugin n’est plus suivi depuis deux ans et n’a pas été testé avec les dernières versions de wordpress . Le problème peut donc aussi venir de là. Il faudra de toute façon trouver une alternative à brève échéance.  Dites-moi si vous arrivez à résoudre le problème en regardant dans les réglages du plugin.

     

    #2277955
    BatLock
    Participant
    Initié WordPress
    6 contributions

    Bonjour,

    Quand vous parlez de la syntaxe du lien, c’est celui dans l’inspecteur Firefox (ou Chrome) ou juste le lien donné par le portofolio ?

    Effectivement l’extension n’est plus suivie depuis deux ans, cela dit il y a une semaine tout fonctionnait correctement et je n’ai rien changé entre temps.. Est-ce que les éléments peuvent se dérégler comme ça de manière aléatoire au bout d’un moment ?
    De même pourquoi cette erreur ne surviendrait que sur une page quand les autres (Enfant, Bébé et Escales) qui utilisent le même procédé fonctionnent bien ?

    Je vais tenter d’enlever et remettre l’image pour voir quand même 🙂

    Est-ce qu’il existe une autre extension qui proposerait le même service que NimblePortfolio et qui serait tenue à jour ?

    Ou bien vais-je devoir modifier la structure du site et refaire tous mes articles sous une autre forme ?

    Quoiqu’il en soit, encore une fois, merci de prendre du temps pour me répondre 🙂

    #2277980
    ferman
    Participant
    Maître WordPress
    1188 contributions

    Bonjour,

    Quand vous parlez de la syntaxe du lien, c’est celui dans l’inspecteur Firefox (ou Chrome)

    Je vous explique pour firefox. Ce doit être semblable pour chrome mais je ne l’utilise pas.

    1.Démarrez l’inspecteur firefox (ou chrome)

    2. sur la page événement, l’inspecteur (à gauche) étant coché, cliquez sur l’image. Toujours à gauche dans la colonne inspecteur, vous voyez le code html relatif à cette image. C’est-à-dire:

    <a href="https://www.theatredelaplume.fr/portfolio/improvizart/" data-rel="nimblebox[nimble_portfolio_gal_pro]">

    Vous voyez le lien vers l’article souhaité. (<ahref https…etc) et la façon dont il se termine (data-rel). Si vous faites la même chose pour les liens des autres pages, vous verrez qu’ils se terminent différemment.

    En revenant à la page événements, cliquez droit sur le lien <ahref https…etc et faites : “modifier comme html”. Vous avez un cadre contenant ce lien.

    Là vous pouvez tester les modifications dont je vous parlais précédemment: remplacement https:// par http:// ou simplement par // ou remplacement data-rel par target”” rel. Ensuite, cliquez dans le vide , à gauche du cadre pour le fermer. Faites-le et essayez les liens.  Donc le problème est là. Mais je ne sais pas ou modifier ces liens de manière perenne. Sans doute dans le plugin, vous avez plusieurs options pour les liens?

    De même pourquoi cette erreur ne surviendrait que sur une page quand les autres (Enfant, Bébé et Escales) qui utilisent le même procédé fonctionnent bien ?

    Justement, comme vous le voyez ci-dessus et contrairement aux autres pages, la page événements n’a pas le même système pour renvoyer vers l’article correspondant (data-rel).

    Enfin, il y aurait peut-être une solution (un bricolage) pour changer le lien dans la base de données mais je ne suis pas chaud pour essayer. Si vous souhaitez le faire, il faudra bien sauvegarder la base de données.

    Tenez-moi au courant.

    • Cette réponse a été modifiée le il y a 3 weeks et 5 jours par  ferman.
    #2278040
    ferman
    Participant
    Maître WordPress
    1188 contributions

    Le problème a été reporté plusieurs et ça ne date pas  d’hier.  Par exemple:  https://wordpress.org/support/topic/when-clicking-zoom-error-pops-up/

    et  https://wordpress.org/support/topic/image-cannot-be-loaded-8/. Regardez en particulier ce qui est proposé dans le premier lien.

     

    • Cette réponse a été modifiée le il y a 3 weeks et 5 jours par  ferman.
    #2278043
    Li-An
    Modérateur
    Maître WordPress
    22521 contributions

    Bonjour, même si ça a fonctionné, le conseil de @ferman est judicieux : si l’extension n’est plus suivie, il faut que vous réfléchissiez à trouver une alternative. À moyen terme, les problèmes vont se succéder pouvant aller jusqu’au piratage (un cas extrême mais pas impossible) de votre site.

    #2278441
    BatLock
    Participant
    Initié WordPress
    6 contributions

    @Ferman :

    J’ai déjà mis en place le conseil donné dans le premier lien que vous donnez, à dire vrai c’était déjà le cas avant que l’erreur n’apparaisse.

    Je suis en train de chercher une solution alternative pour pouvoir supprimer l’extension NimblePortofolio (ce qui implique bien sûr que je refasse tous les articles du site… Ô Joie.), est-ce que vous auriez un conseil à me donner à ce sujet  ? Une extension qui propose le même service avec les miniatures cliquables ?

    Merci ! 🙂

    #2278503
    Li-An
    Modérateur
    Maître WordPress
    22521 contributions

    Vous en prenez une hyperpopulaire et mise à jour https://fr.wordpress.org/plugins/search/filter%20portfolio/. Je n’ai pas de suggestion, je ne les connais pas.

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.