Migration : WordPress « Staging » et base de données (Créer un compte)

  • WordPress :5.8
  • Statut : non résolu
  • Ce sujet contient 5 réponses, 3 participants et a été mis à jour pour la dernière fois par HimSelf, le il y a 1 mois.
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #2415198
    stevemag76
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Ma configuration WP v 5.8

    • Version de PHP/MySQL : 7.4 – Mysql 5.7
    • Thème utilisé :
    • Extensions en place :
    • Nom de l’hébergeur :  ionos
    • Adresse du site :

    Problème(s) rencontré(s) :

    Bonjour, J’ai un site et une base de données ( un WordPress Multisites )

    Je souhaite faire une copie des repertoires et base de données, de façon a travailler sur un copie integrale

    La base de données a été ( me semble t il copié correctement , avec l’aide de Ionos ) et sans de probleme…

    la nouveau domaine : test.exemple.com pointe vers le répertoire de backup

    et je modifie le wp-config.php comme suit :  ( juste les DB_xxx )

    // ** Réglages MySQL – Votre hébergeur doit vous fournir ces informations. ** //
    /** Nom de la base de données de WordPress. */
    define( ‘DB_NAME’, ‘dbs111111’ );

    /** Utilisateur de la base de données MySQL. */
    define( ‘DB_USER’, ‘dbu255556’ );

    /** Mot de passe de la base de données MySQL. */
    define( ‘DB_PASSWORD’, ‘3&F44444’ );

    /** Adresse de l’hébergement MySQL. */
    define( ‘DB_HOST’, ‘db50foo.hosting-data.io’ );/** Jeu de caractères à utiliser par la base de données lors de la création des tables. */
    define( ‘DB_CHARSET’, ‘utf8mb4’ );

    /**
    * Type de collation de la base de données.
    * N’y touchez que si vous savez ce que vous faites.
    */
    define( ‘DB_COLLATE’,  » );

    */
    define( ‘AUTH_KEY’, ‘xxxxxxxxxxxxxxxxx’ );

    define( ‘SECURE_AUTH_KEY’, ‘xxxxxxxxxxxxxxxxx’ );

    define( ‘LOGGED_IN_KEY’, ‘xxxxxxxxxxxxxxxxx’ );

    define( ‘NONCE_KEY’, ‘xxxxxxxxxxxxxxxxx’ );

    define( ‘AUTH_SALT’, ‘xxxxxxxxxxxxxxxxx’ );

    define( ‘SECURE_AUTH_SALT’, ‘xxxxxxxxxxxxxxxxx’ );

    define( ‘LOGGED_IN_SALT’, ‘xxxxxxxxxxxxxxxxx’ );

    define( ‘NONCE_SALT’, ‘xxxxxxxxxxxxxxxxx’ );

    define( ‘WP_SITEURL’, ‘https:// test.exemple.com’ );
    define( ‘WP_HOME’, ‘https://test.exemple.com’ );
    $table_prefix = ‘at_’;

    */
    define( ‘WP_DEBUG’, false );

    /* C’est tout, ne touchez pas à ce qui suit ! Bonne publication. */

    /** Chemin absolu vers le dossier de WordPress. */
    if ( ! defined( ‘ABSPATH’ ) )
    define( ‘ABSPATH’, dirname( __FILE__ ) . ‘/’ );

    /** Réglage des variables de WordPress et de ses fichiers inclus. */
    require_once( ABSPATH . ‘wp-settings.php’ );

    ======================================================================

     

    J’ai vérifié 10 fois le DBname, le DBPassword, le DB user.. me semble correct.. et il ne peut pas se connecter à la base de données. Cela me semble pas possible…que se soit un simple probleme de connection a la base

    Est ce que le WP-config.php n’aurait pas besoin d’autres modifications ??? Je me demande s’il n’y aurait pas un autre probleme ?

    Est ce lié au fait que c’est un multisite ?

    J’ai pensé editer la base de données et modifier les « www.example.com » en « test.example.com » ?  mais la, je n’arrive même pas a me connecter….

    Je ne vois pas 🙁

    merci d’avance…

    Crdlt

    Stéphane

     

     

    • Ce sujet a été modifié le il y a 1 mois par stevemag76.
    #2415200
    mathieu42
    Participant
    Maître WordPress
    1516 contributions

    quel est le message d’erreur exactement ?

    vous faites la copie sur le même hébergement, c’est bien ça ?

    #2415206
    stevemag76
    Participant
    Initié WordPress
    4 contributions

    Bonjour

    le message d’erreur  . ne peut pas se connecter a la base de données

    Oui, j’ai copié tous les fichiers avec Filezila.. tout c’est bien passé

    Oui, j’ai créé un autre répertoire sur le même espace…

    Les 2 noms de domaines : http://www.ewample.com -> pointe sur /Worpdress1 et test.example.com -> pointe sur /Wordpress2

    #2415211
    mathieu42
    Participant
    Maître WordPress
    1516 contributions

    quand c’est une erreur de code de connexion, le message est « Erreur lors de la connexion à la base de données » que ce soit en multisite ou non. votre message vient peut-être de l’hébergement.

    avez-vous essayez d’accéder à la base de données en passant par phpmyadmin sur le domaine de test ? ou en passant par l’espace de gestion de l’hébergement ?

    #2415219
    stevemag76
    Participant
    Initié WordPress
    4 contributions

    J’ai ouvert facilement la base de données via phpmyadmin sur le site de ionos..  J’ai demandé en parallel a ionos, mais ils m’ont répondu ceci

    Notre Service Administrateur a indiqué que votre demande dépasse le cadre de notre support.
    Vous pouvez trouver des tutoriels à ce sujet sur internet.

    => cela ne m’aide pas beacoup 🙁

    #2415948
    HimSelf
    Participant
    Chevalier WordPress
    138 contributions

    1ere question : est-ce normal ceci : define( ‘WP_HOME’, ‘https://test.exemple.com’ ); ?

    2ème question : est-tu certain que l’adresse de connexion au serveur de base de données est le même ?

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.