[Résolu] Migration site 1&1 à OVH

  • WordPress :4.9
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 25)
  • Auteur
    Messages
  • #2087136
    Elo_GG
    Participant
    Initié WordPress
    15 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.0
    • Thème utilisé : Lets Blog
    • Extensions en place :
    • Nom de l’hébergeur : OVH
    • Adresse du site :

    Problème(s) rencontré(s) : Migration de 1&1 à OVH

    Bonjour,

    J’ai besoin d’un (gros) coup de pouce !

    Hier soir, j’ai décidé de passer de 1&1 à OVH, autant pour le NDD que pour l’hébergement.

    Transfert du NDD : ok
    Cependant, concernant l’hébergement, ça semble être une autre paire de manches…

    • Concernant l’import des fichiers sur le FTP :
      Après avoir importé mes fichiers sur le FTP dans /www/nomdemonblog, j’ai en page d’accueil « Index of/ ».
      Comment accéder de nouveau à la page d’accueil, administration, etc ?
      J’ai épluché les forums et tutos, je ne parviens pas à résoudre mon souci…
    • De plus, concernant l’import de la BDD :
      Le fichier wp-config.php contient les bonnes informations de ma nouvelle BDD.
      Je constate dans mon espace client que ma BDD est de 704 ko / 200 Mo alors que je n’ai pas importé de BDD (un autre de mes questionnements).
      Il semble qu’au niveau de la BDD ça devrait être bon, où dois-je bel et bien importer ma BDD dans mon espace client OVH, où ça s’est fait automatiquement ?

    Précision (peut-être importante) : j’avais crée mon blog sur Click and Build avec 1&1.

    Je vous remercie par avance de votre aide précieuse (j’ai tellement peur d’avoir tout perdu) !

    #2087417
    Flobogo
    Modérateur
    Maître WordPress
    14698 contributions

    Bonjour,

    1. Pour les fichiers sur le FTP : vérifiez si il n’y a pas un fichier index.html à supprimer chez votre nouvel hébergeur. Et vérifiez également que vous avez placé les dossiers et fichiers au bon endroit, et pas un cran trop bas dans l’arborescence.
    2. Votre BDD de base fait peut-être 704 Ko avec une installation vierge. Si vous n’importez pas la BDD venant de votre ancien hébergeur, ça ne va pas se faire par magie. 😇
    #2087566
    Elo_GG
    Participant
    Initié WordPress
    15 contributions

    Bonjour Flobogo et merci pour ton retour.

    Le problème a avancé et évolué.

    Côté BDD et accès à l’admin : c’est ok.

    Par contre, j’ai désormais une page blanche (erreur 500 sur Chrome) et toutes les redirections de mes URL renvoient vers des pages 404.

    Auriez-vous des pistes pour que je puisse rétablir la mise en ligne de mon site au public  svp ?

    Merci par avance !

    #2087582
    Joss47
    Modérateur
    Maître WordPress
    4332 contributions

    Bonjour Elo,

    As-tu fais des changements dans ta BDD après migration?
    Le domaine sur OVH ne doit pas être le même que celui que tu avais sur 1&1, si ?

    Il faudrait faire ces requêtes SQL :

    UPDATE wp_options
    SET option_value = replace(option_value, 'http://www.ancienne-adresse-local.fr', 'http://www.nouveau-site.fr')
    WHERE option_name = 'home'
    OR option_name = 'siteurl';

    UPDATE wp_posts
    SET post_content = REPLACE (post_content, 'http://www.ancien-site-local.fr', 'http://www.nouveau-site.fr');

    A adapter en fonction de tes URL et du préfixe de tes tables WP.
    Ancienne adresse local, correspondra à ton URL chez 1&1.

    #2087587
    Elo_GG
    Participant
    Initié WordPress
    15 contributions

    Bonjour Joss47,

    L’URL est la même que lorsque mon site était hébergé chez 1&1.
    J’ai fait un transfert de NDD.

    Ainsi, me confirmes-tu que la manip que tu viens de me donner ne va pas correspondre dans mon cas ?

    Concernant la migration de ma BDD, j’ai effectué l’import directement dans PHPMyAdmin sans toutefois bougé quoi que ce soit (pas vraiment à l’aise avec les BDD ^^).

    Merci par avance de ton retour !

    #2087590
    Joss47
    Modérateur
    Maître WordPress
    4332 contributions

    Ah ok pour l’URL.
    Tu as tenté simplement de re faire un enregistrement de tes permaliens via le back office de WP vu que tu peux y accéder ?
    Tu ne veux pas nous communiquer l’URL du site? Au pire tu peux le faire en mettant le message en privé.

    #2087595
    Elo_GG
    Participant
    Initié WordPress
    15 contributions
    Cette réponse a été marquée comme privée.
    #2087596
    Elo_GG
    Participant
    Initié WordPress
    15 contributions

    As-tu reçu l’URL de mon site en MP ?

    Je n’ai pas enregistré de permaliens via mon back-office WP. Il faut le faire ? Si oui, pourrais-tu me dire comment stp ?

    #2087611
    Joss47
    Modérateur
    Maître WordPress
    4332 contributions

    oui c’est bon merci.
    Pour re générer il faut aller dans Réglages > Permaliens et enregistrer en bas

    #2087615
    Elo_GG
    Participant
    Initié WordPress
    15 contributions

    Merci pour cette nouvelle piste.

    Je viens de me rendre dans Permaliens.

    Ce qui était coché : « Structure personnalisée » alors que je pense que c’était « Nom de l’article ». J’ai donc modifié cela…
    Enregistrer.
    Rien n’a bougé…

    #2087619
    Joss47
    Modérateur
    Maître WordPress
    4332 contributions

    Humm

    Lorsque tu cliques sur un lien depuis le back office d’une de tes pages tu tombes sur une erreur 404 c’est bien cela ? Un lien d’une page à me donner ?
    Désactives toutes tes extensions, vu que je ne sais pas ce que tu as en place, ça ne coûte rien de regarder de ce côté, si au cas ou tu as une extension de sécurité etc.

    pour les permaliens en effet il faut cocher la seconde option que tu dis 😉
    Dans réglages > général > comment sont les deux URL de ton WP? Elles commencent bien par https:// ?

    #2087632
    Elo_GG
    Participant
    Initié WordPress
    15 contributions

    Hier soir ou ce matin j’avais une erreur 404 sur mes pages d’articles. A date, c’est une page blanche.

    Les extensions sont toutes désactivées.

    Les permaliens sont sur « Nom de l’article ».

    Pour info, mon site n’a jamais été sous https//.

    #2087636
    Elo_GG
    Participant
    Initié WordPress
    15 contributions
    Cette réponse a été marquée comme privée.
    #2087640
    Joss47
    Modérateur
    Maître WordPress
    4332 contributions

    Ok.

    Dans ton fichier wp-config.php à la racine de ton wordpress tu trouvera une ligne WP_debug « false » change par « true »
    Une fois fait, on devrait voir des erreurs apparaître au lieu de la page blanche.
    Dis moi quand c’est fait 😉

    Pour info, mon site n’a jamais été sous https//.

    OVH offre nativement le https sur ses hébergements, ça serait bête de ne pas en profiter, mais ça on verra plus tard 🙂

    #2087643
    Elo_GG
    Participant
    Initié WordPress
    15 contributions

    On verra plus tard pour le HTTPS 😀

    Je viens de modifier le fichier wp-config (je vois toujours une page blanche pour ma part, malgré la modif).

15 sujets de 1 à 15 (sur un total de 25)
  • Vous devez être connecté pour répondre à ce sujet.