Migration en local impossible : Table local.wp_options doesn’t exist (Créer un compte)

  • WordPress :5.5
  • Statut : non résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #2359968
    lauracabrol
    Participant
    Initié WordPress
    6 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.3.24
    • Thème utilisé : Storefront
    • Nom de l’hébergeur : 1&1
    • Adresse du site : https://auboutondor.com/

    Problème(s) rencontré(s) : J’essaie de migrer ce site vers un logiciel en local, sans succès. Quand j’essaie sur Local by Flywheel, un message d’erreur apparait (voir la capture écran) : Table local.wp_options doesn’t exist

    Et lorsque j’essaie de le migrer sur MAMP, en modifiant local.wp_options par wp_options, j’arrive à aller sur la page d’accueil mais les autres pages du site renvoient vers les liens du site en ligne.

    J’ai déjà essayé avec le plugin de migration mais le site est trop lourd, même sans les images.

    Je ne sais pas comment le migrer en local. Sauriez-vous d’où vient le problème ?

    • Ce sujet a été modifié le il y a 2 jours et 7 heures par PhiLyon.
    • Ce sujet a été modifié le il y a 2 jours et 7 heures par lauracabrol.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2359970
    PhiLyon
    Modérateur
    Maître WordPress
    26729 contributions

    Bonjour.

    Essaie avec cette extension https://fr.wordpress.org/plugins/all-in-one-wp-migration/

    🙂

    #2359973
    lauracabrol
    Participant
    Initié WordPress
    6 contributions

    Bonjour, j’ai oublié de préciser que j’ai essayé cette solution mais le site est trop lourd, même sans les images. Je viens d’ajouter cette info dans mon texte.

    #2360057
    ferman
    Participant
    Maître WordPress
    3214 contributions

    Bonjour,

    Et lorsque j’essaie de le migrer sur MAMP, en modifiant local.wp_options par wp_options, j’arrive à aller sur la page d’accueil mais les autres pages du site renvoient vers les liens du site en ligne.

    Dans votre base de données vous avez bien modifié les liens en local? par exemple  https: //auboutondor.com/……. en quelque chose comme http: //localhost/auboutondor/…….. Vous avez aussi modifié votre wp-config pour qu’il corresponde à l’adresse de la base de données locale?

    #2360229
    lauracabrol
    Participant
    Initié WordPress
    6 contributions

    Bonsoir, oui j’ai bien modifié les URL, le wp_config.

    J’essaie avec un autre site, j’ai réussi à me connecter mais j’ai accès à l’admin et à la page d’accueil.

    La page d’accueil ne contient pas les infos ajouté dans la personnalisation du thème (onepress).

    Et les autres pages renvoient à une page 404.

    Qu’est-ce que j’aurais pu oublier ?

    • Cette réponse a été modifiée le il y a 21 heures et 17 minutes par lauracabrol.
    #2360231
    lauracabrol
    Participant
    Initié WordPress
    6 contributions

    Je viens de mettre à jour les permaliens, j’ai de nouveau accès à toutes les pages.

    En revanche je ne comprends pas pourquoi les paramètres du thème n’ont pas été sauvegardés lors de l’importation.

    Et pour le premier site dont je parlais au début, je n’arrive toujours pas à accéder au répertoire quand on clique sur “My website”. Il me télécharge un lien. Je ne vois pas d’où ça peut venir.

    • Cette réponse a été modifiée le il y a 20 heures et 56 minutes par lauracabrol.
6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.