Migration du site sur OVH avec ancienne version en production

  • WordPress :5.0.3
  • Statut : non résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #2246817
    Nat17
    Participant
    Initié WordPress
    11 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : Ocean WP
    • Extensions en place : Elementor
    • Nom de l’hébergeur : OVH
    • Adresse du site :

    Problème(s) rencontré(s) :
    Bonjour,

    je voudrais migrer un site sur OVH sans faire de bêtise… et je n’arrive pas à avoir OVH au tel, ils renvoient sur leurs vidéos toutes prêtes.
    En fait, il y a une ancienne version du site en production sur OVH, et qui a été faite avec Joomla. Mais Joomla n’est pas installé sur le compte OVH.

    Comment faire pour basculer de l’ancien au nouveau site sans arrêt de production, ou très limité ?
    Est-ce que je peux installer WordPress sur OVH (avec leur « module en 1 click ») sans gêner la production de l’ancien site ?
    Comment est-ce que je mets tout ce qui a été fait sur mon ordi avec « Local » sur OVH ?
    Comment faire pour tester des choses sur OVH, sans arrêter l’ancienne version du site ?
    Comment faire pour rebasculer éventuellement sur l’ancien site s’il y a un problème ?
    Y a-t-il un moyen de faire une sauvegarde de l’ancien site Joomla au cas où ?

    Je sais que ce sont des questions de novice, mais j’avoue que cela m’aiderait beaucoup….

    Merci d’avance,
    Nathalie.

    #2246820
    ouiouiphoto
    Participant
    Maître WordPress
    1180 contributions

    Bonjours

    Disons que tu as http://www.mondomaine.com qui pointe sur un répertoire « Ton hébergement/Joomla/ »

    Tu fait un répertoire « Ton Hébergement/WP/ » Tu fais pointer dessus un sous domaine wp.mondomaine.com

    Tu installe sur ton installation local une extenstion comme duplicator et tu fais la sauvegarde.

    Tu rapatrie cette sauvegarde dans le répertoire « Ton Hébergement/WP/ » et tu vas dans ton sous domaine wp.mondomaine.com/installer.php

    La ca va t’installer WP et ton site. Attention a l’aspect base de donnée. Tu utilise la même que joomla mais avec un autre préfix ? Tu as une autre base dispo ?

    Ensuite tu aura donc localement un site WP a l’adresse wp.mondomaine.com que tu pourra tester

    Une fois que les test sont bon il faudra donc modifier ton site WP pour qu’il ai l’impression d’être installé sur http://www.mondomaine.com.  La il y a pas mal de procédures sur le net.

    Tu demande ensuite que ton domaine http://www.mondomaine.com pointe sur « Ton hébergement/WP/ » Eventuellement tu fais un sous domaine Joomla.mondomaine.com pour avoir toujours le site joomla en ligne

    Normalement tu as zéro interruption de service MAIS et je le mets en gras toutes les pages indexées ou référencées dans d’autres sites ou dans les moteurs de recherche étaient sur une syntaxe de lien Joomla. Et donc il va falloir dans ton fichier .htaccess les rerouter vers des pages du site WP si le lien entre l’ancien et le nouveau site ne sont pas identiques

    #2246873
    Nat17
    Participant
    Initié WordPress
    11 contributions

    Bonjour,

    merci beaucoup pour toutes ces informations !

    Pour la base de données, je souhaite utiliser celle qui est actuellement utilisée par le site joomla.
    Je vois sur OVH le nom d’utilisateur, le nom de la base et l’adresse du serveur :
    santebiolaro     santebiolaro    santebiolaro.mysql.db  avec TYPE MYSQL v.5.6  (ce site avait été fait il y a environ 10 ans)

    Est-ce que je peux dire à WP d’utiliser directement cette base ? et comment ? (J’ai fait une sauvegarde de la base sur OVH du coup)
    Désolée encore une fois de mes questions de novice…

    Pour les pages indexées ou référencées dans d’autres sites, ça veut dire qu’il faut que je reroute dans le fichier .htacces toutes les pages de l’ancien site sur des pages du nouveau site WP, c’est ça ? Toute la structure du site a été revue… donc à part la page d’accueil, les anciennes pages n’existent plus telles qu’elles, mais elles peuvent effectivement être reroutées sur de nouvelles pages.

    Merci encore 🙂

     

    • Cette réponse a été modifiée le il y a 1 month par  Nat17.
    #2246881
    ouiouiphoto
    Participant
    Maître WordPress
    1180 contributions

    Lorsque tu installera le site avec Duplicator il faudra alors donner les infos de cette base.  Et oui il faudra gerer les redirections dans le htaccess.

    #2246882
    Nat17
    Participant
    Initié WordPress
    11 contributions

    OK, merci !

    #2247793
    Nat17
    Participant
    Initié WordPress
    11 contributions

    Bonsoir,

    j’ai un problème avec Duplicator…. quand je lance le scan, après 15 mn j’ai le message : erreur de scan 405 not allowed, nginx/1.13.12

    J’ai relancé un scan en excluant les fichiers cache, uploads et updraft, et j’ai exactement la même erreur…

    Une idée de ce que je pourrais faire ?
    Merci d’avance,
    Nat.

    #2247834
    ouiouiphoto
    Participant
    Maître WordPress
    1180 contributions

    Le problème vient d’une configuration de ton environnement local. C’est quoi ton environment local ?

    #2247905
    Nat17
    Participant
    Initié WordPress
    11 contributions

    Déjà je précise que je suis sur Windows 10.

    La config de Local c’est :

    Local Environment : Preferred 1.3.2
    Web server : nginx
    PHP Version : Unknown
    MySQL Version : 5.7
    WordPress Version : 4.9.9
    Site Name : nomdusite
    Sire Domain : nomdusite.local
    Site Path :  ~\Local Sites\nomdusite
    Multisite : No

    Mais en fait en Novembre j’avais fait un petit essai avec un autre nom de site.
    J’ai vérifié, la config de Local pour cet essai est la même, sauf la version de WordPress 4.9.8, mais surtout la site Path était D:\WORDPRESS\répertoire site\autrenomdusite

    J’ai vérifié que les fichiers de Duplicator doivent aller dans :
    C:/users/asus/local sites/nomdusite/app/public/wp-snapshots
    Je vois dans ce dossier que hier un répertoire « tmp » a été créé, mais qu’il est vide.
    Je vois aussi qu’il y a plein d’autres fichiers qui existent déjà, datant de novembre, quand j’avais fait un essai sur le site (au tout début), et effectivement Duplicator me dit bien qu’il y a un paquet qui avait été créé à cette date-là.
    Est-ce que je dois d’abord enlever ce premier paquet d’une façon ou d’une autre ?
    (Je n’en ai pas besoin de toute façon).

    Autre chose, sur la partition C, sur laquelle Duplicator veut écrire, il n’y a pas beaucoup de place, seulement que 13,8 Go de libre, alors que sur le disque D, j’ai 788 Go de libre.
    Est-ce que ça peut jouer aussi ?

    Je pensais avoir fait attention lors de l’installation à bien mettre le site sur D:/ …. comme le montre la config de Local pour le premier essai de site.
    Mais apparemment, j’ai cru ensuite que tout irait sur D, et je n’ai pas fait attention pour le vrai site qui m’intéresse, et qui se trouve donc sur C… et Duplicator ne me permet pas de changer l’endroit où il va mettre le paquet.

    En plus, depuis le début ça rame énormément avec Local… apparemment d’autres ont aussi le problème sur PC, mais ça vient peut-être d’un problème de config…

    #2248033
    Tricotfils
    Participant
    Initié WordPress
    2 contributions

    Bonjour, je rebondit sur votre sujet car ma question est très proche. J’ai une boutique prestashop en ligne et sur Ovh je dispose d’un domaine non activé. Voici ma demande : puis je installé Wp sur ce nom de domaine non actif.ovh et le développer avec les plug in nécessaire et ensuite retiré mon ancien site pour transféré le nouveau sur mon vrai domaine sans que cela ne gêne mon site actuel ?

    Merci par avance car je débute sur Wp et ne suis pas informaticienne mais commercante

    #2248078
    Nat17
    Participant
    Initié WordPress
    11 contributions

    Problème résolu pour Duplicator… et vitesse de Local sur Windows !

    Après plusieurs nettoyages, essais,… j’ai pu avoir un scan de Duplicator, mais le paquet s’arrêtait systématiquement au bout de 20mn à 59% …
    Du coup j’ai essayé avec ce que recommandait Duplicator (et notamment de tenter avec DupArchive au lieu du Zip)… sans succès.

    Mais c’est bien dans la configuration de Local que ça s’est débloqué, et ça peut servir à d’autres qui galèrent avec la lenteur de Local sur Windows :
    dans le Menu « Preferences », aller sur « Advanced » et il y a un paramètre « Faster Docker Volumes », noté comme « experimental » qui était sur OFF, je l’ai mis sur ON et là….. MAGIQUE…. Local est 4 à 5 fois plus rapide qu’avant…. et Duplicator a fait le paquet sans problème en 9 mn…..

    Si j’avais trouvé ce paramètre avant, j’aurais gagné beaucoup de temps, alors je le partage pour les autres !
    Et merci ouiouiphoto pour les conseils avisés !

    NB : Tricotfils, désolée je ne connais pas Prestashop, alors je ne peux pas te répondre…

    #2248106
    Tricotfils
    Participant
    Initié WordPress
    2 contributions

    Heureuse que tu ais pu te dépatouiller. je pense que je vais ouvrir un post. bonne continuation

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.