[Résolu] Migration de site et accès back-office refusé

  • WordPress :4.9
  • Statut : résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #2094176
    Debrailly
    Participant
    Initié WordPress
    38 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 5.6/5.6
    • Thème utilisé : language-school
    • Extensions en place : jetpack, revslider, updraftplus, wordpress-seo et des plugins liés au theme (cmsmaster…. et learnpress …)
    • Nom de l’hébergeur :  Amen
    • Adresse du site : http://sos-anglais.fr/

    Problème(s) rencontré(s) :

    J’avais un pack Linux sur Amen lié à un nom de domaine que je souhaite ne pas renouveler mais chez Amen ce n’est pas possible m’a-t-on dit de détaché un nom de domaine d’un pack …. no comment

    Donc j’ai acheté un nouveau pack WordPress.

    J’ai fait la migration du site : les fichier via FTP et importation de la base de donnée OK

    Cependant, lorsque je me connecte avec mes identifiant et mdp, on m’interdit l’accès au tableau de bord “cette page ne vous est pas accessible” ! Comme si mon rôle d’admin avait été squizé …

    Comment via phpMyAdmin, je peux éventuellement modifier mon rôle ? Ou pensez vous à un autre problème ?

    Merci

    Isabelle

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2094221
    PhiLyon
    Modérateur
    Maître WordPress
    23109 contributions

    Bonjour.

    Peut-être une extension, désactives-les par ftp, Jetpack probablement

    🙂

    #2094234
    Debrailly
    Participant
    Initié WordPress
    38 contributions

    Merci

    J’ai bien testé en retirant les plugins suspects mais sans résultat.

    … :-/

     

    #2094244
    PhiLyon
    Modérateur
    Maître WordPress
    23109 contributions

    Essaies avec un thème de base, Twenty Seventeen

    🙂

    #2094277
    Hervel
    Participant
    Maître WordPress
    30021 contributions

    Bonjour,
    Avez-vous un nouveau nom de domaine ?
    Car sans changement, tout  renvoyer comme ça, tout est rester avec le nom de domaine http://sos-anglais.fr/

    Vous parlez de pack WordPress, c’est Amen qui installe WordPress pour vous ?
    Pas bon de prendre ce genre d’option chez un hébergeur, jamais très stable, ou des options sont bloquées. Ou alors petit espace de stockage pour le site ou la base de données.
    Il faut installer WordPress soi-même, sauf  les hébergeurs spécialisés WordPress comme WPServeur mais plus le même prix

    #2094307
    Debrailly
    Participant
    Initié WordPress
    38 contributions

    Bonjour,

    Merci pour vos remarques.

    J’ai trouvé la solution : un problème de préfixe dans la base de données.

    C’est bien expliqué sur le lien suivant : wpchanel prefixe base de données

    Pour ma part, je suis revenue à l’ancien préfixe de ma base et ai donc effacé tous les préfixes choisis par l’hébergeur.

    Cela fonctionne maintenant et j’ai bien à nouveau accès au back office.

    Voilà donc si certains se retrouvent face au même problème : c’est une question de préfixe 🙂

    Merci à tous

     

    #2103531
    Hervel
    Participant
    Maître WordPress
    30021 contributions

    Bonjour,

    Il fallait juste changer de wp-config.php, à la ligne

    /**
     * Préfixe de base de données pour les tables de WordPress.
     *
     * Vous pouvez installer plusieurs WordPress sur une seule base de données
     * si vous leur donnez chacune un préfixe unique.
     * N'utilisez que des chiffres, des lettres non-accentuées, et des caractères soulignés!
     */
    $table_prefix  = 'wp_';
    wp-config.php

    C’était donc bien Amen qui a installé WordPress pour vous,  une autre raison, d’installer WordPress soi-même.

    #2103688
    Debrailly
    Participant
    Initié WordPress
    38 contributions

    Bonsoir Wolfneo,

    Merci pour l’astuce,

    J’ai en effet modifier les prefixe mais de l’ensemble de la base de données.

    Et oui, il vaut mieux installer wordpress soi-même, surtout lors d’une migration: j’ai cru gagner du temps …

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.