[Résolu] MESSAGE ERREUR : appeler fonction « the_content » (Créer un compte)

  • WordPress :5.2
  • Statut : résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2284913
    NicoF
    Participant
    Padawan WordPress
    72 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.3.11 / v5.5.60-0+deb7u1-log
    • Thème utilisé : Twenty 19 child theme
    • Extensions en place : Elementor pro, Yoast,wp file manager, slider revolution,popUp, search & filter, ACF, all in one, ninja form,
    • Nom de l’hébergeur : 1and1
    • Adresse du site : http://coursdenatation.co/

    Problème(s) rencontré(s) :

    Je rencontre un problème, dès que je souhaite modifier avec Elementor ma page Blog j’ai le message d’erreur qui me dit d’appeler la fonction : « the_content » ! J’ai recherché le fichier où inscrire le fonction php suivante :
    <?php the_content(); ?>
    mais je ne trouve pas le fichier avec le partie blog correspondante.

    J’ai également une erreur parfois en voulant toujours modifier une page avec Elementor et je tombe sur une erreur fatal : 500.

    Je ne sais pas si les deux problèmes sont liés, j’aurais vraiment besoin d’un coup de pouce, cela fait deux jours que je suis dessus sans vraiment résoudre le soucis.

    merci d’avance pour votre aide.

    Nicolas 🙂

     

    • Ce sujet a été modifié le il y a 4 années et 3 mois par NicoF.
    #2284917
    momofr@free.fr
    Modérateur
    Maître WordPress
    6696 contributions

    Salut, la page blog, si elle est assignée dans les réglages WP comme pages des articles, ne peut pas être modifiée avec Elementor. Elle utilise la page modèle du thème.
    Si tu veux modifier cette page tu ne dois pas assigner de page pour les articles dans les réglages de Lecture de WordPress.
    Si tu utilises Elementor PRO tu peux créer ta propre pages d’archives dans les modèles Elementor, ainsi ta mise en page (modèle d’archive) sera utilisée si tu utilises le réglage de Lecture actuel.

    #2284927
    NicoF
    Participant
    Padawan WordPress
    72 contributions

    Merci beaucoup pour votre retour rapide cela fonctionne. Du coup dans le réglage de lecture actuel je laisse « vide » ou je dois sélectionner cette nouvelle page Blog ?

    Concernant ma deuxième erreur, le problème qu’il se pose c’est que je ne peux plus accéder à l’interface Edit de wordpress sur n’importe qu’elle page!!! Je peux les modifier via Elementor mais je ne peux plus accéder à l’éditeur WordPress sur toutes les pages!! J’ai une erreur : ERROR 500 – INTERNAL SERVER ERROR, et  ceux depuis que je viens de changer le paramètre « lecture actuel »! J’avais déjà eu à une reprise cette erreur sur une page, j’avais du la supprimer et la recréée mais la je suis bloqué… d’ou peut provenir ce bug?

    mille mercis pour votre aide!!

    #2284958
    momofr@free.fr
    Modérateur
    Maître WordPress
    6696 contributions

    Salut, si tu as opté pour la première solution tu ne dois pas paramétrer la lecture de la page blog, dans le second cas tu peux le faire.

    L’erreur 500 peut être provoquée par beaucoup de choses, la première chose à vérifier c’est l’allocation mémoire pour WordPress, avec Elementor il faut l’augmenter au minimum à 128Mo et je préconise 512Mo pour être tranquille quelque soit le type de page à concevoir. Si ça ne règle rien, tu dois désactiver toutes tes extensions sauf Elementor, si ça marche alors tu les réactives une à une pour détecter celle qui est en conflit (à reporter sur le support Elementor).

    #2285015
    NicoF
    Participant
    Padawan WordPress
    72 contributions

    Je passe par Elementor je laisserai donc le champ vide.

    Concernant l’erreur 500, j’ai contacté mon hébergeur, le tuto en lien n’a rien donné. J’ai donc pris un pack hébergement supérieur, l’hébergement web pro chez 1and1, avec plus de performance => problème réglé.

    Merci pour votre aide très clair et votre réactivité.

     

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.