Message d’erreur « Warning homez.424 » (Créer un compte)

  • Statut : non résolu
  • Ce sujet contient 52 réponses, 4 participants et a été mis à jour pour la dernière fois par Anonyme, le il y a 13 années et 2 mois.
15 sujets de 16 à 30 (sur un total de 53)
  • Auteur
    Messages
  • #767681
    Komli
    Participant
    Chevalier WordPress
    328 contributions

    Le fichier wp-config.php sert principalement à WordPress pour le connexion à la base de données. Donc tu dois y mettre les informations nécessaires manuellement quand l’installation automatique ne fonctionne pas.

    Donc

    define(‘DB_NAME’, ‘votre_nom_de_bdd’);

    Le nom de ta base de données fourni par OVH entre ‘ ‘

    define(‘DB_USER’, ‘votre_utilisateur_de_bdd’);

    L’identifiant MySQL fourni par OVH toujours entre les ‘ ‘

    define(‘DB_PASSWORD’, ‘votre_mdp_de_bdd’);

    Le mot de passe

    define(‘DB_HOST’, ‘localhost’);

    Le nom du serveur MySQL où se trouve ta base.

    Toutes ces infos t’ont été fournies par OVH. Après tu enregistre ton fichier et tu le transfère avec Filezilla (pour info, les lignes qui commencent par des étoiles sont des commentaires).

    #767682
    Titecle
    Membre
    Initié WordPress
    24 contributions

    Merci pour ces explications, je m’en suis sortie.
    J’arrive maintenant à me connecter à mon blog mais j’ai droit à une jolie page blanche avec les six lignes d’erreur suivantes :

    Warning: Cannot modify header information – headers already sent by (output started at /homez.424/larchedej/www/wp-config.php:1) in /homez.424/larchedej/www/wp-login.php on line 354

    Warning: Cannot modify header information – headers already sent by (output started at /homez.424/larchedej/www/wp-config.php:1) in /homez.424/larchedej/www/wp-login.php on line 366

    Warning: Cannot modify header information – headers already sent by (output started at /homez.424/larchedej/www/wp-config.php:1) in /homez.424/larchedej/www/wp-includes/pluggable.php on line 693

    Warning: Cannot modify header information – headers already sent by (output started at /homez.424/larchedej/www/wp-config.php:1) in /homez.424/larchedej/www/wp-includes/pluggable.php on line 694

    Warning: Cannot modify header information – headers already sent by (output started at /homez.424/larchedej/www/wp-config.php:1) in /homez.424/larchedej/www/wp-includes/pluggable.php on line 695

    Warning: Cannot modify header information – headers already sent by (output started at /homez.424/larchedej/www/wp-config.php:1) in /homez.424/larchedej/www/wp-includes/pluggable.php on line 897

    Auriez-vous une idée pour résoudre ça ? :s

    #767683
    Komli
    Participant
    Chevalier WordPress
    328 contributions

    Certainement une erreur dans le fichier wp-config.php. Regarde la 1ère ligne du fichier, elle doit commencer par <?ph sans espace avant ni ligne vide.

    #767684
    Titecle
    Membre
    Initié WordPress
    24 contributions

    Non il n’y a apparemment pas de problème d’espace ou de ligne vide.

    #767685
    Guy
    Participant
    Maître WordPress
    14817 contributions

    Peut-être verifier qu’il n’y en a pas en bas non plus, comme l’a dit Komli, cela ressemble à ce type d’erreur, il ne faut pas d’espaces ou de lignes vides ni au debut ni à la fin, c’est à dire ni avant

    #767686
    Titecle
    Membre
    Initié WordPress
    24 contributions

    Ah, le fichier ne finissait effectivement pas avec le symbole ?>
    Je l’ai donc ajouté à la fin en faisant attention qu’il n’y ait pas d’espace mais ça ne change pas mon problème.. :(
    Que faire ?

    #767687
    Titecle
    Membre
    Initié WordPress
    24 contributions

    De plus j’ai à nouveau le problème d’identification !!

    #767688
    Guy
    Participant
    Maître WordPress
    14817 contributions

    Quand on regarde la page de ton blog, il semble manquer des fichiers, pour récupérer les fichiers de ton theme tu peux les trouver là : Theme PressPlay.

    tu décomprimes le fichier zip sur ton ordi, et avec Filezilla copies le contenu du réperoire PressPlay vers le repertoire « wp-content/themes/presplay » de ton blog. Théoriquement, cela devrait regler les messages d’erreurs que l’on peut voir :

    Warning: include() [function.include]: Failed opening ‘/homez.424/larchedej/www/wp-content/themes/pressplay/searchform.php’ for inclusion (include_path=’.:/usr/local/lib/php’) in /homez.424/larchedej/www/wp-content/themes/pressplay/header.php on line 118

    Ca sera déja une première étape avant de se repencher sur le problème d’identification

    #767689
    Titecle
    Membre
    Initié WordPress
    24 contributions

    Ca a marché !! J’ai suivi tes indications et les messages d’erreur ont disparu !!
    Merci beaucoup c’est un grand pas dans le bon sens 🙂 !!
    En ce qui concerne le problème d’identification, cela peut-il être lié à un hic que j’ai rencontreé avec Filezilla ?
    Je m’explique, hier après avoir fait toutes les manipulations dont nous avons parlé quand j’ai voulu fermer FileZilla une boîte de dialogue s’est ouverte me disant :
    « Attention certains fichiers sont encore en cours d’édition ou nécessitent d’être envoyés, si vous fermez Filezilla maintenant vos modifications seront perdues ».
    Etant incapable d’identifier quels fichiers pouvaient bien être encore en cours d’édition j’ai fini par fermer FileZilla. Comment pourrais-je solutionner ça ?

    #767690
    Guy
    Participant
    Maître WordPress
    14817 contributions

    Le message quand tu essaies d’acceder à l’admin est

    Warning: Cannot modify header information – headers already sent by (output started at /homez.424/larchedej/www/wp-config.php:1) in /homez.424/larchedej/www/wp-includes/pluggable.php on line 897

    C’est probablement toujours le problème dans le fichier wp-config.php, il faut le revérifier, bien enlever les espaces ou les lignes vides en haut et en bas, et cela devrait fonctionner.

    #767691
    Titecle
    Membre
    Initié WordPress
    24 contributions

    Je passe le fichier en revue mais je ne vois pas de ligne ni d’espace avant le symbole
    Il y a bien des espaces, lignes vides et retour à la ligne au sein du fichier mais vous m’aviez dit qu’il ne devait pas y en avoir avant et après les symboles en question, c’est bien ça ?
    Dans le doute je vous copie-colle le fichier ici :

    #767692
    Komli
    Participant
    Chevalier WordPress
    328 contributions

    Tu l’as édité avec quel logiciel ton fichier wp-config.php ? Tu as choisi quelles options d’enregistrement ?

    #767693
    Titecle
    Membre
    Initié WordPress
    24 contributions

    Je l’ai édité avec le Bloc Note, Puis Fichier –> Enregistrer
    Le problème vient de là ?

    #767694
    Komli
    Participant
    Chevalier WordPress
    328 contributions

    Je me posais la question car je n’ai pas vu d’erreur dans le fichier, mais avec le bloc notes il ne devrait pas y avoir de problème.

    #767695
    Guy
    Participant
    Maître WordPress
    14817 contributions

    cela parait bon, essaye de le remttre sur le blog avec filezilla, il s’était peut-être mal enregistré

15 sujets de 16 à 30 (sur un total de 53)
  • Vous devez être connecté pour répondre à ce sujet.