[Résolu] mes pages ne s’affichent plus (Créer un compte)

  • WordPress :6.0
  • Statut : résolu
11 sujets de 16 à 26 (sur un total de 26)
  • Auteur
    Messages
  • #2410372
    Li-An
    Modérateur
    Maître WordPress
    26516 contributions

    Si ça n’apparait pas dans vos réglages c’est que le index.php est ajouté de manière externe. Ce que vous nous dites me laisse à penser qu’il y a un htaccess super mal configuré. Récupérez le contenu du fichier .htaccess et copiez le nous ici. Vous pouvez aussi faire le test de le renommer (en htaccessold par exemple) puis vous retournez sauvegarder le réglage des permaliens et vous nous dites si ça marche mieux.

    #2410373
    Li-An
    Modérateur
    Maître WordPress
    26516 contributions

    Et comme il y un problème « externe »…

    Il y avait un questionnaire affiché, c’est dommage de ne pas l’avoir complété entièrement, car il peut aider à vous aider.
    Alors, merci de le copier-coller et compléter du mieux possible dans votre prochain post. Vous pouvez utiliser cette extension https://github.com/zitezinfo/infosite et copier/coller les informations affichées.

    Pour l’installer : téléchargez le fichier .zip indiqué dans le lien puis Extensions>Ajouter, cliquer sur le bouton Téléverser une extension (utilisez le fichier zip).

    #2410374
    ferman
    Participant
    Maître WordPress
    5247 contributions

    et celles qui s’affichent ont un lien de type …/?page_id=109

    C’est normal, c’est le propre des permaliens « simples ».

    Le problème c’est que certaines pages ne s’affichent plus quand je clique dans le men du site.

    Je vois toutes les pages actuellement présentes dans le menu. Supprimez le cache du navigateur (supprimez l’historique) et rvérifiez.

    Retournez dans les permaliens, cochez « titre de la publication » vérifiez que la ligne « structure personnalisée » est comme sur la pièce jointe puis enregistrez.

    • Cette réponse a été modifiée le il y a 1 mois par ferman.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2410386
    hypnose.arlon
    Participant
    Initié WordPress
    11 contributions

    j’ai déjà essayé ce paramétrage pour les permaliens mais quand je fais ça, il n’y a plus aucune page qui apparait quand je clique depuis le menu

    je viens de re-tester

    • Cette réponse a été modifiée le il y a 1 mois par hypnose.arlon.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2410523
    Flobogo
    Modérateur
    Maître WordPress
    18501 contributions

    Et ce que je vous ai demandé de faire le 09 juillet :

    Dans réglages > général, regardez ce qui est indiqué pour l’adresse du site, est-ce qu’il n’y aurait pas ce /index.php/ supplémentaire ? Si oui, supprimez-le.

    Dans le menu admin, dans cet onglet « réglages » > « général », vous ne devez plus avoir /index.php/ ni dans « adresse de WordPress » ni dans « adresse du site ».

    #2410556
    hypnose.arlon
    Participant
    Initié WordPress
    11 contributions

    C’est le cas, il n’y a plus cette référence (cf. pièce jointe)

    Je pense suivi toutes les procédures.

    Quand je lance Better search replace  à gauche https://www.hypnose-aubange.com/index.php/ et à droite https://www.hypnose-aubange.com/, voici le résultat :

    Pendant le rechercher/remplacer, 28 tables ont été parcourues, 0 cellules changées avec 0 mises à jour.

    Avez-vous une idée de ce qu’il faut faire ? En fait, c’est le même problème que mon problème initial quand j’ai voulu modifier les permaliens.

    Merci d’avance

     

    PS : ça n’a peut-être pas de rapport mais je n’arrive plus à mettre à jour mes pages, quand j’essaie, j’ai un message d’erreur

    « La mise à jour a échoué. Vous êtes probablement hors ligne. »

    J’ai vérifié la santé du site et il y a un problème avec API REST (cf pièce jointe) mais essayé de trouver comment faire mais le tuto que j’ai n’est pas facile à suivre. Avez-vous un tuto à ce sujet ? Est-ce que ça peut être lié à mon problème de page non visibles ?

    L’API REST est l’une des façon pour WordPress ou d’autres applications de communiquer avec le serveur. Un exemple est l’écran de l’éditeur, qui s’appuie dessus pour afficher et enregistrer vos publications.

    L’appel à l’API REST a renvoyé le résultat inattendu suivant : (404) <!DOCTYPE HTML PUBLIC « -//IETF//DTD HTML 2.0//EN »> <html><head> <title>404 Not Found</title> </head><body> <h1>Not Found</h1> <p>The requested URL was not found on this server.</p> </body></html> .

    • Cette réponse a été modifiée le il y a 4 semaines par hypnose.arlon.
    • Cette réponse a été modifiée le il y a 4 semaines par hypnose.arlon.
    • Cette réponse a été modifiée le il y a 4 semaines par hypnose.arlon.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2410566
    Li-An
    Modérateur
    Maître WordPress
    26516 contributions

    Ah ben, comment se fait il que les deux URL soient différentes sur ces réglages  adresse Web adresse du site ? Ça peut expliquer tous ces problèmes de permaliens.

    #2410570
    hypnose.arlon
    Participant
    Initié WordPress
    11 contributions

    MERCI !!!

    J’ai remis les deux URL avec www. et tout fonctionne nouveau 🙂

     

    #2410637
    Flobogo
    Modérateur
    Maître WordPress
    18501 contributions

    Ah ben oui, j’avais dit d’enlever /index.php/ … mais du coup, je supposais que le reste était bon. 😁

    Je passe le sujet en « résolu ».

    Petite précision : dans votre menu, l’onglet « objectif » n’a pas été rectifié après modification des permaliens, et l’URL est erronée.

    Et autre petite chose : si vous savez accéder au FTP (Filezilla) ou au gestionnaire de fichiers chez OVH, ouvrez le fichier .htaccess et ajoutez cette ligne à la fin :

    Options -Indexes

    Cela évite qu’on puisse lister le contenu de certains dossiers de votre installation.

    • Cette réponse a été modifiée le il y a 3 semaines et 6 jours par Flobogo. Raison: ajout de précisions
    #2410715
    hypnose.arlon
    Participant
    Initié WordPress
    11 contributions

    voilà, j’ai édité le fichier .htaccess et je pense que les permaliens sont corrects.

    encore un grand MERCI à tous

     

    #2410744
    Flobogo
    Modérateur
    Maître WordPress
    18501 contributions

    Cette fois, c’est nickel. 👌 (Bon, il vous reste à passer en version WP 6.0.1 fraîchement sortie)

11 sujets de 16 à 26 (sur un total de 26)
  • Vous devez être connecté pour répondre à ce sujet.