[Résolu] mes pages ne s’affichent plus (Créer un compte)

  • WordPress :6.0
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 26)
  • Auteur
    Messages
  • #2409437
    hypnose.arlon
    Participant
    Initié WordPress
    11 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 5.4
    • Thème utilisé : twenty seventeen
    • Extensions en place : ?
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://www.hypnose-aubange.com

    Problème(s) rencontré(s) :

    Je pense avoir fait une bêtise en modifiant le type de permalien car depuis il n’y a plus que la page d’accueil qui s’affiche.

    Toutes les autres pages donnent  404 not found

    J’ai essayé de restaurer mon site depuis le portail d’OVH à des dates antérieures mais ça ne fonctionne pas 🙁

    Est-ce que quelqu’un peut m’aider svp ?

    Merci d’avance

     

     

     

    • Ce sujet a été modifié le il y a 1 mois et 1 semaine par Li-An.
    • Ce sujet a été modifié il y a 3 semaines et 6 jours par Flobogo. Raison : rectificatif de la version WP
    #2409442
    Li-An
    Modérateur
    Maître WordPress
    26516 contributions

    Bonjour, supprimez ou renommez le fichier htaccess à la racine de votre site pour voir ce que ça donne (éventuellement recopiez son contenu dans un éditeur texte type Notepad).

    #2409522
    Flobogo
    Modérateur
    Maître WordPress
    18501 contributions

    Bonjour,

    La bêtise, c’est surtout de garder un site qui n’est pas à jour, avec une version PHP obsolète, et le protocole HTTP non sécurisé. Vous courrez au-devant du piratage.

    Suivez cette partie du tuto concernant la mise à jour d’un site ayant plusieurs versions de retard. Faites bien les sauvegardes préalables, en particulier pour la base de données (tuto avec PhpMyAdmin)

    #2409571
    hypnose.arlon
    Participant
    Initié WordPress
    11 contributions

    ça n’a pas fonctionné

    dois-je recréer moi-même un nouveau fichier htaccess ? Si oui, que faut-il mettre dedans ?

    merci

    #2409572
    hypnose.arlon
    Participant
    Initié WordPress
    11 contributions

    @Flobog :

    j’essaie de suivre les différents tutos mais je n’arrive pas à me connecter via phpmyadmin.

    j’ai 2 messages d’erreur :

    impossible de se connecter au serveur

    mysqli::real_connect(): (HY000/1045): Access denied for user ‘hypnoseayv572’@’10.9.111.150’ (using password: YES)

    je suis sûr du mot de passe car je l’ai modifié juste avant d’essayer de me connecter

    c’est encore pire depuis que j’ai essayé de faire une sauvegarde de la base de données car depuis, je n’ai même plus ma page d’accueil qui s’affiche mais le message Error establishing a database connection

    je ne sais pas quoi faire de plus, je pense avoir suivi tout le tuto

    merci d’avance

     

    • Cette réponse a été modifiée le il y a 1 mois par hypnose.arlon.
    • Cette réponse a été modifiée le il y a 1 mois par hypnose.arlon.
    #2409588
    Li-An
    Modérateur
    Maître WordPress
    26516 contributions

    Bonjour, il y a visiblement un problème avec le serveur de votre base de données. Contactez votre hébergeur – et bienvenu chez OVH.

    #2409603
    hypnose.arlon
    Participant
    Initié WordPress
    11 contributions

    merci, je vais prendre contact avec OVH 🤞

    #2409868
    hypnose.arlon
    Participant
    Initié WordPress
    11 contributions

    Bonjour,

    Je vous remercie pour vos réponses. J’ai récupéré mon site 🙂


    @Flobogo
    :

    J’ai fait toutes les mises à jour comme indiqué dans votre tuto. Version WordPress 6.0

    Par contre, je suis encore en PHP 7.0 car je ne sais pas si je peux passer directement à la version 8.0.

    Enfin, comment puis-je faire pour être en protocole HTTP sécurisé ?

    Encore merci

     

     

     

    #2409869
    Li-An
    Modérateur
    Maître WordPress
    26516 contributions

    Vous devez privilégier php 7.4+ Pour le https, il y a myriades de tutos sur le Web https://www.mistersize.com/blog/ajouter-https-ssl-ovh/

    Personnellement, je préfère le déménagement complet de http en https mais la plupart des gens utilisent une extension comme dans le tuto – ce que n’est pas parfait mais bon.

    #2409870
    mathieu42
    Participant
    Maître WordPress
    1317 contributions

    je vois que votre site s’affiche maintenant en passant par « https » donc la 1re étape est faite.

    ensuite la 2de étape est d’aller chercher sur chaque page les éléments qui sont encore en « http ». je ne sais pas s’il existe des extensions qui font ça mais j’ai l’habitude de regarder dans la console de développement du navigateur. par exemple sur la page d’accueil, le navigateur met un avertissement à cause de l’image de fond avec la mer.

    #2409911
    Flobogo
    Modérateur
    Maître WordPress
    18501 contributions

    je vois que votre site s’affiche maintenant en passant par « https » donc la 1re étape est faite.

    Oui, mais fonctionnement incorrect, car la version HTTP co-existe avec la version HTTPS au lieu d’être redirigée. De plus, la version « HTTPS » fait apparaître « index.php » dans les URL.


    @hypnose-arlon
    :

    Prenez votre courage à 2 mains, et suivez cette procédure :

    Par précaution, installez et activez une extension de sauvegarde de base de données comme WP-Optimize. Et faites une sauvegarde de la base de données. (à vous envoyer par mail, ou dans le Cloud si vous avez un compte DropBox par exemple, mais évitez de stocker sur l’hébergement surtout que vous ne savez pas utiliser Filezilla)

    Ensuite, installez et activez l’extension Better Search Replace. Rendez-vous dans le menu correspondants (« Outils », je pense, ou « réglages »). Dans la fenêtre, tapez en haut à gauche l’adresse complète du site avec http://   puis en haut à droite, l’adresse que vous voulez obtenir avec https://  Ensuite, sélectionnez en-dessous toutes les tables de la base de données, puis faites un essai « à blanc » en cochant juste la case du bas. Si l’essai montre des résultats, refaites la même chose sans rien cocher.

    Ensuite, refaites la procédure avec en haut à gauche l’adresse https://www.hypnose-aubange.com/index.php/  et à droite, simplement https://www.hypnose-aubange.com/

    Ne vous déconnectez pas, allez dans le menu des « réglages généraux » et vérifiez votre adresse WordPress. Si elle apparaît bien sans /index.php dans les 2 cases, c’est parfait (sinon, rectifiez) et sauvegardez.

    Déconnectez-vous, et accédez ensuite à nouveau à votre site … logiquement, plus besoin de http et plus de /index.php/ dans l’URL.

    Si ça bugue, revenez le dire, et je vous expliquerai (ou quelqu’un d’autre) comment rectifier dans PhpmyAdmin.

    #2410266
    hypnose.arlon
    Participant
    Initié WordPress
    11 contributions

    Bonjour,

    Tout d’abord, vraiment merci pour votre aide

    Je pense que c’est bon pour le passage en https:// par contre mes pages d’affichent toujours avec /index.php/ malgré la procédure avec Better search replace

    Y a-t-il autre chose à faire ?

    Merci

    #2410276
    ferman
    Participant
    Maître WordPress
    5247 contributions

    Bonjour,

    Regardez dans vos  permaliens  la structure que vous avez définie. Si c’est « structure personnalisée » vérifiez que vous n’avez pas un index.php qui se promène comme ICI. (paragraphe  » the almost pretty permalinks »).

    #2410316
    Flobogo
    Modérateur
    Maître WordPress
    18501 contributions

    C’est souvent l’installation automatique chez OVH qui entraîne cette URL.

    Dans réglages > général, regardez ce qui est indiqué pour l’adresse du site, est-ce qu’il n’y aurait pas ce /index.php/ supplémentaire ? Si oui, supprimez-le.

    Autre piste, comme le conseille @ferman, allez dans le réglage des permaliens, supprimez le /index.php/ .

    Ensuite, utilisez à nouveau l’extension Better Search Replace, avec à gauche, l’adresse suivie de /index.php/ et à droite, l’adresse « normale ».

    Cette fois, ça devrait être bon.

    #2410360
    hypnose.arlon
    Participant
    Initié WordPress
    11 contributions

    Je viens de faire le changement dans permaliens mais je ne sais pas uniquement supprimer /index.php/ dans « personnalisé »

    Je dois choisir une des parmi les réglages courants : simple, date et titre, mois et titre, numérique, titre de la publication ou personnalisé

    Le seul choix qui fonctionne plus ou moins c’est l’option « simple ».  Le problème c’est que certaines pages ne s’affichent plus quand je clique dans le men du site.

    https://www.hypnose-aubange.com/definition/

    et celles qui s’affichent ont un lien de type https://www.hypnose-aubange.com/?page_id=109

    je préfèrerais avec le nom de la page

    Je pense que j’ai essayé tous les choix de type de permaliens mais il y a chaque fois certaines pages voirent toutes qui ne s’affichent plus via le menu

    Désolé mais j’ai encore besoin de votre aide

    merci d’avance

     

     

15 sujets de 1 à 15 (sur un total de 26)
  • Vous devez être connecté pour répondre à ce sujet.