Mes pages ne s’affichent pas. (Créer un compte)

  • Statut : non résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #550932
    T.Cabrera
    Membre
    Initié WordPress
    5 contributions

    Ma configuration WP actuelle
    – Version de WordPress : 4.2.2
    – Version de PHP/MySQL : MySQL5.6.12
    – Thème utilisé : Geekery
    – Extensions en place : Aucun
    – Nom de l’hebergeur : WAMP
    – Adresse du site : Aucun (travail en local le temps du développement)

    Problème(s) rencontré(s) :
    Bonjour à tous,
    je suis totalement nouveau dans WordPress. J’en fais dans le cadre d’un stage, mais je n’y ai pas toucher en cours. Mon problème est le suivant : Quand je créer une page, elle n’est pas trouvable sur le site. Pourtant, la page est bien affiché dans le tableau de bord.
    Je sais que la résolution de se problème peut paraître dérisoire pour certains, mais cela fais 2 heures que je cherche et je n’ai toujours rien trouver.
    Merci d’avances pour vos réponses.

    #1009474
    lorenzolamas
    Participant
    Maître WordPress
    3235 contributions

    Par défaut, une page publiée n’apparait pas forcément dans le menu du site.
    Il faut aller dans Apparence > Menu (créer un menu et ajouter la page) OU cocher “ajouter les nouvelles pages au menu” (ou un truc du style).

    #1009475
    T.Cabrera
    Membre
    Initié WordPress
    5 contributions

    Le problème n’est pas le menu, mes pages sont bien dans le menu. Par contre quand je clique dessus, j’ai une erreur404.

    #1009476
    Flobogo
    Gestionnaire du forum
    Maître WordPress
    17223 contributions

    Bonjour,

    Par contre quand je clique dessus, j’ai une erreur 404.

    Bah, fallait le dire tout de suite 😉

    En effet, dans WAMP, le rewrite_mode n’est pas activé par défaut et c’est ce qui provoque ces erreurs 404.
    –> quand l’icône de WAMP est verte, faites un clic gauche dessus, choisissez “Apache”, puis “Modules Apache”. Une liste s’affiche, cliquez sur la petite flèche noire en bas de liste pour dérouler la suite, et là, cochez “rewrite_module

    Retournez dans l’admin’ WordPress, allez dans Réglages > Permaliens, choisissez le type de liens qui vous convient et enregistrez (même si vous n’avez rien changé) –> cela créera le fichier .htaccess et régénèrera les liens.
    En principe, vous n’aurez plus d’erreur 404. 🙂

    #1009477
    T.Cabrera
    Membre
    Initié WordPress
    5 contributions

    Merci bien, ça m’a tout réglé 🙂 ( mon clavier ne marchai pas, j’ai pas pu vous répondre avant :-( )

    #1009478
    Flobogo
    Gestionnaire du forum
    Maître WordPress
    17223 contributions

    Pas de souci, même si vous mettez 2 jours à donner des nouvelles, c’est bien de revenir dire que ça fonctionne.

    Comme votre topic est résolu, vous pouvez même mettre le smiley correspondant dans votre prochain post, en cliquant sur bt_smilies.png dans la barre d’outils.
    Seul un modérateur peut passer le topic en mode “résolu” mais cela facilite les recherches ultérieures pour ceux qui auraient le même souci.

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.