Mes icônes de réseaux sociaux ne s’affichent pas (Créer un compte)

  • Statut : non résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #510812
    Esbroufe
    Participant
    Initié WordPress
    46 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.3.2
    – Version de PHP/MySQL : PHP 5
    – Thème utilisé : Thème zylyz
    – Extensions en place : All in SEO – Google XML Sitemaps, askimet, contact form 7, Feed burner, Related Post Thumbnails, Shareaholic, WP Cumulus
    – Nom de l’hebergeur : 1&1
    – Adresse du site : http://www.pasbetes.com/

    Bonjour, pour personnaliser mes liens vers les réseaux sociaux avec des icônes, j’ai crée des widgets textes avec du code. Tout marche bien en page d’accueil mais quand je clique sur un article, les images ds réseaux sociaux dans la sidebar ne sont plus visibles, par contre le lien reste visible vu qu’il est tagé. Pourquoi ? Je ne sais pas quoi faire, pourquoi le chemin vers l’image se perd quand on est sur une page article ? Merci de m’aider svp, ce serait gentil.

    #837899
    Theme wordpress francais
    Membre
    Maître WordPress
    687 contributions

    Est ce que tu n’aurais pas plusieurs sibebar ? Genre une pour l’ accueil, une pour les articles ….
    Ou un is_home qui traine avant ton code ?

    #837900
    Anonyme
    Invité
    Maître WordPress
    34067 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #837901
    Esbroufe
    Participant
    Initié WordPress
    46 contributions

    Bonjour, je ne sais pas si j’ai plusieurs sidebar. Mon tableau de bord dans apparence, widgets me met uniquement sidebar et footer donc je pense qu’il n’y en a qu’un. Je pense que ma ligne de code n’est pas bonne ou bien mon adresse d’image. Je vous mets ce que j’ai mis :

    Twitter

    <a href="http://twitter.com/pasbetes" target="_blank"><img width="130" height="94" title="twitter" /></a>

    Rss

    <a href="http://feeds.feedburner.com/pasbetes" target="_blank"><img src="wp-content/themes/Zylyz/images/rsspatte.png"alt="rss" width="87" height="92" title="rss"/

    Je m’arrache les cheveux sur ce truc d’autant plus que mon module facebook lui s’affiche très bien en page d’accueil et sur les articles…

    #837902
    Guy
    Participant
    Maître WordPress
    14817 contributions

    C’est le chemin vers les images qui pose probleme. Tu devrais mettre le chemin absolu:

    http://www.pasbetes.com/wp-content/themes/Zylyz/images/rsspatte.png

    par exemple

    #837903
    Esbroufe
    Participant
    Initié WordPress
    46 contributions

    C’est super, merci ça marche… Mais j’ai pas compris, ça n’est pas la première fois que je fais une erreur d’adrese d’image, je ne connais pas la différence entre url absolue et relative, enfin pas exactement et du coup je ne sais pas comment écrire mes adresses.

    #837904
    Guy
    Participant
    Maître WordPress
    14817 contributions

    Url absolue: il n’y a pas d’erreur possible, tu mets l’adresse complète avec le http et tout et tout.
    – Avantage, si l’adresse est bonne elle fonctionnera toujours pour le site concerné
    – Inconvénient, si tu veux transférer ou adapter à un autre site, il faut vérifier et modifier dans les fichiers tout ce qui concernait l’ancien site.

    Url relative: l’adresse est relative à l’endroit où tu appelles la fonction. Pour ton exemple, quand tu appelais dans la home, ton url était celle de ton site, donc tonsite/wp-content/etc… était une adresse valide. Lorsque tu étais dans une page tonsite/tapage/wp-content/etc… devenait une adresse invalide.

    Pour les url absolues, normalement le point peut représenter la racine du site, ce qui veut dire qu’au lieu de mettre « http://tonsite/wp-content/etc.. » il est probable que mettre « ./wp-content/etc… » aurait suffit.

    #837898
    Esbroufe
    Participant
    Initié WordPress
    46 contributions

    Merci, je me suis faite une petite note avec ce que tu as écrit. Problème résolu, on peut clore ✅

8 sujets de 1 à 8 (sur un total de 8)
  • Le sujet ‘Mes icônes de réseaux sociaux ne s’affichent pas’ est fermé à de nouvelles réponses.