MàJ manuelle: pb avec détails de connexion base de données (Créer un compte)

  • WordPress :5.4
  • Statut : non résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2356285
    cecilio93
    Participant
    Initié WordPress
    3 contributions

    Bonjour,
    Ce matin en voulant me connecter à mon wp-admin de mon site web, j’ai eu ce message:

    <b>Warning</b>: Illegal string offset ‘remember’ in <b>/homepages/23/d148769640/htdocs/clickandbuilds/MonBlog/wp-includes/user.php</b> on line <b>41</b>

    <b>Warning</b>: Cannot assign an empty string to a string offset in <b>/homepages/23/d148769640/htdocs/clickandbuilds/MonBlog/wp-includes/user.php</b> on line <b>41</b>

    <b>Warning</b>: Illegal string offset ‘user_login’ in <b>/homepages/23/d148769640/htdocs/clickandbuilds/MonBlog/wp-includes/user.php</b> on line <b>56</b>

    <b>Fatal error</b>: Uncaught Error: Cannot create references to/from string offsets in /homepages/23/d148769640/htdocs/clickandbuilds/MonBlog/wp-includes/user.php:56 Stack trace: #0 /homepages/23/d148769640/htdocs/clickandbuilds/MonBlog/wp-login.php(806): wp_signon(”, ”) #1 {main} thrown in <b>/homepages/23/d148769640/htdocs/clickandbuilds/MonBlog/wp-includes/user.php</b> on line <b>56</b>

    On m’a signalé que c’était peut-être une tentative de piratage.

    En faisant quelques recherches, je suis tombée sur ce blog qui a eu le problème similaire et qui a réussi à le régler en faisant une mise à jour manuelle.
    Je décide donc de m’y atteler. (Je précise, je ne mets jamais vraiment les mains dans le cambouis, c’est ma première fois.)

    J’ai donc fais une sauvegarde de mon wordpress + de ma base de données et suivi le process pour la mise à jour. MAIS au moment de refresh ma page, je tombe sur une page me demandant d’entrer les détails de connexion de ma base de données.
    On me demande: “Nom de la base de données, Idantifiant, Mot de passe, Adresse de la base de données, Préfixe des tables.”

    Me voilà décontenancée, ce n’est pas indiqué sur le blog cité plus haut. Je fais donc encore quelques recherchers, et voilà le chemin que j’ai réalisé pour le moment:

    1/ Je tente, d’abord, sur Ionos, de changer le mot de passe de ma base de données. Je le modifie, puis je tente de remplir les cases ensuite avec ce nouveau mot de passe: ça ne fonctionne pas.

    2/ Dans ma sauvegarde, je me rends compte que j’ai un fichier wp-config.php, mais que je ne l’ai pas conservé sur mon serveur FTP lors de ma mise à jour. Je l’ouvre et je trouve les infos que je dois, si je comprends bien, mettre dans les cases “Nom de la base de données, Idantifiant, Mot de passe, Adresse de la base de données, Préfixe des tables.”

    3/ Je le glisse à la racine de mon serveur ftp, en me disant que ça va résoudre le problème.

    Seulement là, je m’aperçois que le mot de passe qui se trouve dans mon fichier wp-config.php n’est plus le même que celui de ma base de données, puisque comme j’ai indiqué en 1/, j’ai changé le mot de passe sur Ionos! Quand je souhaite maintenant faire concorder les deux, ça ne marche pas non plus.

    4/ Je suis allée voir là-dessus: https://codex.wordpress.org/fr:Details_de_mise_a_jour
    Sur cette page, on me parle du fichier .htaccess, robots.txt, wp-images, comme quoi je dois les conserver. C’est noté en rouge alors je suppose que c’est extrêmement important! Hors, je ne les ai pas dans ma sauvegarde, ni dans les fichiers issus de la dernière version wordpress. Après quelques recherches sur le .htaccess, je ne sais pas si je l’ai supprimé en cours de route par erreur, ou s’il a toujours été absent de mes fichiers wordpress.

    Je précise en passant que j’ai désactivé mes plugins via mon serveur FTP en renommant le fichier plugins par plugins_old.

    Savez-vous comment je dois procéder maintenant?
    Merci!

    #2356310
    ferman
    Participant
    Maître WordPress
    3022 contributions

    Bonjour,

    3/ remettez chez l’hébergeur le mot de passe de la base de données de wp-config (ou m’opération inverse). Si ça ne marche pas, il y a un autre problème.

    4/ pour .htaccess, ce n’est pas grave , wordpress en récréera un (minimum).

    La mise à jour a-t-elle  réglé votre premier problème (les messages)?

    Je ne vois pas de page wp-admin: vous avez une extension qui déplace la page de connection mais bon comme tous vos plugins sont désactivés?  Quels sont ces plugins d’ailleurs?

    Un autre problème potentiel: vous avez la version 1.3 de votre thème et ils en sont à la version 2.4.1. Vous n’avez pas fait de mise à jour depuis longtemps. Je ne pense pas que votre thème soit compatible avec la version de wordpress 5.5.1 que vous utilisez.

    #2356346
    Flobogo
    Modérateur
    Maître WordPress
    16344 contributions

    Bonjour,

    En effet, si le thème a besoin d’une mise à jour, il faut la faire, surtout si ça n’est pas le cas depuis longtemps. Il est conseillé de la faire progressivement, avec versions intermédiaires.

    Et si votre problème est résolu, merci de l’indiquer en modifiant l’état de votre demande, en haut à gauche (au-dessus du titre de topic)

    #2356375
    PhiLyon
    Modérateur
    Maître WordPress
    26590 contributions

    Bonjour.

    Il est conseillé de la faire progressivement, avec versions intermédiaires.

    Euh, pas évident de retrouver les versions intermédiaires…

    🙂

    #2356941
    Flobogo
    Modérateur
    Maître WordPress
    16344 contributions

    Je ne sais plus trop comment on y accède, en effet. Peut-être là : https://themes.svn.wordpress.org/nom-du-theme

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.