Màj 2.7: connexion admin devenue impossible (Créer un compte)

  • Statut : non résolu
9 sujets de 31 à 39 (sur un total de 39)
  • Auteur
    Messages
  • #653612
    WP-Remi
    Membre
    Maître WordPress
    538 contributions

    Perso, j’ai supprimé le fichier fr_FR.php du dossier languages et tout refonctionne. Est-ce que ce fichier est nécessaire ? Sans lui, je n’ai pas eu de problèmes sur mon WordPress.

    Dios-je le remettre et désactiver wp-db-backup ou je peux continuer avec cette bidouille en attendant la mise à jour de wp-db-backup ?

    Merci d’avance pour la réponse.

    #653593
    Marc-OH
    Participant
    Chevalier WordPress
    253 contributions

    Bonjour à vous tous ! (je poste dans ce sujet car mon problème regroupe à peu près tous les problèmes que vous avez évoqués…)

    Alors je suis confronté à un problème de taille plutôt handicapant… Je vous explique tout ce qui s’est passé :
    – J’ai fais ma mise à jour vers wordpress 2.7, pas de problèmes
    – J’ai voulu activer nextgen-galleriy > “erreur 500”
    – J’ai ensuite viré le fichier de lang FR > pas de changement, toujours l’erreur 500…
    – J’ai ensuite désactivé wp–db-backup > erreur 500
    – Et maintenant quand je veux aller sur mon admin > erreur 500 donc plus d’accès à l’admin…

    Comment régler ce problème au plus vite ? Je fais vraiment appelle à vous là :p

    EDIT : problème reglé mais je ne sais pas comment j’ai fais…

    #653613
    florent522
    Participant
    Initié WordPress
    45 contributions

    tu as réussit a faire marcher wp-backup ?

    #653614
    Marc-OH
    Participant
    Chevalier WordPress
    253 contributions

    Non wp-db-backup, je n’y touche plus ! 😋

    J’ai localisé l’erreur sur mon blog elle vient bien du fichier lang fr_FR. Vous savez si il existe un correctif ? (au moins pour que les dates de mes posts soient affichés en français…)

    #653615
    antoine33
    Participant
    Initié WordPress
    16 contributions

    salut

    j ai eu le meme souci que vous

    j ai supprime le dossier et le contenu du plugin backup
    et j ai pu acceder a ma console

    😉😉😉😉

    #653616
    FascinantJapon
    Participant
    Initié WordPress
    37 contributions

    J’ai deja mis ca dans http://www.wordpress-fr.net/support/sujet-20746-php mais pour les gros faignants (comme moi), je le post aussi ici.✅

    Bon, bien que Supporter ait deja donné la plus grande partie, voire toute la solution, voila ce que j’ai fait:

    1. Récupérer les fichiers wp/wp-config.php et wp/wp-content/languages/fr_FR.php (adapter le chemin à votre installation si besoin)
    2. Aller à l’adresse suivante: http://api.wordpress.org/secret-key/1.1/ et copier les 4 clés générées
    3. Les coller dans wp-config.php comme ci-dessous:
    cle-config.jpg
    4. Ouvrir le fichier fr_FR.php et remplir la clé avec l’une des quatre déjà générée ou alors avec une nouvelle clé:
    cle-francais.jpg
    5. Recharger les 2 fichiers par ftp dans les bons dossiers

    Voila. Maintenant, le backup de la base de données, ainsi que l’envoi par email en cliquant sur le bouton ou a heure fixe marche. De la même manière, l’extension wordbook qui ne marchait plus, remarche.

    #653617
    redb
    Membre
    Initié WordPress
    18 contributions

    LA solution pour tout les plugin qui buggue à l’install. MERCI
    Personnellement j’ai désactivé les droit d’écriture sur le dossier /wp-content/languages

    #653618
    FascinantJapon
    Participant
    Initié WordPress
    37 contributions

    ATTENTION!
    Pour une info complete sur ces problemes de cles (et plus), voir le post de Supporter en sticky à l’adresse: http://www.wordpress-fr.net/support/sujet-21204-compatibilite-wordpress-resume
    Notamment, la cle exacte à mettre dans le fichier fr_FR.php.

    #653619
    funstyler
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Comment installer une nouvelle version de WordPress (3.1) sans avoir les problème de « Vous n’avez pas les droits suffisants pour accéder à cette page » ?

    Bah après bien des galères voici comment j’y suis arrivé sans rien perdre de mon travail de près de 10 ans sur le WEB :

    Sur votre disque local, créez un dossier « SAUVEGARDE de mon SITE »
    AVEC votre outils FTP préféré :
    • Allez sur le serveur où se trouve votre site puis, sauvegardez sur le disque local dans le dossier « SAUVEGARDE de mon SITE » tous les fichiers, dossiers et sous dossiers de votre site (Pour le cas où il faille revenir en arrière)
    Avec PHPMyAdmin :
    • Renommez toutes les tables de votre base en ajoutant par exemple OLD_ en préfixe de ces dernières.
    • Exportez la base en entier dans un sous-dossier de « SAUVEGARDE de mon SITE » nommé « sauvegarde_BDD_Mon_site »
    AVEC votre outils FTP préféré :
    • Retournez sur le serveurs de votre site et virez tous les fichiers, dossiers et sous dossiers
    • Installez les nouveau fichiers, dossiers et sours dossiers de la nouvelle versions de votre site.
    • Repalcez au même endroit les plugins,les extension, et les dossiers (et sous-dossiers) d’images et autres documents.
    Avec votre navigateur préféré :
    • Lancer l’installation de votre site nouvelle version.
    • De ce fait créez la base de données et ses tables avec les anciens noms de tables
    • Une fois le site installé laissez en l’état pour l’instant
    Avec PHPMyAdmin :
    • Faite les operations qui vont suivre pour toutes les tables sauf pour ces trois là : OLD_wp_usermeta ; OLD_wp_user ; OLD_wp_options
    • Sélectionnez une table puis cliquez sur Opérations
    • Dans la partie Copier la table vers (base.table) : écrivez dans le champs le nom de la nouvelle table correspondante
    • choisissez « structure et données »,
    • cochez toutes les options « Ajouter DROP TABLE » ; « Inclure la valeur courante de l’AUTO_INCREMENT » ; « Aller à la table copiée »
    • cliquez sur executer
    retournez sur votre site avec votre navigateur et entrez avec le loggin admin et son password.
    Normalement vous entrez sur votre console. Recréez les utilisateurs avec leur rôles et password si vous êtes pusieurs à utiliser votre site et voilà…
    Normalement tout baigne !

    Une chose encore : avec la version 3.1 de WordPress on a parfois un message d’erreur de ce type : “Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1474560 bytes) in /wp-includes/class-simplepie.php on line 4852” ; Il vient d’un bug avec les fichier de langue française ! Allez dans le dossier wp-content/languages où vous trouverez 6 fichiers : continents-cities-fr_FR.mo ; continents-cities-fr_FR.po ; fr_FR.mo : fr_FR.po ; ms-fr_FR.mo ; ms-fr_FR.po

    Virez les (ou renommez les) et les choses rentrent dans l’ordre …

    Voilà j’espère que j’ai aidé un grand nombre d’entre vous…. Cordialement JG

9 sujets de 31 à 39 (sur un total de 39)
  • Vous devez être connecté pour répondre à ce sujet.