[Résolu] login wp non reconnue + pb http error 500 (Créer un compte)

  • WordPress :6.4
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 17)
  • Auteur
    Messages
  • #2466841
    DonkeyCom
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    Ma configuration WP actuelle

    • WordPress version 5.8.8
      Thème actuel : Divi (version 4.13.1)
      Extension actuelle : Cookie Notice & Compliance for GDPR / CCPA (version 2.4.12)
      PHP version 8.0.30
    • Nom de l’hébergeur :  O2switch
    • Adresse du site : http://www.sud-donkeygarage.fr

    Problème(s) rencontré(s) : impossible de me connecter à la page login de wordpress

    <!– wp:paragraph –>
    <p class= » »>bonjour à tous, je sollicite grandement votre aide svp. J’ai créé ce site en 2020 avec des identifiants en accord avec ce site. Depuis novembre 2023 mon site est planté. A première vue je pense qu’il s’agissait d’une mise à jour d’une extension.</p>
    <!– /wp:paragraph –> <!– wp:paragraph –>
    <p class= » »>Détails de l’erreur
    ======================
    Une erreur de type E_ERROR a été causée dans la ligne 46 du fichier /home/enal4091/public_html/wp-content/plugins/cookie-notice/includes/modules/wp-fastest-cache/wp-fastest-cache.php. Message d’erreur : Uncaught ArgumentCountError: Too few arguments to function Cookie_Notice_Modules_WPFastestCache::delete_cache(), 0 passed in /home/enal4091/public_html/wp-content/plugins/cookie-notice/includes/modules/wp-fastest-cache/wp-fastest-cache.php on line 34 and exactly 1 expected in /home/enal4091/public_html/wp-content/plugins/cookie-notice/includes/modules/wp-fastest-cache/wp-fastest-cache.php:46</p>
    <!– /wp:paragraph –> <!– wp:paragraph –>
    <p class= » »>J’ai donc voulu me connecter comme d’habitude afin d’accéder à mon tb de bord wordpress. Mais là c’est l’echec, il ne reconnait plus mon adresse mail… alors j’ai essayé de modifier le mot de passe en passant par C panel… mais toujours le même problème :lorsque je me position sur la page de connexion à wordpress, ce dernier me dit qu’il ne me reconnait pas. (la piste mot de passe oublié a aussi été explorer) je ne comprend pas.. c’est comme si wordpress avait supprimé mon compte…Je me suis rapproché de O2switch, mais ils me disent que cela ne vient pas d’eux mais de l’éditeur WP Fastest cache.</p>
    Comment faire pour accéder à nouveau a mon tb de bord WP ?

    <!– /wp:paragraph –> <!– wp:paragraph –>
    <p class= » »>Bref maintenant j’ai la magnifique page HTTP ERROR 500</p>
    Je vous remercie d’avance de toutes l’aide que pourrez tous m’apporter…

    <!– /wp:paragraph –>

    #2466845
    Li-An
    Participant
    Maître WordPress
    28376 contributions

    Bonjour. Allez par FTP au niveau du répertoire wp-content/plugins et changez son nom en pluginsxxx pour désactiver toutes les extensions. Même chose pour le thème dans wp-content/themes/nom-du-theme. Et réessayez.
    Pour retrouver les extensions et le thème, il suffira de remettre les noms par défaut des répertoires.

    #2466847
    ferman
    Participant
    Maître WordPress
    6936 contributions

    Bonjour,

    Votre site ne semble pas (plus?) être en erreur 500. C’est un problème avec la version 2.4.12 de Cookie Notice & Compliance. Il faut mettre à jour vers la version 2.4.13.  Il faudra d’abord désactiver le plugin. Si vous n’avez pas accès à votre administration, c’est possible au choix soit par ftp (en renommant le dossier du plugin « nom-du-dossier-OLD », puis revenant à « nom-du-dossier »), soit à partir de la base de données du site.   Vous aurez alors normalement accès à votre administration et pourrez mettre à jour l’extension ce qui devrait régler le problème.

    #2466849
    DonkeyCom
    Participant
    Initié WordPress
    8 contributions

    un grand merci pour vos réponses, je viens de faire les modifs dans le gestionnaires  de fichiers de la base de donnée de Cpanel voir captures. (Je m’excuse vraiment  de vous solliciter, cela peut vous paraitre simple mais là je n’ai vraiment plus l’acces à mon tb bord. WordPress ne reconnait plus mon adresse mail. je me sens perdu ! C’est la première fois que cela m’arrive..ca sert de lecons me direz vous….  Une fois renommer en …-…..-OLD si je relance le site ou la page login de wp il ne me reconnait tjs pas et le site affiche tjs une erreur http 500

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2466854
    Flobogo
    Modérateur
    Maître WordPress
    20080 contributions

    Bonjour,

    La désactivation de l’extension (« plugin« , en anglais) ne suffit pas. Il faut aussi désactiver wp-fastest-cache en renommant le dossier avec -OLD lui aussi.

    Et regarder si vous avez un dossier « cache » dans wp-content > uploads ou dans wp-content > mu-plugins : si vous trouvez un dossier avec le mot « cache« , videz-le.

    Enfin, dans le dossier wp-content > themes, renommez normalement (sans -OLD) le thème twenty-twenty-one. Il fallait renommer uniquement votre thème courant Divi.

     

    #2466855
    ferman
    Participant
    Maître WordPress
    6936 contributions

    Où voyez vous cette erreur 500. Je vois seulement que la page wp-admin est redirigée vers une page 404. Dans vos extensions vous n’en auriez pas une de sécurité ? Puisque désactiver Cookie Notice & Compliance ne suffit pas, faites ce que vous disait Li-An. Renommez tout le dossier plugins en plugins-old pour désactiver e bloc toutes les extensions et réessayez d’entrer dans votre admin.

    #2466858
    Flobogo
    Modérateur
    Maître WordPress
    20080 contributions

    Le dossier wp-content > mu-plugins contient probablement une extension de sécurité. Mais avant de le désactiver, montrez-nous quand même le contenu de ce dossier mu-plugins.

    #2466888
    DonkeyCom
    Participant
    Initié WordPress
    8 contributions

    bonjour,

    un grand merci à tous pour vos contributions et votre aide. Voici le contenu du fichier cache et du fichier mu-plugin. Je vois aussi que j’ai 2 fichiers concernant cache : il y a Cache contenant 2 sous fichiers « tmp Wpfc » celui est vide + « Wpfc Minified » qui lui par contre est rempli de 20 sous fichiers arrêté au 20.11.2023 (date à laquelle le site à du planté) + 23 sous fichiers datant d’hier. Apres il y a et-cache … du coup je n’ose pas supprimer quoique ce soit , faut il vraiment tout supprimer ?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2466891
    DonkeyCom
    Participant
    Initié WordPress
    8 contributions

    J’ajoute aussi ces 2 captures pour vous montrer le contenu de Plugin et de wp-fastest-cache.


    @ferman
    : Où voyez vous cette erreur 500. –>  L’erreur 500 s’affiche lors de la recherche ci joint la capture.

    Je vois seulement que la page wp-admin est redirigée vers une page 404. Dans vos extensions vous n’en auriez pas une de sécurité ? –> Là par contre je ne sais pas du tout ou je peux trouver ca ?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2466898
    ferman
    Participant
    Maître WordPress
    6936 contributions

    Vous avez une extension de sécurité: wps hide login. Il y a des chances qu’elle soit à la base du problème. Désactivez-là (renommez-la en wps-hide-login-OLD).

    #2466900
    DonkeyCom
    Participant
    Initié WordPress
    8 contributions

    VICTOIRE !!!!!!!!!! Vous êtes mon sauveur, mon génie 🙂 mon magicien !!! Je viens de faire la manip : j’ai renommé le plugin en « wps-hide-login-OLD » ! j’ai relancé mon site et là : tandamm la page d’accueil se lance ! un grand merci ! ==> Du coup, il faudrait que je supprime ce plugin ? je ne le réactive pas. Je peux le laisser en OLD comme ca ?

    Concernant les caches : est ce que cela mériterait que je vide un peu ? ou pas nécessairement ? A partir de quel moment on peut juger nécessaire de vider le fichier cache ?

    Maintenant je vais voir mon 2e problème : l’accès au login wp qui ne reconnaissait pas mon mail pour pouvoir retrouver mon tb de bord et mon divi builder.

    • Cette réponse a été modifiée le il y a 2 mois et 3 semaines par DonkeyCom. Raison: questions ajoutées
    #2466901
    Li-An
    Participant
    Maître WordPress
    28376 contributions

    Encore une preuve que ce type d’extension n’est pas recommandable – Les extensions de sécurité que je conseille : Ninja Firewall (léger sur le site), SecuPress (français) et Wordfence (la plus populaire) cf mon billet https://www.echodesplugins.li-an.fr/plugins/un-wordpress-vraiment-protege/.

    Si vous aviez réalisé la manip que j’ai indiqué en première réponse, vous n’auriez pas autant galéré.

    #2466904
    DonkeyCom
    Participant
    Initié WordPress
    8 contributions

    ca sert d’expérience c’est certain…. Merci encore pour votre aide.

    Je prend bonne note de ces extensions de securité. j’avais laissé un peu ce site à l’abandon, je vais m’y replonger un peu dedans.

    • Cette réponse a été modifiée le il y a 2 mois et 3 semaines par DonkeyCom.
    #2466907
    ferman
    Participant
    Maître WordPress
    6936 contributions

    Et si je peux me permettre: voila pourquoi on recommande fortement d’ajouter aux demandes d’aide la liste complète des extensions actives. Cela permet de cerner le problème rapidement et souvent de gagner un temps fou (pour vous et pour nous). Là je l’ai vu par hasard dans une de vos copies d’écran.

    je ne le réactive pas. Je peux le laisser en OLD comme ca ?

    Si vous ne le réactivez pas il faut le supprimer. Si vous souhaitez le réactiver, maintenant que vous êtes dans votre administration, vous pouvez le faire, vous ne serez pas éjecté de l’administration. Il faudra alors regarder les réglages du plugin et le reparamétrer. Vérifier que vous n’êtes pas sur une liste noire et si oui, effacer.  Ne quittez pas votre admin sans l’avoir fait sans cela vous ne pourrez pas rentrer (il faudrait alors  re-désactiver wps-hide-login …etc) .Vous devez aussi enlever tous les « old » que vous avez mis dans vos dossiers (thèmes et extensions) et mettre à jour cookie notice.

     

    • Cette réponse a été modifiée le il y a 2 mois et 3 semaines par ferman.
    #2466910
    DonkeyCom
    Participant
    Initié WordPress
    8 contributions

    J’ai suivi pas à pas tous vos précieux conseils :

    J’ai supprimé : wps-hide-login

    J’ai remis correctement les fichiers nommé OLD

    J’ai installé Secupress et là je me rend compte qu’il faut que je fasse pas mal de modifs j’ai donc supprimé aussi Wp cerber security qui n’est pas compatible avec… et je vais continuer à faire toutes mes petites modifs.

    Merci à tous, je vais reprendre ma veille….;)

15 sujets de 1 à 15 (sur un total de 17)
  • Vous devez être connecté pour répondre à ce sujet.